SMALL - espritmodel.com SMALL - Telemetry SMALL - Radio
Reply
Thread Tools
Old Nov 23, 2004, 10:44 AM
Registered User
Shadrack's Avatar
Winnipeg
Joined Feb 2002
5,851 Posts
Horrible Losi Support.

I purchased the Mini T when it came out, and of course, the bearings, batteries, and shocks. Well imagine my surprise at how badly the shocks leaked, using extra seals, etc. I contacted Losi at that time and was told they were aware of a problem and would be sending out something to fix it. Nothing. Here we are months and months later, and I have been sending them email asking about this, and I don't even get a response. I have 4 shocks that are useless, I'm out that money, and now I don't even get responded to by Losi. Horrible support. They could learn a lesson from Castle Creations on how support should work. And Castle sent me a replacement speed control to fix one that they knew was bad, little more of a customer investment than proper shocks. I will never buy a Losi product again because they don't stand behind their mistakes.
Shadrack is offline Find More Posts by Shadrack
Reply With Quote
Sign up now
to remove ads between posts
Old Jan 09, 2005, 04:36 PM
Registered User
Joined Jan 2005
13 Posts
dont talk about losi like that losi rocks but awre of this problem i bought gpm shocks for 15.00 of ebay brand new from hong kong
joshrchobbies is offline Find More Posts by joshrchobbies
Reply With Quote
Old Jan 09, 2005, 05:52 PM
Registered User
Shadrack's Avatar
Winnipeg
Joined Feb 2002
5,851 Posts
A company that "Rocks" doesn't take it's customers money, and then ignore product support on something they know is defective. When Castle Creation gave me support, they had the replacement product in the mail that day. I like the mini-t, but the shocks suck, and they knew it when they put them out. Check other peoples compaints on here.
Shadrack is offline Find More Posts by Shadrack
Reply With Quote
Old Feb 09, 2005, 10:16 AM
Vtol Builder
Lewist's Avatar
High Wycombe, Great Britain (UK)
Joined Jul 2004
997 Posts
I have never had a problem with leaking shocks, after a few months the rears get a LITTLE air in them but i do mean a little, but the fronts still have the origional oil in them that i put in there about 12 - 18 months ago (can't remember when i got the little bugger!)

Must have been lucky
Lewist is offline Find More Posts by Lewist
Reply With Quote
Old Feb 09, 2005, 12:15 PM
Registered User
Shadrack's Avatar
Winnipeg
Joined Feb 2002
5,851 Posts
My big issue is that they said they would send me some new seals, and after repeated emails, I just gave up. That is what bothered me, is that they knew that there was an issue, they said they would fix it, and then didn't follow through.
Shadrack is offline Find More Posts by Shadrack
Reply With Quote
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Think twice about Losi Support Shadrack Vendor Talk 0 Nov 23, 2004 10:46 AM