SMALL - espritmodel.com SMALL - Telemetry SMALL - Radio
Reply
Thread Tools
Old Sep 29, 2004, 01:12 PM
Girls? RC? School?
Phoenix, AZ 85017
Joined Sep 2004
187 Posts
Problems with first flight on Hummingbird.

Ok, I was trying to fly it today but I have two problems.

1- At full throttle it barely lifts off the ground. I've tried running it with a higher headspeed and less pitch and vise-versa. Neither one helps. It's got 3 GWS servos, 2 GWS ICS300 speed controls, GWS PG-03 gyro, GWS 6 channell micro receiver, the stock hb 370 motor, and a 9.6V bird seed battery. I'm using the fully symetrical wood blades.

2- When I give it forward elevator it rolls left more than it pitches forward. When I give back elevator it rolls right more than it pitches back. I can't figure this out. What could cause this?

Edit: BTW: I am using an RD6000 Super TX.

Thanks
falcon247 is offline Find More Posts by falcon247
Last edited by falcon247; Sep 29, 2004 at 01:35 PM.
Reply With Quote
Sign up now
to remove ads between posts
Old Sep 29, 2004, 01:24 PM
Blade Springs "Rock"
Central Coast, CA
Joined Apr 2004
2,141 Posts
I may not be able to help, but you are using fully symetrical blades on a fixed pitch rotor....??? I didn't think the hummingbird was collective pitch....???


Sorry, my mistake, elite version????

G.
Geoffrey109 is offline Find More Posts by Geoffrey109
Reply With Quote
Old Sep 29, 2004, 01:31 PM
Girls? RC? School?
Phoenix, AZ 85017
Joined Sep 2004
187 Posts
Yes, it is the Elite CP. The blades are flat on the bottom and curved on top. I know in planes this is called flat bottom wing like on trainers. The package said fully sym. though so I assume this is what they call fully sym. in blades?
falcon247 is offline Find More Posts by falcon247
Reply With Quote
Old Sep 29, 2004, 02:00 PM
Life-One flight at a time
HBirdV.2's Avatar
B.C Canada
Joined Jul 2004
466 Posts
Check and see if the servos are moving in the mount I had that problem on my FP.
HBirdV.2 is offline Find More Posts by HBirdV.2
Reply With Quote
Old Sep 29, 2004, 02:17 PM
HeliNewbie
cupid4600's Avatar
Alberta
Joined Aug 2004
193 Posts
Make sure that the servos are connected to the correct channels on the Rx. Also, on the Tx, check its set to 120 deg. CCPM.

Mine had some minor setup problems but it flies like a charm. Enjoy!
cupid4600 is offline Find More Posts by cupid4600
Reply With Quote
Old Sep 29, 2004, 02:24 PM
Girls? RC? School?
Phoenix, AZ 85017
Joined Sep 2004
187 Posts
HBirdV.2- The servos are mounted right and arn't moving.

cupid4600- All the servos are plugged in right and everything moves in the right direction. When I look at the swashplate everything seems to move proportionatly but when I give it elevator input it either rolls alot more than than pitch. The radio has normal, 90 degree, and 3 120 degree CCPM mixes. I have it set on the right one and like I said above everything looks like it moves right. It just has the weird roll problem and it just barely comes off the floor at full throttle.

I'm still messing with the pitch and throttle curves but I'm pretty much lost here.
falcon247 is offline Find More Posts by falcon247
Reply With Quote
Old Sep 29, 2004, 03:37 PM
Registered User
Melbourne Australia
Joined May 2003
5,263 Posts
Quote:
Originally Posted by falcon247
1- At full throttle it barely lifts off the ground. I've tried running it with a higher headspeed and less pitch and vise-versa.
2-
what about if you give it more headspeed and more pitch ? It seems that you are cancelling one out with the other.
OzzieFlyer is offline Find More Posts by OzzieFlyer
Reply With Quote
Old Sep 29, 2004, 03:54 PM
Girls? RC? School?
Phoenix, AZ 85017
Joined Sep 2004
187 Posts
Well I've always had it at full throttle but I meant that I would reduce the pitch trying to get more headspeed hoping that it would cause it to have a little better lift. Right now I am using it with the max amount of pitch and throttle. It lifts off but slowly and it seems to lift even slower the farther from the ground it gets. The highest I've gotten it is about a foot. I don't know how much higher it will go after that I havn't tried yet. I've hear of some people cutting .5" off each blade. Is this what I should do?

Though it dosn't get off the ground easily it does get up so I am just bouncing around on the floor. lol Little 3 second flights.

Thanks
falcon247 is offline Find More Posts by falcon247
Reply With Quote
Old Sep 29, 2004, 04:02 PM
Registered User
Melbourne Australia
Joined May 2003
5,263 Posts
what cells are you using ? 2 or 3..and what brand
what is the headspeed ?
how much pitch do you have at full collective ?
can you select a higher %mix on your pitch in your ccpm setup ?

Just some things I can thing of that might be causing this

You shouldnt need full collective and 100% throttle to lift off. (but I guess you know that already )
OzzieFlyer is offline Find More Posts by OzzieFlyer
Reply With Quote
Old Sep 29, 2004, 04:35 PM
Girls? RC? School?
Phoenix, AZ 85017
Joined Sep 2004
187 Posts
I'm using a 8cell AAA pack(like the 9.6v bird seed). I have a 3s1p LiPo coming but I expected it to be able to fly with the stock setup.

I don't have a tachometer so I don't know the headspeed.

I also don't have a pitch guage(I have been eyeballing it) but it has a good deal of pitch with the swashplate all the way up. Eyeballing it I would guess 20 degrees. I've tried reducing this too but it makes it worse.

I've tried lots of different pitch and throttle curves(I have 5 of each) but it dosn't get any better.

Where can I get a pitch guage and about how much are they?

Thanks
falcon247 is offline Find More Posts by falcon247
Reply With Quote
Old Sep 29, 2004, 04:39 PM
Girls? RC? School?
Phoenix, AZ 85017
Joined Sep 2004
187 Posts
As far as adjusting the pitch to get them both same I have to adjust one link all the way down and the other a few turns out. I thought they should be the same but if I adjust them like that then the pitch is not the same from blade to blade. Could this have anything to do with it?

Also it seems like my revo mixing is constantly changing too. One minute the tail rotor will be spinning when the throttle is all the way down the next it won't spin untill I get to full throttle. Could this be a gyro problem? I had it all set up fine on the turntable but now the setting seems to drift significantly.
falcon247 is offline Find More Posts by falcon247
Reply With Quote
Old Sep 30, 2004, 01:07 AM
Girls? RC? School?
Phoenix, AZ 85017
Joined Sep 2004
187 Posts
This thing has damaged my ego. lol I can only hover for about 3 seconds at about 8 or 9 inches before it starts slipping sideways forward. It sure pulls real bad to the left on takeoff even with extra trim to the right. I know this is normal but it is very annoying.

Any ideas on how to keep the revo settings consistent? Maybe my gyro gain is too high?
falcon247 is offline Find More Posts by falcon247
Reply With Quote
Old Sep 30, 2004, 01:13 AM
Registered User
Auckland, New Zealand
Joined Sep 2004
7 Posts
It sounds to me like the cyclic phasing is out between the swashplate inner race and the blade grips, When you look down onto the heli from above are you getting exactly 90 degrees btween inner race ball link and the blade grip ball link? I hope this makes sense?
Helikiwi is offline Find More Posts by Helikiwi
Reply With Quote
Old Sep 30, 2004, 01:29 AM
Registered User
Auckland, New Zealand
Joined Sep 2004
7 Posts
About your weird cyclic,It sounds to me like the cyclic phasing is out between the swashplate inner race and the blade grips, When you look down onto the heli from above are you getting exactly 90 degrees btween inner race ball link and the blade grip ball link? I hope this makes sense?
Helikiwi is offline Find More Posts by Helikiwi
Reply With Quote
Old Sep 30, 2004, 07:26 AM
United States, MI, Goodrich
Joined Mar 2004
3,846 Posts
...
UAVProducts is offline Find More Posts by UAVProducts
Site Sponsor
Last edited by UAVProducts; Sep 30, 2004 at 09:48 AM.
Reply With Quote
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
First flight on Slow Stick with geared 400 Flybyguy Foamies (Kits) 8 Jul 29, 2003 12:54 PM
Charging problems with new flight pack ChrisP Power Systems 3 Jun 08, 2001 03:35 PM
First flight on Seledkin - Something fishy JeffD Electric Sailplanes 3 May 22, 2001 09:09 AM
First Flight on an A-7 Megowcoupe Electric Ducted Fan Jet Talk 10 May 21, 2001 09:36 PM
first flight on twinjet marcusg Foamies (Kits) 11 May 10, 2001 11:54 PM