HobbyKing.com New Products Flash Sale
Reply
Thread Tools
Old Apr 04, 2004, 06:49 AM
I'd rather be Flying
davecee's Avatar
Nashville, NC, USA
Joined Mar 1999
2,707 Posts
Phoenix-60, fried first day out.

Here's the set-up.
Phoenix-60, Mega 22/30/2, geared 5/1, 20 GP3300's, APC-E 15/8 prop, BEC is properly disabled. E-Calc predicts about 40 amps static.
Flew the system yesterday for the first time at a fly-in. The ESC had only been powered up prior to this to program the LVC and a very short (less than 10 seconds) partial throttle run up just to check proper operation. When flying, after throttling back the motor would not throttle back up. I was able to land safely dead-stick. I thought the first time was just a fluke, but the second time made me a believer and I attempted no more flying and did not even run the motor anymore.
Here's the weird part. A stranger approached me and said "Castle Creations ?" It stunned me to hear him correctly guess what brand of controller I was using. He then proceeded to tell me that he had lost a U-Can-Do 46, with a CC Phoenix-60 that did the same thing. Unfortunately his plane was low and slow at the time and didn't survive. He said he'd seen the problem with other Phoenix-60 and 80 controllers. Then he said that I would probably find a portion of the shrink wrap melted or burned on the back of the controller and that " CC had gotten some bad chips". When I was able to remove the controller from the plane last night I found melted/burned shrink wrap on the back of the controller, and what appeared to be charred components. So, my question is, have you seen this problem with CC Phoenix-60 controllers? Is it a common problem or just a fluke? I've been flying electric for 20 years or so and I've had only one previous esc failure and that was my fault due to an overloaded BEC. I've e-mailed CC and am awaiting their response, I undrstand they're at the Toledo show this weekend.
Dave Chewning Sr.
davecee is online now Find More Posts by davecee
Last edited by davecee; Apr 04, 2004 at 10:25 AM.
Reply With Quote
Sign up now
to remove ads between posts
Old Apr 04, 2004, 02:40 PM
Registered User
mlehman's Avatar
United States, FL, Cape Coral
Joined Jun 2002
1,181 Posts
I just had the same problem with a CC60.. I just had it hooked up checked the motor rotation..went through the programing, throttled the motor up and.. poof.. out comes the magic smoke

I`m going to email them also

Mike
mlehman is offline Find More Posts by mlehman
Reply With Quote
Old Apr 04, 2004, 04:58 PM
Registered User
Southeast ID USA
Joined Aug 2002
4 Posts
I have one as well. If you throttle back momentarily and hit the throttle again nothing happens until you throttle off for a couple seconds. Then it starts again. I have not flown it yet. CC60/AXI 4120-14/3S5P Kokam 1500's. 15x10 prop. 41 Amps.
lookes is offline Find More Posts by lookes
Reply With Quote
Old Apr 04, 2004, 06:52 PM
I'd rather be Flying
davecee's Avatar
Nashville, NC, USA
Joined Mar 1999
2,707 Posts
Quote:
Originally posted by lookes
I have one as well. If you throttle back momentarily and hit the throttle again nothing happens until you throttle off for a couple seconds. Then it starts again. I have not flown it yet. CC60/AXI 4120-14/3S5P Kokam 1500's. 15x10 prop. 41 Amps.
Actually mine wouldn't start again AT ALL until the ESC was unpowered and then powered back up. That's what I did after the first incident. After the second one I didn't try to run the motor anymore.
Dave Chewning Sr.
davecee is online now Find More Posts by davecee
Reply With Quote
Old Apr 04, 2004, 11:35 PM
Permanently Banned
Larry3215's Avatar
Gig Harbor, Washington, United States
Joined Sep 2003
8,434 Posts
Its bad that these things happened.

On the plus side tho - you have ESC's made by a company that has the best customer service I have ever seen.

They will fix you up.

Larry
Larry3215 is offline Find More Posts by Larry3215
Reply With Quote
Old Apr 05, 2004, 09:19 AM
Registered User
UK
Joined Jun 2003
452 Posts
My CC45 has just doed a trajic early firey death for no reason - anyone know the contact email address for CC?

the old support@castlecreations.com seems to bounce back on me, think address may have changed?

Nick T
NickT is offline Find More Posts by NickT
Reply With Quote
Old Apr 05, 2004, 11:28 AM
Registered User
Patrick del Castillo's Avatar
Olathe,KS,USA
Joined Oct 2000
2,654 Posts
Try: info@castlecreations.com

Patrick
Patrick del Castillo is offline Find More Posts by Patrick del Castillo
Reply With Quote
Old Apr 06, 2004, 03:26 AM
Registered User
UK
Joined Jun 2003
452 Posts
Well, talk about service from CC again it seems. Had a nice email awaiting me this morning from Shawn asking for my address - a new one will be posted along with a return envelope for the dead one!

Market leader on more than features and price it would seem

Thanks Shawn

Nick Taylor
NickT is offline Find More Posts by NickT
Reply With Quote
Old Apr 06, 2004, 11:03 AM
I'd rather be Flying
davecee's Avatar
Nashville, NC, USA
Joined Mar 1999
2,707 Posts
Quote:
Originally posted by NickT
Well, talk about service from CC again it seems. Had a nice email awaiting me this morning from Shawn asking for my address - a new one will be posted along with a return envelope for the dead one!

Market leader on more than features and price it would seem

Thanks Shawn

Nick Taylor
I heard from Shawn yesterday (e-mail) and after answering a few questions about my set-up and flying style I received another e-mail today offering to replace the ESC. It's nice to see a company stand behind their product.

Dave Chewning Sr.
davecee is online now Find More Posts by davecee
Last edited by davecee; Apr 06, 2004 at 03:06 PM.
Reply With Quote
Old Apr 11, 2004, 11:33 AM
I'd rather be Flying
davecee's Avatar
Nashville, NC, USA
Joined Mar 1999
2,707 Posts
I received my replacement ESC yesterday, April 10th. Only 4 days from the offer to replace it. WOW! Thanks, Shawn and Castle Creations. I mailed the old one back on the 7th.

Dave Chewning Sr.
davecee is online now Find More Posts by davecee
Last edited by davecee; Apr 11, 2004 at 11:36 AM.
Reply With Quote
Old Apr 11, 2004, 01:54 PM
Registered User
mlehman's Avatar
United States, FL, Cape Coral
Joined Jun 2002
1,181 Posts
I sent mine back with a 25 and 10 that I needed to upgrade

Mike
mlehman is offline Find More Posts by mlehman
Reply With Quote
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Discussion First Day Out w/ H9 PTS Mustang=Not so good.. lol BSchorr Beginner Training Area (Fuel) 11 Apr 05, 2007 11:54 AM
Discussion Babys first day out Paul Wilson Fuel Warbirds 10 Nov 11, 2006 04:21 AM
Discussion Second day out, first solo chadtheguru Beginner Training Area (Fuel) 12 Jun 09, 2006 08:25 AM
Fried Phoenix-60 - Scary Failure Mode FoamCrusher Castle Creations 3 May 08, 2004 07:52 PM
First day out in my caddy... KMKAZE Life, The Universe, and Politics 0 Sep 06, 2001 02:35 PM