HobbyKing.com New Products Flash Sale
Reply
Thread Tools
Old Oct 25, 2013, 08:22 PM
Well, now that you know ...
Bigster's Avatar
Grafton, Massachusetts, United States
Joined Sep 2004
5,663 Posts
Help!
Thunder power balance connector

I recently purchased a couple G4 TP 3S2700 packs. When I plugged it into my Cellpro 4S, the charger complained (basically it couldn't see all the cells). When I plugged it into the balance board (via adapter) to my iCharger 106b+) it also complained but with it was easier to see that as I wiggle the connector, I get the balance wires to connect and disconnect.

I have a few other TP batteries, and have had no such issue with any of them on either charger.

I had a suspicion that the pins on the chargers basically weren't going far enough into the balance plug on the battery. I carefully filed the connector down a little and it seems a little better, but it's still not something I trust.

Has anyone else seen such a thing?
Bigster is offline Find More Posts by Bigster
Reply With Quote
Sign up now
to remove ads between posts
Old Oct 25, 2013, 08:54 PM
Y=C+I+G
cmdl's Avatar
United States, CA, Rosemead
Joined Jan 2012
7,799 Posts
i have had mischarge and connection issues. cleaning the contacts with rubbing alcohol solves the problem. yours may be the case too. clean both batt contacts as well as charger contacts.
cmdl is online now Find More Posts by cmdl
Reply With Quote
Old Oct 25, 2013, 09:03 PM
Well, now that you know ...
Bigster's Avatar
Grafton, Massachusetts, United States
Joined Sep 2004
5,663 Posts
Maybe, but it really "feels" like a bad fit, both batteries are the same (and brand new).
Bigster is offline Find More Posts by Bigster
Reply With Quote
Old Oct 25, 2013, 09:17 PM
Y=C+I+G
cmdl's Avatar
United States, CA, Rosemead
Joined Jan 2012
7,799 Posts
very true - but it could also be the charger contacts (rather than batt contacts) that have issues and thus need cleaning. if you do clean them you non-destructively eliminate a source of bad connection.
cmdl is online now Find More Posts by cmdl
Reply With Quote
Old Oct 25, 2013, 10:40 PM
Well, now that you know ...
Bigster's Avatar
Grafton, Massachusetts, United States
Joined Sep 2004
5,663 Posts
Quote:
Originally Posted by cmdl View Post
very true - but it could also be the charger contacts (rather than batt contacts) that have issues and thus need cleaning. if you do clean them you non-destructively eliminate a source of bad connection.
Agreed and I will try it. I have my doubts though as I don't have any problems with other thunder power packs.
Bigster is offline Find More Posts by Bigster
Reply With Quote
Old Oct 26, 2013, 11:34 AM
Well, now that you know ...
Bigster's Avatar
Grafton, Massachusetts, United States
Joined Sep 2004
5,663 Posts
I think I solved the issue. I tried a couple of other packs I have with TP connectors and they were rock solid. So I removed the pins from another battery and moved the plastic housing to my new battery. It definitely fits better but I was still getting intermittent connections. So I pulled the pins again and found the openings seem to be wider on the new pack. I squeezed the tabs together a bit on each and it seems much better.

As I said, very strange. I'm not keen on the TP connectors when they work well - if they're going to give me grief I'll cut them off and replace them.
Bigster is offline Find More Posts by Bigster
Reply With Quote
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Discussion Thunder Power With Balancing Connector F100 Batteries and Chargers 3 Mar 01, 2006 06:41 PM
Thunder Power TP-205 Pack Balancer "With Balance Connector" boolat Batteries and Chargers 6 Nov 15, 2005 03:21 AM
Sold Thunder Power 2100mAh ProLite (balancing connector) used <10x dgoss Aircraft - Electric - Helis (FS/W) 2 Oct 21, 2005 03:26 PM
Where can I get cell balancing connector matching for my Thunder-power pack? chan Batteries and Chargers 3 Sep 26, 2005 11:01 PM
Thunder Power Balancing Connector Waff Batteries and Chargers 5 Sep 06, 2005 10:20 AM