SMALL - espritmodel.com SMALL - Telemetry SMALL - Radio
Reply
Thread Tools
Old Jul 25, 2013, 02:44 PM
Registered User
Joined Jul 2011
28 Posts
Discussion
TBS Disco + DJI Naza V2 - Red Yellow light error

Hello

I have just recovered my tbs after a little fall in the forest, tried to fly it today and after takeoff it started blinking red yellow all the time.

I just let it blink and it flies just like atti mode.

If i land i stops and blinks green again, then i takeoff it hovers nice a few secs then starts blink again.. if i just ignore it it casually blinks green sometimes.

I have tried calibrating it each time it starts. Done the "deep" calibration of the "IMU".

Anyone know what it might be? The difference since i crashed done to the craft is that i've put the FPV TX flat instead on the top plate. And the GPS also flat instead of on the stick. (The stick dosent fit in my new carry case)
Toffe87 is offline Find More Posts by Toffe87
Reply With Quote
Sign up now
to remove ads between posts
Old Jul 25, 2013, 02:58 PM
Registered User
albx's Avatar
Italy
Joined Jun 2007
399 Posts
To ne this seems a compass error
albx is offline Find More Posts by albx
Reply With Quote
Old Jul 25, 2013, 03:03 PM
Registered User
Joined Jul 2011
28 Posts
I mounted the gps on the pole again.. jackpot.. :-/

Can this be the case??

I had it into the servoconnectors on the back there the RX for remote is.. I thought RX / RX did not interfere with eachother? battery was under it
Toffe87 is offline Find More Posts by Toffe87
Reply With Quote
Old Jul 26, 2013, 08:46 AM
Registered User
Joined Jul 2011
28 Posts
Ok, now its f**ked. Took 5 minutes to get fix. When i get fix it flew up. Driftet around and around. (not on pole)..

I really dont want that frcking pole.. Is it a must? :-/

Is there any way to test if the gps is dead after that crash?

Toffe87 is offline Find More Posts by Toffe87
Reply With Quote
Old Jul 26, 2013, 08:57 AM
I hate waiting for parts
Mike_Then's Avatar
United States, NC, Garner
Joined Apr 2001
6,770 Posts
Have you checked the Naza manual? It explains in detail what the light error codes mean.
Mike_Then is online now Find More Posts by Mike_Then
RCG Plus Member
Latest blog entry: FAA comment period ends today
Reply With Quote
Old Jul 26, 2013, 08:58 AM
Registered User
United States, MI, Dansville
Joined Oct 2012
499 Posts
im not an expert but if it (the gps) was mounted on the mounting stick then you mounted it flat on the chassis did you also go into the assisstant and change the location parameters for the gps. since you have to put in -10 for the last gps parameter it might need to be 0 ?

just a thought.
dybbob is offline Find More Posts by dybbob
Reply With Quote
Old Jul 26, 2013, 12:01 PM
Registered User
Fastgixxerlv's Avatar
Las Vegas
Joined May 2009
787 Posts
Orange light means your in atti. mode and the red (depending on how many ie 3 blinks) is the satellite signal. No blink is good signal, with blink weak signal.

I have never entered the values of where it installed and it works. I even move it around from time to time with no issues.

Try and keep it away from the frame and VTx antenna.
Fastgixxerlv is online now Find More Posts by Fastgixxerlv
Reply With Quote
Old Jul 26, 2013, 12:07 PM
Registered User
Joined Jul 2011
28 Posts
I know what the light is It was flashing RED and YELLOW when i landed it started blinking green. I calibrated, flew and same thing.

When i mounted it back with the RX above the battery the module got miscalibrated and dident hold position at all.

I moved it to the middle on the left of the TX and its 100% stable now.. :P So if mounting behind keep it atleast 10cm above battery. Works fine. If not keep it away! :P
Toffe87 is offline Find More Posts by Toffe87
Reply With Quote
Old Mar 18, 2014, 11:05 AM
Registered User
lougedo's Avatar
Spain, GA, Corunna
Joined Jan 2011
305 Posts
Quote:
Originally Posted by Toffe87 View Post
I know what the light is It was flashing RED and YELLOW when i landed it started blinking green. I calibrated, flew and same thing.

When i mounted it back with the RX above the battery the module got miscalibrated and dident hold position at all.

I moved it to the middle on the left of the TX and its 100% stable now.. :P So if mounting behind keep it atleast 10cm above battery. Works fine. If not keep it away! :P
Thank you! i will try that, im having the same issues.. difting sometimes like crazy and not holding the position
lougedo is offline Find More Posts by lougedo
Reply With Quote
Old Mar 18, 2014, 02:15 PM
Kev Waite
Plymouth UK
Joined Nov 2005
351 Posts
It is a compass error, it is in the manual. I had this when the GPS puck was too low and gets interference from the magnetic field generated by the motors. Raised the height of the puck above the motors and never had the problem since, over a year ago.
rcpaintfx is offline Find More Posts by rcpaintfx
Reply With Quote
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
For Sale DJI 450 Quad, 550 Hexa, Phantom, TBS Disco Quad, & Turnigy H.A.L. LED light kits! macentyre Aircraft - Electric - Multirotor (FS/W) 0 May 09, 2013 11:54 AM
For Sale DJI 450 Quad, 550 Hexa, Phantom, TBS Disco Quad, & Turnigy H.A.L. LED light kits! macentyre Aircraft - Electric - Multirotor (FS/W) 0 May 07, 2013 11:43 PM
For Sale DJI 450 Quadcopter, 550 Hexacopter, TBS Disco Quad, & Turnigy H.A.L. LED light kits! macentyre Aircraft - Electric - Multirotor (FS/W) 0 Apr 25, 2013 01:55 PM
For Sale DJI 450 Quadcopter, 550 Hexacopter, TBS Disco Quad, & Turnigy H.A.L. LED light kits! macentyre Aircraft - Electric - Multirotor (FS/W) 0 Apr 21, 2013 03:19 PM
For Sale DJI 450 Quadcopter, 550 Hexacopter, TBS Disco Quad, & Turnigy H.A.L. LED light kits! macentyre Aircraft - Electric - Multirotor (FS/W) 0 Apr 21, 2013 02:17 AM