Espritmodel.com Telemetry Radio
Reply
Thread Tools
Old Mar 02, 2013, 05:16 AM
Registered User
Mt helena western australia
Joined May 2009
2,013 Posts
Discussion
help with logo 500 heli setup

So i finally got a new heli after 7 months since i had my hk450 and was doing basic 3d on it (inverted hovering, flips) and bought a sim (g5.5) about a month before now so flying it isnt the problem =), and best of all its the heli of my dreams, a brand new logo 500DX (flybared) as it never was completed by the previous owner. So iev been rebuilding a few bits the previous owner really did badly ie lopsided flybar, very incorrect linkage lengths and now im onto setting up the cyclic servos (futaba s9252 @5v) with my turnigy 9x after days of setting up the head with a set of calipers =s, but now im having trouble with setting up the head as iev forgotten alot of stuff , the main thing im having trouble with is keeping the swash lever constantly. Iev got to the point were all the servos are moving in the right direction aswell at the same pace doing normal speed stick movments and swash wont move up or down more than 0.5mm which is normal i guess (unless pitch is obviously changed). But when i do really hard stick bashing the swash really moves up and down up to 8mm and im not quite shore what to do to fix it =/. I have a few days to fix this so take your time with the replies as my ESC (100A redbrick) batterys (zippy 6s 5000mah 25c) gyro (ga250 LOVE THIS GYRO) come in.
rangamatchstic is offline Find More Posts by rangamatchstic
Reply With Quote
Sign up now
to remove ads between posts
Old Mar 02, 2013, 06:25 AM
Registered User
Mt helena western australia
Joined May 2009
2,013 Posts
TLDR: need help setting up cyclic on logo 500 with tg9x, swash works fine (under 0.5mm movment) with normal stick movment speeds, but when you really go crazy the swash moves up and down alot.
rangamatchstic is offline Find More Posts by rangamatchstic
Reply With Quote
Old Mar 09, 2013, 07:23 AM
Registered User
Mt helena western australia
Joined May 2009
2,013 Posts
hahah found out it was just the 9v battery i was running the ubec off for setup inside was just not supplying enough current to the servos =P, did it with a lipo saddle pack and it works pretty much fine.
rangamatchstic is offline Find More Posts by rangamatchstic
Reply With Quote
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Discussion Best way to setup the rudder throws on a 450 Heli (or any Heli with a Gyro) SoarWest Beginner Training Area (Heli-Electric) 8 Jan 15, 2013 03:52 AM
Discussion DJI 500 / Devo 10 Setup, newbie help please! colemanmeyer Beginner Training Area (Heli-Electric) 12 Jan 14, 2013 11:31 PM
Sold Logo 500 parts whytlotus Aircraft - Electric - Helis (FS/W) 0 Jan 12, 2013 09:41 AM
Discussion Help with a turnigy HAL setup UK sirjosht Multirotor Talk 0 Jan 10, 2013 09:03 AM
Help! heli setup with dx7s helipilot23 Mini Helis 3 Jan 05, 2013 07:05 PM