HobbyKing.com New Products Flash Sale
Reply
Thread Tools
Old Feb 13, 2013, 05:25 PM
Registered User
United States, IL, St Charles
Joined Jan 2013
671 Posts
Help!
please help with servo issue on v120d02s

ok so i got this heli today and for some reason when i start the throttle the left side servo pulls down like it wants to go left. then when i let off the throttle it goes back to normal???? please let me know how i can fix this? also when i increase throttle the farther the servo goes i am using a devo 8.
Bnh105 is offline Find More Posts by Bnh105
RCG Plus Member
Reply With Quote
Sign up now
to remove ads between posts
Old Feb 17, 2013, 08:06 AM
Registered User
Joined Oct 2012
28 Posts
its cool im pretty sure thats how the heli gets lift, by angeling the blades
milk_man89 is offline Find More Posts by milk_man89
Reply With Quote
Old Jun 28, 2013, 07:16 AM
High VulTAge
Joined Apr 2013
260 Posts
all 3 servos should be moving down when raising the throttle. On the V120 the links on the blade grips are on the trailing edge of the blades so the swash moves down to get positive pitch. When only moving the throttle the swash should stay nice and flat in every direction.
Vultage is offline Find More Posts by Vultage
Reply With Quote
Old Jul 06, 2013, 11:45 PM
Registered User
ryane67's Avatar
United States, MI, Waterford Charter Township
Joined Mar 2013
779 Posts
Is it only the single servo or all three pulling down when you apply throttle? As vultage said it's a trailing edge linkage system so the swash moves down to increase collective.
ryane67 is offline Find More Posts by ryane67
Reply With Quote
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Poll Issues with Hitec 65MG on 6V? arnav Radios 4 Feb 07, 2013 07:57 AM
Discussion Need Help, Issues with old Motor on a P-38 Mudnyrey Electric Warbirds 0 Feb 01, 2013 11:54 AM
Discussion Help with RX24610V on V120D02 gmbnj Micro Helis 7 Oct 11, 2010 10:53 PM
Discussion Any issues with BEC on 4 micro/mini servo with 3-4s combo? Magna Power Systems 4 Nov 14, 2006 08:56 PM
Help With Charging Li-Po's With Triton Charger Pleas? Synthetic Batteries and Chargers 13 Dec 17, 2004 08:08 PM