HobbyKing.com New Products Flash Sale
Reply
Thread Tools
Old Feb 13, 2013, 08:11 AM
Registered User
Joined Feb 2013
5 Posts
Discussion
SkyCharger B6AC

Using my SkyCharger B6AC . Trying to charge a new and or a used 1800mAh Sky LiPo battery I get a ERR that reads.( Battery Vol. ERR Cell Connect). I am using the balance attached. When using fast charge without the balance attach it will charge. What can I do so I can charge with the balance when charging.
Jim Lewellyn is offline Find More Posts by Jim Lewellyn
Reply With Quote
Sign up now
to remove ads between posts
Old Feb 13, 2013, 08:44 AM
Registered User
302 Z28's Avatar
United States, TX
Joined May 2009
203 Posts
What is the measured voltage of the pack you are trying to charge?

Vince
302 Z28 is offline Find More Posts by 302 Z28
Reply With Quote
Old Feb 13, 2013, 09:18 AM
Registered User
Barbados
Joined Jan 2011
1,956 Posts
Quote:
Originally Posted by Jim Lewellyn View Post
Using my SkyCharger B6AC . Trying to charge a new and or a used 1800mAh Sky LiPo battery I get a ERR that reads.( Battery Vol. ERR Cell Connect). I am using the balance attached. When using fast charge without the balance attach it will charge. What can I do so I can charge with the balance when charging.
Balance plug attached fine you also have to connect the discharge lead to the banana port in order to get it to work in balance mode,the discharge cable is where the charger charges and the balance plug is where it balances and monitors indivisual cell voltage.If you don't have both connected it na work.
The Tug is offline Find More Posts by The Tug
Reply With Quote
Old Feb 15, 2013, 07:45 AM
Registered User
Joined Feb 2013
5 Posts
Quote:
Originally Posted by 302 z28 View Post
what is the measured voltage of the pack you are trying to charge?

Vince
11.1v
Jim Lewellyn is offline Find More Posts by Jim Lewellyn
Reply With Quote
Old Feb 15, 2013, 07:51 AM
Registered User
Joined Feb 2013
5 Posts
Quote:
Originally Posted by The Tug View Post
Balance plug attached fine you also have to connect the discharge lead to the banana port in order to get it to work in balance mode,the discharge cable is where the charger charges and the balance plug is where it balances and monitors indivisual cell voltage.If you don't have both connected it na work.
I have all connections made and I continue to get the same message.
Jim Lewellyn is offline Find More Posts by Jim Lewellyn
Reply With Quote
Old Feb 15, 2013, 07:54 AM
Registered User
Barbados
Joined Jan 2011
1,956 Posts
If you have a meter test the main charge leads for bad solder joint and do the same on the batt side.
The Tug is offline Find More Posts by The Tug
Reply With Quote
Old Feb 15, 2013, 08:00 AM
222 km/hr Parkjet flyer
solentlife's Avatar
Latvia, Ventspils pilsēta, Ventspils
Joined Jan 2010
8,362 Posts
Quote:
Originally Posted by Jim Lewellyn View Post
Using my SkyCharger B6AC . Trying to charge a new and or a used 1800mAh Sky LiPo battery I get a ERR that reads.( Battery Vol. ERR Cell Connect). I am using the balance attached. When using fast charge without the balance attach it will charge. What can I do so I can charge with the balance when charging.
From later posts - I assume this is a 3S pack ?

So you have the Charger set for a 3S pack ... and balance lead plugged into correct port ? The main power leads connected to charge leads from charger ?

On pressing start - you get "Battery Vol ERR Cell connect" ... ?

It sounds like one pin of the balance lead / socket may have failed.

Nigel
solentlife is offline Find More Posts by solentlife
Reply With Quote
Old Feb 15, 2013, 08:02 AM
222 km/hr Parkjet flyer
solentlife's Avatar
Latvia, Ventspils pilsēta, Ventspils
Joined Jan 2010
8,362 Posts
Quote:
Originally Posted by The Tug View Post
If you have a meter test the main charge leads for bad solder joint and do the same on the batt side.
He does say that charge without balance works - so his main charge leads are ok.

The problem appears to be in the balance port socket as his post remarks about not just one LiPo.

Nigel
solentlife is offline Find More Posts by solentlife
Reply With Quote
Old Feb 15, 2013, 09:07 AM
Registered User
United States, MN
Joined Feb 2011
4,356 Posts
Yep sounds like the socket since he said two different batteries don't work. Could either try with a balance board plugged into the 6s port if you have one, or else cut the key off one side of the connector so you can try plugging it into the 4s or larger ports.
grimbeaver is offline Find More Posts by grimbeaver
Reply With Quote
Old Feb 15, 2013, 09:42 AM
Registered User
Barbados
Joined Jan 2011
1,956 Posts
+1 on that trim off one of the guides so the plug will fit in one of the larger ports the polarity is wired the same on all the plugs,unless you have a board.
The Tug is offline Find More Posts by The Tug
Reply With Quote
Old Feb 15, 2013, 05:11 PM
Registered User
Joined Feb 2013
5 Posts
Quote:
Originally Posted by The Tug View Post
+1 on that trim off one of the guides so the plug will fit in one of the larger ports the polarity is wired the same on all the plugs,unless you have a board.
I have tried a 2S and a 3S in there proper ports. Neater on work and I get the same read out.
Does anyone know where to get parts or where to have a charger repaired? Hobbypartz only cover warranty for 30 days. Without the balance the charger is junk.
Jim Lewellyn is offline Find More Posts by Jim Lewellyn
Reply With Quote
Old Feb 15, 2013, 10:41 PM
222 km/hr Parkjet flyer
solentlife's Avatar
Latvia, Ventspils pilsēta, Ventspils
Joined Jan 2010
8,362 Posts
Quote:
Originally Posted by Jim Lewellyn View Post
I have tried a 2S and a 3S in there proper ports. Neater on work and I get the same read out.
Does anyone know where to get parts or where to have a charger repaired? Hobbypartz only cover warranty for 30 days. Without the balance the charger is junk.
mmmmm so as I read this - whatever pack you plug into balance port - it still gives error ...

Definitely balance port faulty then. Trouble is with chargers unlike wattmeters - the balance ports are fixed to the case and requires opening the case up. Not a recc'd practice with chargers for LiPo's etc. Really the only safe sure option is to replace the charger.

BUT - I wouldn't junk the charger entirely - it will still be useful as a NiXX and other format charger which do not use balance leads ........ so at least you will gain a charger that way. For that the 6 chargers are extremely useful ...

Nigel
solentlife is offline Find More Posts by solentlife
Reply With Quote
Old Feb 16, 2013, 10:36 AM
Registered User
Joined Feb 2013
5 Posts
Thanks for all of the replay's. Is there any place to have chargers repaired or where replacement boards can be purchased?
I was told that the Manufacture could be reached at http://www.sftrc.com/index.asp but no luck with this.
Jim Lewellyn is offline Find More Posts by Jim Lewellyn
Reply With Quote
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Discussion SkyCharger B6AC+ problems eruji Batteries and Chargers 1 Jun 09, 2011 10:42 PM
Question Skycharger B6AC charger question Wingman26 HobbyPartz.com 7 Jul 14, 2010 03:10 PM
Discussion SkyCharger B6AC LiPo Balance Charging Problem Jawsmon HobbyPartz.com 1 May 06, 2010 11:59 AM
Question Some Newbie Questions on a SkyCharger B6AC flip68 Batteries and Chargers 3 Feb 22, 2010 08:21 AM
Question Questions about SkyCharger B6AC stekeye HobbyPartz.com 0 Nov 28, 2009 03:26 AM