HobbyKing.com New Products Flash Sale
Reply
Thread Tools
Old Feb 10, 2013, 08:24 PM
Registered User
Joined Feb 2012
25 Posts
Discussion
OSD Pro Throttle function not working?

Hi, I purchased the OSD Pro and I have been having an issue with the power output to my motor when I route the servo wire from my receiver to the Throttle In port, and then take the ESC Servo and attach it to the Throttle Out on the OSD Pro. The problem is that in the ~50%-100% throttle range, there seems to be a "power shortage" and the throttle starts wavering in RPMS and starts attenuating (cutting back in RPM and power)...

Everything else with my OSD pro function work (video, ailerons, etc)..but the throttle is what is acting up. I know its the OSD pro because when I choose not to route my ESC through the OSD Pro, I have a perfectly fine Throttle curve with no apparent power outages.

Any ideas?


Thanks
mfische is offline Find More Posts by mfische
Reply With Quote
Sign up now
to remove ads between posts
Old Feb 11, 2013, 02:54 PM
billpa's Avatar
Joined Nov 2003
4,926 Posts
Hi - sorry to hear about the problem. That's an odd issue!

Normally, when I hear reports of stuttering at high RPM, it turns out to be a bad solder connector on the battery or ESC's connectors, but if you are not seeing it when you bypass the OSD's throttle i/o, that's obviously not it.

One thing to try - if you are using the Guardian stabilizer, go into the readio control menu, and temporarily turn off "Stabilizing/Elevon Mixing". Then, if you can do so safely, try a bench run-up to see if the throttle still wavers.

If you are not using the Guardian, we'll need to look elsewhere.
billpa is offline Find More Posts by billpa
Site Sponsor
Reply With Quote
Old Feb 11, 2013, 04:25 PM
Registered User
Joined Feb 2012
25 Posts
I was able to fix it! Turns out I needed to upgrade my firmware (even though its brand new out of the box). Thanks!
mfische is offline Find More Posts by mfische
Reply With Quote
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Help! Eagle tree V4 Elogger and Osd pro everything working except throttle monitoring? whosthebaddest Eagle Tree Systems 5 Mar 19, 2014 04:50 PM
Discussion FDR pro + Osd pro not working? ekozxx Eagle Tree Systems 10 Mar 07, 2013 08:06 PM
Help! RC plane throttle not working Miniclip12 Electric Plane Talk 31 Jan 15, 2013 07:35 PM
Discussion Throttle not working when going through OSD ryanrolds Eagle Tree Systems 4 Feb 26, 2011 01:08 AM