HobbyKing.com New Products Flash Sale
Reply
Thread Tools
Old Feb 08, 2013, 01:08 PM
Registered User
United States, NJ, Pedricktown
Joined Jan 2013
29 Posts
Discussion
Phoenix sim with DX6I and Blade SR Heli - No Throttle Control

Hello guys, need some serious help. I have the Phoenix flight simulator, and the airplane and some heli functions work just fine. The problem is when I go to the Blade SR heli I have no throttle control. It's either full throttle when I move the stick up or no throttle at all when I move it down, there is no mid range throttle. I would love to practice with the SR heli as this is my first collective picth one. If anyone could explain how to make the throttle work correctly with this sim and transmitter I would really appreciate the help. Thanks very much!
Jack1950 is offline Find More Posts by Jack1950
Reply With Quote
Sign up now
to remove ads between posts
Old Feb 13, 2013, 06:22 PM
Registered User
United States, NJ, Pedricktown
Joined Jan 2013
29 Posts
Since no one has posted an answer I decided to contact product support at Horizon. They got back to me in a couple of days and said that the throttle control must be set at 50% before starting the transmitter calibration. If not, then you will most likely end up with only 2 throttle settings which appears to be my problem. Tomorrow I'll give it a try and see what happens. Hope this info may also be helpful to someone else. If this solves my problem I'll let you all know.
Jack1950 is offline Find More Posts by Jack1950
Reply With Quote
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Blade MSR for Phoenix Sim tele1974 Non R/C Items (FS/W) 0 Feb 01, 2013 02:00 PM
Wanted phoenix flight sim. w/ controller FOUND ONE lx2008 Aircraft - General - Miscellaneous (FS/W) 0 Jan 25, 2013 08:21 PM
Discussion Throttle inverted on phoenix 4 with turnigy 9x - please help leopereira Simulators 3 Jan 15, 2013 04:19 PM
For Sale Blade MSR with DX6i and Phoenix Sim jayw81 Aircraft - Electric - Helis (FS/W) 1 Apr 14, 2011 05:21 PM
Question No throttle and no braking with Phoenix with brake enabled. Possible? Jan_B Castle Creations 3 May 14, 2007 11:04 AM