HobbyKing.com New Products Flash Sale
Reply
Thread Tools
Old Jan 23, 2013, 07:46 PM
Registered User
Joined Jan 2013
7 Posts
Help!
TriCopter HELP!!!!

I have a kk2 FC and a dx6i transmitter, with an orange rx 6 channel receiver... The problems im having are 1. aileron input is not being detected...2. the number 2 motor should be spinning c.c.w. but is spinning c.w. 3 the yaw servo is not doing a thing... the motors power up tho and all is wired correctly (I think) i have been looking for a step by step instruction manual or something to get me going on it..NOT a youtube video..... im almost positive that the dx6i isnt set up right nor is the kk2.0 ... so i need major HELP. lol
thanks,
skltnjak is offline Find More Posts by skltnjak
Reply With Quote
Sign up now
to remove ads between posts
Old Jan 23, 2013, 08:16 PM
Registered User
New Zealand, Canterbury, Christchurch
Joined Dec 2012
1,428 Posts
Motor direction is based on how the wires are connected, switch any of the two wires between the ESC and thre motor and it will start spinning in the right direction.

How have you got the ESC's and servo connected to the KK2?

What does the receiver test show on the KK2 when you move the sticks? Does it show the correct input for all 4 channels?
WendoNZ is offline Find More Posts by WendoNZ
Reply With Quote
Old Jan 24, 2013, 12:48 AM
Registered User
Joined Jan 2013
7 Posts
i have the ESC's hooked up on the right side of the FC
motor 1 =M1
motor 2=M2
motor 3=M3
and the servo=M4
on the board it shows that its receiving input from all channels except Aileron or channel 1
all the controls seem to corrispond with the the sticks.
skltnjak is offline Find More Posts by skltnjak
Reply With Quote
Old Jan 24, 2013, 02:44 AM
Registered User
New Zealand, Canterbury, Christchurch
Joined Dec 2012
1,428 Posts
Do your ESC's have BEC's, and if so are they all connected?

To power servo's you need a BEC connected to M2-M8, M1 will only power the KK2 itself. You also presumably want to work out why Aileron isn't being detected. Double check cables, make sure your TX is in the right mode and sending Ail on channel 1 etc
WendoNZ is offline Find More Posts by WendoNZ
Reply With Quote
Old Jan 24, 2013, 10:22 AM
Registered User
Joined Jan 2013
7 Posts
I believe they do and are.... Im thinking i need to re wire and saulder it again... honestly i have no clue if the aileron is on channel 1.... how do i confirm that it is.... how do i know if the ESCs have BECs?
skltnjak is offline Find More Posts by skltnjak
Reply With Quote
Old Jan 24, 2013, 03:36 PM
Registered User
Joined Jan 2013
7 Posts
i checked all my wires and ESC's they do infact have BEC's built in... i think it might be a setting with my board .... i have done the factory reset a few times but every time it comes up with a no signal from the aileron..
skltnjak is offline Find More Posts by skltnjak
Reply With Quote
Old Jan 24, 2013, 04:33 PM
Head full of foam
United States, NE, Omaha
Joined Jan 2013
324 Posts
Quote:
Originally Posted by skltnjak View Post
i checked all my wires and ESC's they do infact have BEC's built in... i think it might be a setting with my board .... i have done the factory reset a few times but every time it comes up with a no signal from the aileron..
Hmm, seems like a dumb thing to try and you probably already have but there is a monitor function in the Dx6i. Check that to see if it's even seeing stick movement at the controller.

Probably not it but it only takes a few seconds to check.

Edit: If you get it fixed by yourself please post the solution. I'm building one of these (light wooden frame came in today) and I can use all the pointers I can get. Thanks.
RuralFPV is offline Find More Posts by RuralFPV
Last edited by RuralFPV; Jan 24, 2013 at 04:39 PM.
Reply With Quote
Old Jan 24, 2013, 04:45 PM
Registered User
Joined Jan 2013
7 Posts
yep. i tried the monitor function...says its working there... im pretty sure i shorted out my board... i know i need to get new ESC"s tho.. loose wires or points in it... so i think i might start from scratch..gonna try a new Rx and maybe a new FC. "sigh" been working slowly on this project for about 3 months... *bleh* lol just my luck it seems haha
skltnjak is offline Find More Posts by skltnjak
Reply With Quote
Old Jan 25, 2013, 03:03 PM
Registered User
Joined Jan 2013
7 Posts
is there any setting on the FC that would make it so the aileron wouldnt be detected?
skltnjak is offline Find More Posts by skltnjak
Reply With Quote
Old Jan 25, 2013, 03:51 PM
Registered User
Joined Jan 2013
7 Posts
Problem solved! one of the esc's was shorted out or came messed up... two saulder points were touching that shouldnt have been, so i need to get a new one of those, and the board is bad... case closed. sniff
skltnjak is offline Find More Posts by skltnjak
Reply With Quote
Old Jan 25, 2013, 04:14 PM
Head full of foam
United States, NE, Omaha
Joined Jan 2013
324 Posts
Glad you got it sorted out.

Thanks for posting the solution. Reinforces the idea that I need to order 1 extra ESC and 1 extra motor.
RuralFPV is offline Find More Posts by RuralFPV
Reply With Quote
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Discussion tricopter help monika Multirotor Electronics 14 Mar 16, 2013 03:48 PM
Help! Need KK 1.6 Tricopter (Agressive) firmware RobDog Multirotor Electronics 3 Jan 17, 2013 09:12 AM
Discussion tricopter yoyo'ing bluesteel212 Multirotor Talk 0 Jan 07, 2013 11:51 PM
Discussion Differences in flight performance on Tricopter FCs. acetech09 Multirotor Electronics 1 Jan 06, 2013 03:16 AM
For Sale Tricopter DlgHucker Aircraft - Electric - Multirotor (FS/W) 7 Jan 05, 2013 09:00 PM