HobbyKing.com New Products Flash Sale
Reply
Thread Tools
Old Apr 17, 2013, 03:51 PM
Registered User
Germany, NRW, Cologne
Joined Apr 2012
18 Posts
i think you have to raise the Power and maybe the I, to get rid of the vibes. You can see the vibes on the gimbal?
Quote:
Originally Posted by saabguyspg View Post
I finally sorted out my shaking issue... wow three weeks later...

anyway now I find that if I try and pitch the camera vertically (straight down) then I get the crazy high frequency vibes....

If I redcue my D gain down so that this goes away then the pitch axis is not stable...

Any ideas? Has anyone else had this issue?

Steve
gilandar is offline Find More Posts by gilandar
Reply With Quote
Sign up now
to remove ads between posts
Old Apr 17, 2013, 04:09 PM
Registered User
Joined Mar 2013
82 Posts
How can I check which version of Firmware is on my board?

I always get the answer "upload failed" while using xloader v1.00.
Anyone an idea?
copterfan1 is offline Find More Posts by copterfan1
Last edited by copterfan1; Apr 17, 2013 at 04:49 PM.
Reply With Quote
Old Apr 17, 2013, 04:49 PM
Begin with end in mind...
power's Avatar
Eagle Lake, Minnesota
Joined Apr 2003
5,599 Posts
Quote:
Originally Posted by copterfan1 View Post
How can I check which version of Firmware is on my board?
Look at the upper left corner of the GUI, it should state which version is loaded. Doesn't matter which GUI you use it will show the FW version...

It will always state "upload failed" this has been mentioned several times....

Mike
power is offline Find More Posts by power
Reply With Quote
Old Apr 17, 2013, 05:09 PM
Psionic001's Avatar
Australia, NSW, Sydney
Joined Apr 2006
2,162 Posts
I designed and printed a compact gimbal, the "Minim Gimbal" for GP3.
It works beautifully, but when I point it down vertically it also goes nuts.
I think it's a limitation in the firmware.
Admittedly I haven't tried increasing the tilt range in the software, so maybe it's an end stop issue.

Cheers
Matt





Quote:
Originally Posted by saabguyspg View Post
I finally sorted out my shaking issue... wow three weeks later...

anyway now I find that if I try and pitch the camera vertically (straight down) then I get the crazy high frequency vibes....

If I redcue my D gain down so that this goes away then the pitch axis is not stable...

Any ideas? Has anyone else had this issue?

Steve
Psionic001 is offline Find More Posts by Psionic001
RCG Plus Member
Reply With Quote
Old Apr 17, 2013, 05:38 PM
Registered User
Joined Mar 2013
82 Posts
Please help!
I have soldered the sensor plate and connected to my now AlexMos Board.
When I connect the board via USB to my Win7 Computer the board flashes green for a while then permanent.
When i start the GUI it Shows BoardVer. 0,0 and nothing happens. When i try to upload a new firmway, xloader says "upload failed". No idea, what to do.
When i shake the sensor board i cannot see any Feedback in the GUI.

Connection Problem or Driver problem for USB?




Quote:
Originally Posted by power View Post
Look at the upper left corner of the GUI, it should state which version is loaded. Doesn't matter which GUI you use it will show the FW version...

It will always state "upload failed" this has been mentioned several times....

Mike
copterfan1 is offline Find More Posts by copterfan1
Reply With Quote
Old Apr 17, 2013, 05:47 PM
Psionic001's Avatar
Australia, NSW, Sydney
Joined Apr 2006
2,162 Posts
Clearly you have been unsuccessful at uploading the firmware to the board.
There's a few ways to upload firmware, have you tried the other apps?

"To upgrade firmware, download latest firmware (.hex file) and XLoader or AvrdudeR utility. Run utility, select COM port where controller is connected, and specify hex file to upload. Leave all other settings at default (baud is 115200, device is "SimpleBGC"). If device is restarted after upload - it means all done. Run GUI and check if firmware version has changed.

LINUX and MAC users: use avrdude to upload firmware. See command line parameters in XLoader/upload.bat."


Quote:
Originally Posted by copterfan1 View Post
Please help!
I have soldered the sensor plate and connected to my now AlexMos Board.
When I connect the board via USB to my Win7 Computer the board flashes green for a while then permanent.
When i start the GUI it Shows BoardVer. 0,0 and nothing happens. When i try to upload a new firmway, xloader says "upload failed". No idea, what to do.
When i shake the sensor board i cannot see any Feedback in the GUI.

Connection Problem or Driver problem for USB?
Psionic001 is offline Find More Posts by Psionic001
RCG Plus Member
Reply With Quote
Old Apr 17, 2013, 05:57 PM
flitelab's Avatar
Canada, NS, Halifax
Joined Feb 2010
6,977 Posts
Quote:
Originally Posted by Psionic001 View Post
I designed and printed a compact gimbal, the "Minim Gimbal" for GP3.
It works beautifully, but when I point it down vertically it also goes nuts.
I think it's a limitation in the firmware.
Admittedly I haven't tried increasing the tilt range in the software, so maybe it's an end stop issue.

Cheers
Matt

Very nice clean design. Assume you 3D printed it yourself?
flitelab is offline Find More Posts by flitelab
Site Sponsor
Reply With Quote
Old Apr 17, 2013, 06:01 PM
Registered User
Joined Mar 2013
82 Posts
Now i tried with AVRDudeR. After a second it says flashing done but nothing happens.
Seems i have Problems with this USB Driver.



Quote:
Originally Posted by Psionic001 View Post
Clearly you have been unsuccessful at uploading the firmware to the board.
There's a few ways to upload firmware, have you tried the other apps?

"To upgrade firmware, download latest firmware (.hex file) and XLoader or AvrdudeR utility. Run utility, select COM port where controller is connected, and specify hex file to upload. Leave all other settings at default (baud is 115200, device is "SimpleBGC"). If device is restarted after upload - it means all done. Run GUI and check if firmware version has changed.

LINUX and MAC users: use avrdude to upload firmware. See command line parameters in XLoader/upload.bat."
copterfan1 is offline Find More Posts by copterfan1
Reply With Quote
Old Apr 17, 2013, 06:16 PM
Registered User
v00d0o's Avatar
United States, VA, Fairfax
Joined Dec 2012
1,196 Posts
Where can I get some cheap vibration dampers? Preferably in the US.
v00d0o is online now Find More Posts by v00d0o
RCG Plus Member
Old Apr 17, 2013, 06:21 PM
Registered User
Joined Mar 2013
82 Posts
Now i tried an other computer with Windows 8.
Firmware update with xloader started and seemed to work, because of blinking Controller. But it stills blinks very fast (green). I disconnected the board from USB and after reconnecting it still is blinking green very fast - ??
Anyone an idea?


Quote:
Originally Posted by copterfan1 View Post
Now i tried with AVRDudeR. After a second it says flashing done but nothing happens.
Seems i have Problems with this USB Driver.
copterfan1 is offline Find More Posts by copterfan1
Reply With Quote
Old Apr 17, 2013, 07:34 PM
Begin with end in mind...
power's Avatar
Eagle Lake, Minnesota
Joined Apr 2003
5,599 Posts
[QUOTE=Psionic001;24750438]I designed and printed a compact gimbal, the "Minim Gimbal" for GP3.
It works beautifully, but when I point it down vertically it also goes nuts.
I think it's a limitation in the firmware.
Admittedly I haven't tried increasing the tilt range in the software, so maybe it's an end stop issue.

Cheers
Matt

I have my limits set at 90 deg each way on both pitch and roll. I have had no issues with the gimbal twitching at all when I go to vertical.

Mike
power is offline Find More Posts by power
Reply With Quote
Old Apr 17, 2013, 07:40 PM
Begin with end in mind...
power's Avatar
Eagle Lake, Minnesota
Joined Apr 2003
5,599 Posts
Quote:
Originally Posted by copterfan1 View Post
Now i tried an other computer with Windows 8.
Firmware update with xloader started and seemed to work, because of blinking Controller. But it stills blinks very fast (green). I disconnected the board from USB and after reconnecting it still is blinking green very fast - ??
Anyone an idea?
Read this post....

http://www.rcgroups.com/forums/showp...postcount=1621

You have to install the drivers, I messed around for some time like you and then installed/reinstalled the drivers from the link in this post and everything was smooth from there...

Mike
power is offline Find More Posts by power
Reply With Quote
Old Apr 17, 2013, 08:15 PM
uavservices on MRF
saabguyspg's Avatar
Calgary Canada
Joined Jun 2006
4,970 Posts
Thanks to everyone for the response.

I am seeing this vibration when not in flight. Ie on the bench.

I assume my gimbal may not be 100% in line so I am ensuring it is all perfect now.

I have read that askman has the same issues.

When I point the camera straight down on the bench I hear a real "moaning" noise that goes louder and louder.

If I reduce my d down to 3 then it goes away and works perfet however that is too low for proper tilt stabilization in flight

I will post a video as soon as I get the gimbal back together.

Steve
saabguyspg is offline Find More Posts by saabguyspg
Reply With Quote
Old Apr 17, 2013, 09:23 PM
Registered User
Israel
Joined Aug 2010
57 Posts
Finely got everything ready to fly
Brushless Gimbal (AlexMos Gimbal) (2 min 33 sec)
Levinemax is offline Find More Posts by Levinemax
Reply With Quote
Old Apr 17, 2013, 10:04 PM
Friend is a 4 letter word...
JussiH's Avatar
3rd stone from the sun
Joined May 2007
2,670 Posts
Controllers will be available from thursday 14:00 CET at Viacopter and Flyduino.

We have revised the IMU a bit to include a JST XH connector and matching cable.

JussiH is offline Find More Posts by JussiH
RCG Plus Member
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Mini-HowTo Super Simple Gimbal - SSG - KK2.1 & OpenPilot support crezzee Aerial Photography 1362 Yesterday 01:55 PM
Yippee! Simple Brushless Gimbal Controller--FPV MODEL fpvmodels Multirotor Talk 3395 May 18, 2014 01:47 PM
Discussion A very simple camera-gimbal for Gaui 330xs babanan Multirotor Talk 2 Oct 09, 2013 08:46 AM