SMALL - espritmodel.com SMALL - Telemetry SMALL - Radio
Reply
Thread Tools
Old Jan 15, 2013, 10:12 AM
A man with too many toys
United States
Joined Feb 2001
18,060 Posts
New Product
New ICE Firmware

I see in the latest firmware download (3.53.11) that ICE firmware 4.02 beta is now upgraded to 4.02 (non-beta). Does anyone know the difference between the two? The Firmware Revision History has not been updated with information about the new version.

.
RC Man is offline Find More Posts by RC Man
Reply With Quote
Sign up now
to remove ads between posts
Old Jan 15, 2013, 12:57 PM
Registered User
Chicago 'burbs
Joined May 2006
1,708 Posts
A complete guess on my part, but since the number didn't change, I'd say there is no difference except that CC doesn't consider this version as a "beta" anymore.

Only way to really know is to have a CC rep. give a response.
Alan Hahn is online now Find More Posts by Alan Hahn
Reply With Quote
Old Jan 15, 2013, 02:15 PM
Registered User
Joined Jan 2013
22 Posts
3.53.11

Well it has fixed my head speed change rate problem where on 3.27 randomly it would ramp up instantly between set rpms instead of the low change rate setting of 2.

BUT now it seems it has caused other problems.

It has affected the slow start now where the low "initial spool-up rate" setting of "2" is a lot faster and lowering it to "1" or "0" made little difference if any to slow it down.

I also find it annoying that you cannot view ALL of the data along the bottom of the screen where it hides the MAX line??
Scott999 is offline Find More Posts by Scott999
Last edited by Scott999; Jan 15, 2013 at 11:01 PM.
Reply With Quote
Old Jan 15, 2013, 02:58 PM
A man with too many toys
United States
Joined Feb 2001
18,060 Posts
Log Viewer

Quote:
Originally Posted by Scott999 View Post
I also find it annoying that you cannot view ALL of the data along the bottom of the screen where it hides the MAX line??

I noticed that also and it is defiantly a step backwards. They made the bottom window section too small and you canít change it. Itís a real pain. CC needs to get this fixed right away.

.
RC Man is offline Find More Posts by RC Man
Reply With Quote
Old Jan 15, 2013, 03:25 PM
A man with too many toys
United States
Joined Feb 2001
18,060 Posts
Scott are you trying to slow down the blade spin up speed or what? Headspeed change rate does not control that.


The first second of spoolup is controlled by Motor Start Power (motor tab). After that it’s controlled by the Spool-up Rate.


Headspeed change is for switching between the three flight modes and autorotations.


.
RC Man is offline Find More Posts by RC Man
Reply With Quote
Old Jan 15, 2013, 05:33 PM
Registered User
Joined Jan 2013
22 Posts
Ice 100 4.02

..........I am now, since 4.02 has sped up the "initial spool-up rate" from what it was on 3.27. The "initial spool-up rate" setting controls the slow start after the motor has started as you say from the motor start power setting.

It has always been set on low (2) and now a custom setting of (1) with little difference if any to slow it down.

Remember that this setting has quite a broad range of setting and I am right down near the bottom of the range and it is spooling up too fast for a scale model that's for sure and certainly faster than what is was on 3.27
Scott999 is offline Find More Posts by Scott999
Reply With Quote
Old Jan 16, 2013, 01:38 PM
Registered User
Joined Jan 2013
22 Posts
Data graph

RC Man, I have been informed that the reason for that bottom line of info being "hidden" from view is PC screen resolution setting.

I had my laptop screen set to 125% (where I do not have a problem with anything else) however re set it back to 100% and now can view the graph correctly...........
Scott999 is offline Find More Posts by Scott999
Reply With Quote
Old Jan 16, 2013, 06:24 PM
A man with too many toys
United States
Joined Feb 2001
18,060 Posts
Quote:
Originally Posted by Scott999 View Post
RC Man, I have been informed that the reason for that bottom line of info being "hidden" from view is PC screen resolution setting.

I had my laptop screen set to 125% (where I do not have a problem with anything else) however re set it back to 100% and now can view the graph correctly...........
Properly written software should be able to handle any font size. It worked before but not any more. Doesnít look like progress to me???????????






.
RC Man is offline Find More Posts by RC Man
Reply With Quote
Old Jan 16, 2013, 09:05 PM
Registered User
Joined Jan 2013
22 Posts
Graph

Totally agreed
Scott999 is offline Find More Posts by Scott999
Reply With Quote
Old Jan 17, 2013, 07:19 AM
Castle Support
Clintstone's Avatar
USA, GA, Statesboro
Joined Oct 2007
966 Posts
Please fill out a BUG report... Engineering is working on a BETA test so a bug report would insure they see your comments... Thanks
Clintstone is offline Find More Posts by Clintstone
Reply With Quote
Old Jan 17, 2013, 09:58 AM
Registered User
Joined Jan 2013
22 Posts
Already known by Castle support on both problems, but have bug reported now as well.
Scott999 is offline Find More Posts by Scott999
Reply With Quote
Old Jan 17, 2013, 10:35 PM
Registered User
catbalu's Avatar
Joined Oct 2009
23 Posts
Quote:
Originally Posted by Scott999 View Post
Well it has fixed my head speed change rate problem where on 3.27 randomly it would ramp up instantly between set rpms instead of the low change rate setting of 2.

BUT now it seems it has caused other problems.

It has affected the slow start now where the low "initial spool-up rate" setting of "2" is a lot faster and lowering it to "1" or "0" made little difference if any to slow it down.

I also find it annoying that you cannot view ALL of the data along the bottom of the screen where it hides the MAX line??
Yes ... Well I am going to have to agree with scott999 on this software version, The soft start spool up speed is about twice as fast as the 3.27 version and I feel that is a bit dangerous Things they need to consider before they post any new updates for there controllers I run a hv160 in a 90 size multi blade head scale machine and dont need any rather sub standed software like the last few updates... It is just about time to buy another brand of esc...
catbalu is offline Find More Posts by catbalu
Reply With Quote
Old Jan 18, 2013, 09:00 AM
Registered User
Joined Sep 2012
30 Posts
Hi,

I updated my CC120HV in my 550E with 600mx 1220kv ,and now the motor don't spin (kick like a cow ), I made some test with diferents value in "start power" and with "spool up" but don't spin

I reset the end points

Back to 3.27 and the motor work's OK

Any help please
Marcos Sallua is offline Find More Posts by Marcos Sallua
Reply With Quote
Old Jan 18, 2013, 10:59 AM
A man with too many toys
United States
Joined Feb 2001
18,060 Posts
Quote:
Originally Posted by Marcos Sallua View Post
Hi,

I updated my CC120HV in my 550E with 600mx 1220kv ,and now the motor don't spin (kick like a cow ), I made some test with diferents value in "start power" and with "spool up" but don't spin

I reset the end points

Back to 3.27 and the motor work's OK

Any help please
WOW thatís bad news. You need to fill out a bug report (download page) ASAP so CC can get that fixed.

RC Man is offline Find More Posts by RC Man
Reply With Quote
Old Jan 18, 2013, 11:45 AM
Registered User
Joined Sep 2012
30 Posts
Quote:
Originally Posted by RC Man View Post
WOW thatís bad news. You need to fill out a bug report (download page) ASAP so CC can get that fixed.

Ok, thank you!

Done, the bug report has been sent a support@castlecreations.com
Marcos Sallua is offline Find More Posts by Marcos Sallua
Reply With Quote
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
New Product ICE V4.02 Firmware RC Man Castle Creations 26 Oct 01, 2012 06:10 AM
Discussion Hf Pro and Phoenix HV ICE 2 with firmware 4.01 conf. mfabriz Hoverfly Technologies 0 May 25, 2012 12:17 PM
Sold To trade or sell: my new firmware DL rx for your old firmware DL rx signflyer FPV Equipment (FS/W) 4 Apr 24, 2012 10:49 PM
Discussion Was there any reported issue with ICE firmware v4 ? ricoalonso Castle Creations 3 Mar 30, 2012 07:57 PM
Discussion Firmware Phoenix, Phoenix HV, and Phoenix Ice Series 4.00 Beta 02/22/12 imagine 50 Castle Creations 25 Mar 04, 2012 01:24 PM