HobbyKing.com New Products Flash Sale
Reply
Thread Tools
Old Jan 13, 2013, 07:04 PM
Registered User
Joined Jan 2013
3 Posts
Discussion
Banana Hobby

I hope someone can please help me because the worst customer service in the world belongs to Banana Hobby. I just recently bought a plane from them and I cannot get them to call or email me back to help me with my problems.

I purchased an easy trainer 400 from Banana Hobby and I cannot get the receiver to power on. When I connect the battery to the plane the receiver led does not come on? Any suggestions? I am about ready to call my credit card company and cancel my payment to this company. The directions and manual they provide are horrific. There is no way this product is RTF as they advertise.
surfdoc is offline Find More Posts by surfdoc
Reply With Quote
Sign up now
to remove ads between posts
Old Jan 13, 2013, 07:21 PM
Dixie Sky Devils AMA# 1015548
tupeloflyer's Avatar
United States, MS, Tupelo
Joined Oct 2012
1,158 Posts
stupid question, but are you sure your lipo has a charge? do you have a meter or battery tester? if you have voltage and it's connected properly your Rx is bad..
tupeloflyer is offline Find More Posts by tupeloflyer
RCG Plus Member
Latest blog entry: Sig New ARF 4 Star 64
Reply With Quote
Old Jan 13, 2013, 07:25 PM
Registered User
Joined Nov 2008
511 Posts
Make sure your battery plug into the correct connector and always turn the transmitter on first, if the plane don't bind, there should be a little botton switch on the rx for you the press.

Edmond
Edmond Y is offline Find More Posts by Edmond Y
Reply With Quote
Old Jan 13, 2013, 07:26 PM
hjukhjuk
gooby's Avatar
United States, FL
Joined Feb 2012
1,066 Posts
Turn around the servo wire from the esc.
gooby is offline Find More Posts by gooby
Reply With Quote
Old Jan 13, 2013, 07:27 PM
Dixie Sky Devils AMA# 1015548
tupeloflyer's Avatar
United States, MS, Tupelo
Joined Oct 2012
1,158 Posts
you might make sure you esc(speed controller) it's connected to the motor leads, is connected to the reciever correctly the plug has three wires that connects to the Rx, one of them is signal, one is ground, one is volts, it could be plugged in backwards.
tupeloflyer is offline Find More Posts by tupeloflyer
RCG Plus Member
Latest blog entry: Sig New ARF 4 Star 64
Reply With Quote
Old Jan 14, 2013, 01:15 AM
Registered User
San Diego
Joined May 2010
134 Posts
I've had only good CS experience with BH, the two times I needed it. Email with pictures of my issue worked for me.
QuadManiac is offline Find More Posts by QuadManiac
Reply With Quote
Old Jan 14, 2013, 07:53 AM
Registered User
DustBen's Avatar
United States, AL, Gardendale
Joined Dec 2011
2,347 Posts
"Banana Hobby"?
Your post might be applicable to 99% of businesses across the internet.
Your local hobby shop is far more expensive but might be able to hold your hand until you get stuff like your problem figured out.
DustBen is offline Find More Posts by DustBen
Reply With Quote
Old Jan 14, 2013, 11:47 AM
Registered User
Joined Jan 2013
3 Posts
I know the lipo has a charge as the servo's respond when I plug in the battery. There is no identifiable button on the receiver. I know the plug ins to the receiver are all oriented in the right direction because the servo's for the rudder, elevators, etc. respond when battery plugged in. I have tried to connect battery after after turning transmitter on but still nothing. None of the documentation discusses anything related to an esc??
surfdoc is offline Find More Posts by surfdoc
Reply With Quote
Old Jan 14, 2013, 12:22 PM
Hold my beer, now watch this!
United States, IL, Schaumburg
Joined Dec 2012
158 Posts
1. Make sure your lipo is 100% charged
2. Make sure the 3 wire connector from the ESC (that connects to motor) is connected to batt/bind port

Any pics would help. Also BH does suck only 20% success rate with their clients. If you want great service Horizon Hobby front end store for Parkzone E-flight.
Burner147 is offline Find More Posts by Burner147
Reply With Quote
Old Jan 14, 2013, 12:46 PM
Registered User
Evan D's Avatar
Charlotte, NC
Joined Jan 2004
6,177 Posts
You said-
I cannot get the receiver to power on.
When I connect the battery to the plane the receiver led does not come on?
I know the lipo has a charge as the servo's respond when I plug in the battery.
There is no identifiable button on the receiver.
I know the plug ins to the receiver are all oriented in the right direction because the servo's for the rudder, elevators, etc. respond when battery plugged in.
I have tried to connect battery after after turning transmitter on but still nothing.

Are you or are you not getting the servos to respond to moving the transmitter sticks? Getting a twitch whenplugging in the LiPo is not getting response. You need to bind the receiver to the transmitter first. That is in the transmitter instructions. If you can not get it to bind then you probably do have the wires to the receiver backwards.

This is not a easy hobby. You have to have some intelligence and be willing to work through solutions. Jumping immediately to cancelling the charge on your card tells me this hobby may not be for you. All the responses here are spot on. If you can't figure it out with the web help take it to a hobby shop or your local club and get help.
Evan D is online now Find More Posts by Evan D
Reply With Quote
Old Jan 14, 2013, 12:57 PM
Registered User
United States, NC, Troy
Joined Dec 2008
238 Posts
new to hobby

I'll go one step farther. Do NOT try to fly this plane (or any other plane larger than 8" wingspan) by yourself. You WILL crash. Spend some time with an experienced pilot and a lot of time on the simulator for a more successful first flight.

Just sayin' . . . .
iwlf is online now Find More Posts by iwlf
Reply With Quote
Old Jan 14, 2013, 01:17 PM
hjukhjuk
gooby's Avatar
United States, FL
Joined Feb 2012
1,066 Posts
Quote:
Originally Posted by iwlf View Post
I'll go one step farther. Do NOT try to fly this plane (or any other plane larger than 8" wingspan) by yourself. You WILL crash. Spend some time with an experienced pilot and a lot of time on the simulator for a more successful first flight.

Just sayin' . . . .
Not much damage if he does crash, and it will be easily repairable with the epo foam.
gooby is offline Find More Posts by gooby
Reply With Quote
Old Jan 14, 2013, 04:17 PM
Registered User
United States, CA, Oceanside
Joined Apr 2011
5,012 Posts
Well, ya never know. I had a buddy dork in an FMS 800mm P-40 from Banana Hobby. We tracked it down to a bad ESC. The plane was a TOTAL loss so, the quote: "Not much damage if he does crash, and it will be easily repairable with the epo foam." ain't necessarily true.

iwlf is right, most likely that plane is gonna be augered in badly if he goes it alone with that thing.
chucksolo69 is online now Find More Posts by chucksolo69
Reply With Quote
Old Jan 14, 2013, 05:32 PM
Yea, I fly dusty planes..
zeezee's Avatar
United States, LA, Angie
Joined Apr 2009
2,052 Posts
Do not plug 3 wire lead into bat/bind port. Plug into throttle port . Startup: plug bind plug into bat/bind port with rx off. Plug battery in and turn on tx in bind mode. If available read manual for your equipment. You say servo's move. Rx is doing something...ZZee ---PM.. remove bind plug once bound.
zeezee is offline Find More Posts by zeezee
Last edited by zeezee; Jan 14, 2013 at 05:41 PM.
Reply With Quote
Old Jan 14, 2013, 07:18 PM
Registered User
Evan D's Avatar
Charlotte, NC
Joined Jan 2004
6,177 Posts
I really don't think he's gotten to the point the receiver is bound. I think his servos moving is just the power twitch. But, he has taken exception to my post and may not be coming back.
Evan D is online now Find More Posts by Evan D
Reply With Quote
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Discussion banana hobby euro vs hobby lobby eurofighter. mshay Foamy EDFs 9 May 02, 2012 02:42 AM