HobbyKing.com New Products Flash Sale
Reply
Thread Tools
Old Jan 09, 2013, 11:19 AM
Registered User
Joined Jan 2011
14 Posts
Help!
Troubleshooting: Cannot Control Plane

I am flying an FMS Skyraider - 800MM I think - brand new. Build was good and all controls tested good. I am a good micro park flyer pilot and this is my first step up to a slightly larger plane.

Initial flights were bad (pilot error and didn't check CG or secure battery inside plane) and I took a hard landing and lost a prop - went home and had to re-glue the motor mount and try again.

OK - I finally got it off the ground (weather has been horrible here for park flying)... now I need some advice. I flew my other planes to prove that I AM capable of flying... but flying this plane is still like putting socks on a rooster.

Please let me know what to try next.

OK - here is what happens...

Takeoff roll was short and sweet and up it went - I was happy for about 5 seconds. It then started to pitch up then stall out once i hit full throttle at about 15 feet. I couldn't get it to trim fast enough to feel comfortable so I brought it down and landed it.

I then trimmed it a bit on the ground in anticipation - took off again and still at 3/4 throttle it wanted to go nose high - I let it get more altitude and tried to go straight out. I made a slight left bank and it wanted to snap-roll and spiral - so I eased up on the controls. The remainder of the flight was like a rodeo bull ride. Battling between the planes desire to porpoise and spiral down.

There was no gentle bank - there was no straight and level. Finally made a death roll and nose dive into the dirt. Lost another prop and the motor mount seems loose.

What I know -- the control surfaces are in the middle hole and the TX is set up right. I THINK the CG is correct based on what I found online (fingers at the fattest part of the wing - about an inch back from the leading edge, plane upside down balancing) - does it need more nose weight? What else could make it so un-responsive to correction and hard to fly?

I flew my micro park flyer for another 20 minutes, that made it all better. I really want to get this bird flying!!!!! What am I doing wrong??????
bmeeks24 is offline Find More Posts by bmeeks24
Reply With Quote
Sign up now
to remove ads between posts
Old Jan 09, 2013, 11:50 AM
Registered User
Jim Buzzeo's Avatar
Willmar, Minnesota, United States
Joined Sep 2004
159 Posts
it sounds like it's tail heavy... and you allowed it to stall or tried to take off at very near stall speed.
but I also must point out:
"I flew my other planes to prove that I AM capable of flying."

all airplanes do not fly the same.
you're going from a very simple easy to fly trainer (which you've only just learned to fly)
to a full blown, 4 channel (maybe 5 or 6 channel) high powered, high wing loaded warbird
(that hasn't been trimmed) in one fell swoop.

FIRST, adjust the CG so the airplane is SLIGHTLY nose heavy.
(that is, AFTER you've discovered exactly where the CG is supposed to be... )

Second: secure everything inside the airplane. (give the airplane a good SHAKE... that's what's going to happen to it once airborne .. fix /secure anything that moves)
Third: let an EXPERIENCED Pilot (one who has been flying for 4-40 years) fly and trim it for you.

keep flying the trainer airplanes to gain experience

3 months from now AFTER you've gotten more experience give the Skyraider another try.

think about it: you've barely taken the training wheels off your first two wheeler and you're surprised that you're having trouble riding your new 500 horsepower monster.

NO OFFENSE!! :^) we ALL had to learn.
Jim Buzzeo is offline Find More Posts by Jim Buzzeo
Reply With Quote
Old Jan 09, 2013, 11:53 AM
Y=C+I+G
cmdl's Avatar
United States, CA, Rosemead
Joined Jan 2012
5,717 Posts
sounds like a cg issue still. also, move the clevis to the outermost hole on control horn and try - may help.
cmdl is online now Find More Posts by cmdl
Reply With Quote
Old Jan 09, 2013, 01:30 PM
buyer of the farm
United States, FL, DeLand
Joined Mar 2009
3,603 Posts
Quote:
Originally Posted by cmdl View Post
sounds like a cg issue still. also, move the clevis to the outermost hole on control horn and try - may help.
Agree with Jim's advice and yours, with special attention to getting that CG reasonable. Welcome to maiden flight gotchas! Don't panic.
Rockin Robbins is offline Find More Posts by Rockin Robbins
Reply With Quote
Old Jan 09, 2013, 01:32 PM
Registered User
JetPlaneFlyer's Avatar
Aberdeen
Joined Mar 2006
10,470 Posts
I'm assuming you have checked the manual and balanced it as per the recommendation? If so then it sounds like a combination of inexperience with this type of model, and maybe too much throw on the control surfaces and/or not enough exponential.

I've no experience of this particular model but in general these small scale warbirds can often be quite tricky to fly. Depending on what you have flown before you might be biting off more than you can chew.
JetPlaneFlyer is online now Find More Posts by JetPlaneFlyer
Reply With Quote
Old Jan 09, 2013, 02:56 PM
Registered User
Fla.
Joined Apr 2005
952 Posts
You might also want to consider a bit less throttle and a longer take off run . When you add throttle it's going to make the nose go up if you have to much throttle, then you put in some ( To much ) elevator and you are now in trouble ( a stall ) . ENJOY !!! RED
redh is offline Find More Posts by redh
Reply With Quote
Old Jan 09, 2013, 03:11 PM
Registered User
United States, CA, Oceanside
Joined Apr 2011
4,447 Posts
And yet another of the notorious 800mm FMS warbirds "can't get it in the air" stories. At my field, there are 4 of these that have had issues like the ones you describe.
chucksolo69 is online now Find More Posts by chucksolo69
Reply With Quote
Old Jan 09, 2013, 06:19 PM
Space power
cfircav8r's Avatar
United States, IA, Hampton
Joined May 2012
295 Posts
You also had to repair the motor mount right off the bat. You may have added up thrust during the repair, this can give an excessive pitch up response to throttle.
cfircav8r is online now Find More Posts by cfircav8r
Reply With Quote
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Help! [Solved] Cannot flash Hobbyking Multi-Rotor Controller Board V3 Bilow Multirotor Electronics 4 Jul 30, 2012 06:52 AM
Discussion How do you troubleshoot complete loss of control? muidaq Power Systems 20 Jun 25, 2008 12:22 PM
Discussion Converted My Hb Cp2 With Direct Drive Gws But Cannot Control Tail..... agapornis Micro Helis 9 Feb 13, 2006 06:20 AM
Reflex XTR - cannot centre controls wildtech Simulators 12 Jan 15, 2005 06:57 PM