SMALL - espritmodel.com SMALL - Telemetry SMALL - Radio
Reply
Thread Tools
Old Jan 04, 2013, 03:20 AM
Time to learn to fly
Sandav's Avatar
The Netherlands, OV, Zwolle
Joined Feb 2012
215 Posts
Help!
Calibrating ACC not working. FIXED

I've got a big problem with calibrating ACC before flight.
Every time I connect the battery to the system my ACC is way off depending on the angle I keep the frame when connecting the battery. Normally hitting the "calibrate ACC" button (or calibrate by transmitter) takes the artificial horizon back to level but in my case, after moving around a little the artificial horizon returns to the same off-level situation.

The strange thing is, when I disconnect the battery and usb and after that, connect the usb first and after that the battery, all works well

So the order of connecting usb and battery affects the ACC.....

Flight controller is the NanoWii.
MultiWii version is 2.1.

What I did so far.
The NanoWii can be powered two ways, directly from LiPo or by connected esc's, I tried both ways.
I redownloaded the MultiWii 2.1 version and uploaded it to the FC (did this about 10 times or so).

It could be just a little thing that I didn't think about. Maybe I'm blind to the most obvious mistake so any suggestion is welcome.

The left attachment is battery first, the right one is usb first.
Sandav is offline Find More Posts by Sandav
Last edited by Sandav; Jan 05, 2013 at 09:20 AM.
Reply With Quote
Sign up now
to remove ads between posts
Old Jan 04, 2013, 05:50 AM
Registered User
CraigVMN's Avatar
Joined Apr 2012
413 Posts
After connecting the board, you have to press the “read” button to see what’s up with the state of the board. After pressing the calibrate button (while the quad is sitting on a level surface) you then press “write” to make the changes to the board. Then press stop to end communication to the board, then un-plug.
CraigVMN is offline Find More Posts by CraigVMN
Reply With Quote
Old Jan 04, 2013, 07:42 AM
Time to learn to fly
Sandav's Avatar
The Netherlands, OV, Zwolle
Joined Feb 2012
215 Posts
Thanks for the feedback but I did all that .
It's not my first board or quad but this happened to me with my latest build.
Sandav is offline Find More Posts by Sandav
Reply With Quote
Old Jan 05, 2013, 08:56 AM
Time to learn to fly
Sandav's Avatar
The Netherlands, OV, Zwolle
Joined Feb 2012
215 Posts
Found it
Thanks to juuuut in this thread. I moved the quad to soon after plugging in the battery.

So for everybody with a controller that depends on a Leonardo bootloader, keep the quad motionless for a few seconds after plugging in the battery.
It doesn't matter in what position, even upside down is fine.
Sandav is offline Find More Posts by Sandav
Reply With Quote
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Discussion MWC ACC Calibration issues... Solution found.... John Boy Multirotor Talk 2 Aug 08, 2012 10:38 PM
Help! Trying to calibrate ESCs - not working DaMaDo Multirotor Talk 20 Jun 07, 2012 07:03 PM
Question Calibrating ACC takes a long time, normal? jive Multirotor Talk 0 Mar 09, 2012 08:06 PM
Discussion Motor rpm calibration not working hb888 Eagle Tree Systems 4 Oct 30, 2009 07:11 AM
Discussion MK ACC Calibration and Parameters optimisation Manuel Silva Aerial Photography 0 May 18, 2008 06:21 PM