HobbyKing.com New Products Flash Sale
Reply
Thread Tools
Old Dec 07, 2012, 03:56 PM
Registered User
Joined Apr 2008
34 Posts
Discussion
Double horse 9116 tail problem

When I start moving the trottle, the tail motor comes on full speed (it does not track the throttle). I can push the stick all the way to the left and make it turn off, but I can't seem to get it to have more than two speeds, either on or off. I checked all the structures I could think of including gears and wires. Any idea how to fix or test for my solution? I replaced the tail motor, given the common problems they seem to have but the same behavior exist. What can I test or replace to solve the issue.
Gregdoug is offline Find More Posts by Gregdoug
Reply With Quote
Sign up now
to remove ads between posts
Old Dec 07, 2012, 04:04 PM
RTF (Ready to Fragment)
Steve_'s Avatar
United States, WI, Beloit
Joined Nov 2012
4,041 Posts
Did you crash? Mine did that after PCB and / or Gyro damage.

Here is where I have been getting my PCB's, under $16.00 shipped.

http://www.ebay.com/itm/300782014737...84.m1439.l2649

First one took 2 days to get, still waiting for the tha last one I ordered.
Going on 4 days now, I should get it tomorrow.

This seller is in Cali, so you might be able to find something closer.
Steve_ is online now Find More Posts by Steve_
RCG Plus Member
Latest blog entry: Our Day at the Park
Reply With Quote
Old Dec 07, 2012, 04:14 PM
RTF (Ready to Fragment)
Steve_'s Avatar
United States, WI, Beloit
Joined Nov 2012
4,041 Posts
If you were running without the canopy, you don't even have
to crash to lunch your PCB.

All it takes is for the flybar to nick the PCB, and it's toast.

Those surface mount components are no match for a hunk of steel
spinning at 1000+ RPM.
Steve_ is online now Find More Posts by Steve_
RCG Plus Member
Latest blog entry: Our Day at the Park
Reply With Quote
Old Dec 07, 2012, 05:18 PM
Registered User
Joined Apr 2008
34 Posts
I had the canopy on but I did smack into a tree limb. I think that the PCB seems to be the most likely cause as the controller didn't change any settings. I also noticed that the tail motor replacement from HK did not have a plug for the flashing tail light but the tail light is there.... but not on when the heli is started. Not the end of the world but I wonder why the put a light in with no plug?
Gregdoug is offline Find More Posts by Gregdoug
Reply With Quote
Old Dec 07, 2012, 06:42 PM
RTF (Ready to Fragment)
Steve_'s Avatar
United States, WI, Beloit
Joined Nov 2012
4,041 Posts
Either the plug is stuck inside the boom, or it is a factory defect.
All 3 tails I ordered from 2 different sellers have LED's and plugs.

The light, wires and plug from the old boom will swap in fine.

If you don't fly at night, I would remove them altogether.

Removing the pair of wires and plug will save you 3 grams.
Steve_ is online now Find More Posts by Steve_
RCG Plus Member
Latest blog entry: Our Day at the Park
Reply With Quote
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Discussion Double horse 9116 tail problem Gregdoug Beginner Training Area (Heli-Electric) 5 Nov 14, 2012 12:20 AM
Discussion My Double Horse 9116 have this problem louai Beginner Training Area (Heli-Electric) 1 Aug 03, 2012 11:42 AM
Discussion How to adjust tail rotor on 9116 double horse Cullen1 Beginner Training Area (Heli-Electric) 5 Jul 29, 2012 11:51 AM
Question Turnigy 9x and Double Horse 9116 rudder problem Doc Monty Beginner Training Area (Heli-Electric) 3 May 16, 2012 11:44 PM
Discussion 9116 Double Horse Daza1964 Beginner Training Area (Heli-Electric) 1 Mar 26, 2012 10:22 AM