HobbyKing.com New Products Flash Sale
Reply
Thread Tools
Old Feb 13, 2013, 12:03 PM
Registered User
Joined Mar 2011
199 Posts
Allright there was a connection error.
Now I fixed it and after writing I get this error message.
And the Tx still gives no sign of life.
avrdude: Version 5.11, compiled on Sep 2 2011 at 19:38:36
Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/
Copyright (c) 2007-2009 Joerg Wunsch

System wide configuration file is "C:\Download\Arduino\hardware/tools/avr/etc/avrdude.conf"

Using Port : usb
Using Programmer : usbasp
avrdude: seen device from vendor ->www.fischl.de<-
avrdude: seen product ->USBasp<-
AVR Part : ATMEGA328P
Chip Erase delay : 9000 us
PAGEL : PD7
BS2 : PC2
RESET disposition : dedicated
RETRY pulse : SCK
serial program mode : yes
parallel program mode : yes
Timeout : 200
StabDelay : 100
CmdexeDelay : 25
SyncLoops : 32
ByteDelay : 0
PollIndex : 3
PollValue : 0x53
Memory Detail :

Block Poll Page Polled
Memory Type Mode Delay Size Indx Paged Size Size #Pages MinW MaxW ReadBack
----------- ---- ----- ----- ---- ------ ------ ---- ------ ----- ----- ---------
eeprom 65 20 4 0 no 1024 4 0 3600 3600 0xff 0xff
Block Poll Page Polled
Memory Type Mode Delay Size Indx Paged Size Size #Pages MinW MaxW ReadBack
----------- ---- ----- ----- ---- ------ ------ ---- ------ ----- ----- ---------
flash 65 6 128 0 yes 32768 128 256 4500 4500 0xff 0xff
Block Poll Page Polled
Memory Type Mode Delay Size Indx Paged Size Size #Pages MinW MaxW ReadBack
----------- ---- ----- ----- ---- ------ ------ ---- ------ ----- ----- ---------
lfuse 0 0 0 0 no 1 0 0 4500 4500 0x00 0x00
Block Poll Page Polled
Memory Type Mode Delay Size Indx Paged Size Size #Pages MinW MaxW ReadBack
----------- ---- ----- ----- ---- ------ ------ ---- ------ ----- ----- ---------
hfuse 0 0 0 0 no 1 0 0 4500 4500 0x00 0x00
Block Poll Page Polled
Memory Type Mode Delay Size Indx Paged Size Size #Pages MinW MaxW ReadBack
----------- ---- ----- ----- ---- ------ ------ ---- ------ ----- ----- ---------
efuse 0 0 0 0 no 1 0 0 4500 4500 0x00 0x00
Block Poll Page Polled
Memory Type Mode Delay Size Indx Paged Size Size #Pages MinW MaxW ReadBack
----------- ---- ----- ----- ---- ------ ------ ---- ------ ----- ----- ---------
lock 0 0 0 0 no 1 0 0 4500 4500 0x00 0x00
Block Poll Page Polled
Memory Type Mode Delay Size Indx Paged Size Size #Pages MinW MaxW ReadBack
----------- ---- ----- ----- ---- ------ ------ ---- ------ ----- ----- ---------
calibration 0 0 0 0 no 1 0 0 0 0 0x00 0x00
Block Poll Page Polled
Memory Type Mode Delay Size Indx Paged Size Size #Pages MinW MaxW ReadBack
----------- ---- ----- ----- ---- ------ ------ ---- ------ ----- ----- ---------
signature 0 0 0 0 no 3 0 0 0 0 0x00 0x00

Programmer Type : usbasp
Description : USBasp, http://www.fischl.de/usbasp/

avrdude: auto set sck period (because given equals null)
avrdude: warning: cannot set sck period. please check for usbasp firmware update.
avrdude: AVR device initialized and ready to accept instructions

Reading | ################################################## | 100% 0.02s

avrdude: Device signature = 0x1e950f
avrdude: NOTE: FLASH memory has been specified, an erase cycle will be performed
To disable this feature, specify the -D option.
avrdude: erasing chip
avrdude: auto set sck period (because given equals null)
avrdude: warning: cannot set sck period. please check for usbasp firmware update.
avrdude: reading input file "C:\DOCUME~1\Me\LOCALS~1\Temp\build292584824847285 8452.tmp\openLRSng.cpp.hex"
avrdude: writing flash (9354 bytes):

Writing | ################################################## | 100% 5.31s

avrdude: 9354 bytes of flash written
avrdude: verifying flash memory against C:\DOCUME~1\Me\LOCALS~1\Temp\build2925848248472858 452.tmp\openLRSng.cpp.hex:
avrdude: load data flash data from input file C:\DOCUME~1\Me\LOCALS~1\Temp\build2925848248472858 452.tmp\openLRSng.cpp.hex:
avrdude: input file C:\DOCUME~1\Me\LOCALS~1\Temp\build2925848248472858 452.tmp\openLRSng.cpp.hex contains 9354 bytes
avrdude: reading on-chip flash data:

Reading | ################################################## | 100% 5.05s

avrdude: verifying ...
avrdude: verification error, first mismatch at byte 0x0000
0x0c != 0x00
avrdude: verification error; content mismatch

avrdude done. Thank you.
Sp1k3 is offline Find More Posts by Sp1k3
Reply With Quote
Sign up now
to remove ads between posts
Old Feb 13, 2013, 12:08 PM
Registered User
Joined May 2011
24 Posts
Hi,

My HK OpenLRS clones will arrive tomorrow. Thank you in advance for the advice I have seen in this forum.

regards

Alan
alan.powell is offline Find More Posts by alan.powell
Reply With Quote
Old Feb 13, 2013, 01:41 PM
kha
openLRSng haxor
Finland, Espoo
Joined Mar 2011
1,908 Posts
Quote:
Originally Posted by Sp1k3 View Post
Allright there was a connection error. ...
...
avrdude: verification error, first mismatch at byte 0x0000
0x0c != 0x00
avrdude: verification error; content mismatch

avrdude done. Thank you.

I would start by checking the voltage during programming, it should be stable 3v3.
kha is online now Find More Posts by kha
RCG Plus Member
Reply With Quote
Old Feb 13, 2013, 01:56 PM
Registered User
Joined Mar 2011
199 Posts
Quote:
Originally Posted by kha View Post
I would start by checking the voltage during programming, it should be stable 3v3.
I'm using the internal supply. I simply disconnect the 5V supply from the USBASP and I connect a normal battery pack between battery line and gnd on the Rx, and the same I do for the Tx.
Do you think I should supply this external to 3.3v?
I'm not sure I have a 3.3V regulator, but I can check...
But shouldn't the internal regulator be sufficient?
Thanks
Sp1k3 is offline Find More Posts by Sp1k3
Reply With Quote
Old Feb 14, 2013, 01:07 AM
Registered User
Joined Mar 2011
199 Posts
Quote:
Originally Posted by kha View Post
I would start by checking the voltage during programming, it should be stable 3v3.
I Tried supplying with external 3.3V, now I'm getting the same error as when there was a connection problem...

I have the feeling something is burned.

Just a question, I looked up the specs, and they say the uC can handle up to 5V?
Why cannt I supply the USBasp directly with 5V?
Sp1k3 is offline Find More Posts by Sp1k3
Reply With Quote
Old Feb 14, 2013, 01:21 AM
kha
openLRSng haxor
Finland, Espoo
Joined Mar 2011
1,908 Posts
Quote:
Originally Posted by Sp1k3 View Post
Just a question, I looked up the specs, and they say the uC can handle up to 5V?
Why cannt I supply the USBasp directly with 5V?
The rfm22 module is at same voltage and it cant handle 5v.
kha is online now Find More Posts by kha
RCG Plus Member
Reply With Quote
Old Feb 14, 2013, 01:33 AM
Registered User
Joined Mar 2011
199 Posts
Alright I ordered an FDTI 3.3 and some replacement uC so that I can replace them on the boards just in case they are gone.
Sp1k3 is offline Find More Posts by Sp1k3
Reply With Quote
Old Feb 14, 2013, 06:51 AM
Registered User
Joined Mar 2011
199 Posts
Quote:
Originally Posted by kha View Post
The rfm22 module is at same voltage and it cant handle 5v.
ahh darn... so I probably blew the rfm22 and not the atmega chip?! I should have waited before ordering it...
Sp1k3 is offline Find More Posts by Sp1k3
Reply With Quote
Old Feb 14, 2013, 07:17 AM
Always learning..
Jumpy07's Avatar
United Kingdom
Joined Aug 2012
404 Posts
Apologies, posted this question in the 9XR thread but didnt get a response..

I have a 9XR and the Orange Openlrs kit on the way..

The antenna placement on the TX module is a bit naff.. looking at the TX antenna SMA socket.. it looks as if its on a pigtail onto the board of the TX module.

Has anyone fitted a longer pigtail and fitted an SMA socket on the 9XR body in a better location .. and used an antenna such as the diamond ?

Been pondering over the 9XR pics with the back off to see if there is space ?

Many thanks in advance
Jumpy07 is online now Find More Posts by Jumpy07
Reply With Quote
Old Feb 14, 2013, 07:18 AM
throw new IOPilotException();
IceWind's Avatar
Ireland, County Dublin, Dublin
Joined Feb 2005
2,650 Posts
Quote:
Originally Posted by Sp1k3 View Post
ahh darn... so I probably blew the rfm22 and not the atmega chip?! I should have waited before ordering it...
Oh yeah, the Atmega handles the 5v, it's the RFM22 that will fry if powered with more than 3.3v.
IceWind is online now Find More Posts by IceWind
Reply With Quote
Old Feb 14, 2013, 09:11 AM
Registered User
Joined Dec 2008
28 Posts
Is there a way to get a linear RSSI voltage output for connecting to an OSD on openlrsng?
garbonzo is online now Find More Posts by garbonzo
Reply With Quote
Old Feb 14, 2013, 10:30 AM
Always learning..
Jumpy07's Avatar
United Kingdom
Joined Aug 2012
404 Posts
Quote:
Originally Posted by garbonzo View Post
Is there a way to get a linear RSSI voltage output for connecting to an OSD on openlrsng?

Simple RC filter like this one should work.. works on my Frsky RX... waiting on my Orange OpenLRS to try it

Jumpy07 is online now Find More Posts by Jumpy07
Reply With Quote
Old Feb 14, 2013, 04:50 PM
Registered User
Xnaron's Avatar
Joined Feb 2003
3,759 Posts
Quote:
Originally Posted by Jumpy07 View Post
Apologies, posted this question in the 9XR thread but didnt get a response..

I have a 9XR and the Orange Openlrs kit on the way..

The antenna placement on the TX module is a bit naff.. looking at the TX antenna SMA socket.. it looks as if its on a pigtail onto the board of the TX module.

Has anyone fitted a longer pigtail and fitted an SMA socket on the 9XR body in a better location .. and used an antenna such as the diamond ?

Been pondering over the 9XR pics with the back off to see if there is space ?

Many thanks in advance
I don't think it would be hard to do this. I'd like to do similar with mine.

Has anyone tried these antennas? http://www.ebay.com/itm/433Mhz-anten...item2577627cb1
With the long 3M cable you could stick it up on a pole.
Xnaron is offline Find More Posts by Xnaron
Last edited by Xnaron; Feb 14, 2013 at 04:58 PM.
Reply With Quote
Old Feb 15, 2013, 04:24 AM
Always learning..
Jumpy07's Avatar
United Kingdom
Joined Aug 2012
404 Posts
Quote:
Originally Posted by Xnaron View Post
I don't think it would be hard to do this. I'd like to do similar with mine.

Has anyone tried these antennas? http://www.ebay.com/itm/433Mhz-anten...item2577627cb1
With the long 3M cable you could stick it up on a pole.

I bought one of these for the TX : http://www.radioworld.co.uk/catalog/...c1fec48a9917ac

I have made up some a simple wire antennas in a straw tube with SMA plug for the RX.. should be much better than the supplied antennas. See this guide: http://rcexplorer.se/diy/2011/06/diy...-fpv-antennas/

Also plenty of "Sander" style antennas on fleabay http://www.ebay.co.uk/itm/Sander-Sty...item2ec647e7a1
Jumpy07 is online now Find More Posts by Jumpy07
Reply With Quote
Old Feb 15, 2013, 04:28 AM
Registered User
Joined Mar 2012
30 Posts
I just ordered my Orange Tx/Rx 433 setup for a build coming up. Wanted to thank those here working on the OpenLRSng. Looks very promising. I was wondering can I put the RSSI to my FY32AP w/ Hornet OSD?

I have a 9X transmitter on stock firmware still. Going to flash it up and put the back light in it once I get my order from HK. I'll be running with a 1.3ghz RMRC with saw for video. Is their any other filters I need to either make or buy to help with range? I'm also going to check my orange RX/TX for bad solder joints and fix them up before I ever even power them up. Just finished reading this whole thread and I think that part has gotten lost a few pages back and could be some of the reasons why some people are having range issues.
Maglin is offline Find More Posts by Maglin
Reply With Quote
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Wanted Anyone got a good 433mhz UHF RX Antenna? wamdue FPV Equipment (FS/W) 3 Feb 24, 2014 02:19 PM
Question 'Sander' 1/4 wave monopole - correct length for 433MHz UHF? Kahnx FPV Equipment 11 Dec 23, 2013 09:19 AM
For Sale Chainlink UHF system + few matching Rx's i3dm FPV Equipment (FS/W) 0 Apr 22, 2012 06:58 AM
Discussion stiff antenna for 433Mhz UHF Rx ? i3dm FPV Talk 14 Feb 17, 2012 01:25 PM
Sold HK "Orange" Satellite for HK "Orange" Rx rikybob Aircraft - General - Radio Equipment (FS/W) 1 Jan 29, 2011 03:19 PM