HobbyKing.com New Products Flash Sale
Reply
Thread Tools
Old Nov 13, 2012, 05:51 AM
Registered User
Joined Sep 2012
7 Posts
Discussion
AR600 not working after servo hotplug

I have a problem with my Spektrum AR600 receiver. It ceased to work after (at least I think) I connected a servo while the receiver was on.

Now the orange led wont lit, nor it will flash when I turn on the receiver with a bind plug connected. Moreover the red hold led blink once during power-up.

Have anyone encountered similar problem? Btw. the servo is OK, I also checked the power supply .. stable 5V.
Grawp is offline Find More Posts by Grawp
Reply With Quote
Sign up now
to remove ads between posts
Old Nov 13, 2012, 06:29 AM
59 years of RC flying
Daedalus66's Avatar
Canada, ON, Ottawa
Joined Feb 2006
16,115 Posts
Plugging in a servo while the receiver is powered up should not cause a problem unless the servo is faulty (which you say is not the case).

I would go back to basics, make sure your power supply (4.8 volt battery or ESC) is working properly and plugged in the right way round (the most common mistake). Also check that the bind plug is not defective (try another or check continuity).

If applying power with the bind plug in place does not produce rapid flashing of the orange light, the receiver is not functioning properly and should go back to Horizon Hobby service. No point in any further testing.
Daedalus66 is offline Find More Posts by Daedalus66
Reply With Quote
Old Nov 13, 2012, 06:19 PM
Registered User
Joined Sep 2012
7 Posts
I've tested the power supply and bind plug on a new AR6210 that I just bought. So my AR600 is dead.
Anyway I'd like to know why it broke in the first place.
Grawp is offline Find More Posts by Grawp
Reply With Quote
Old Nov 13, 2012, 06:52 PM
Air, Ground & Water
freechip's Avatar
Canada, ON, Rockland
Joined Aug 2008
23,511 Posts
Send it to HH for service/inspection and ask that you be notified of what was/is the problem.

Not much we can do here on the other side of the screen.
I've connected and disconnected servos from a powered setup numerous time and never had any problems personaly.
freechip is online now Find More Posts by freechip
Reply With Quote
Old Nov 13, 2012, 07:02 PM
59 years of RC flying
Daedalus66's Avatar
Canada, ON, Ottawa
Joined Feb 2006
16,115 Posts
Just send to Horizon. Good chance they'll replace it, no questions asked.
Daedalus66 is offline Find More Posts by Daedalus66
Reply With Quote
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Help! Servos work with Servo tester but not with Receiver?? mejmea Power Systems 0 Mar 18, 2012 12:18 PM
Discussion Range Video Rx not working after storage blade thrasher FPV Talk 2 Mar 07, 2010 03:04 PM
Discussion Help after a minor crash my gyro e-sky is not working FedericoA Micro Helis 2 Jul 28, 2007 05:10 AM
Discussion Radio Fell Down!!!! Not Working Properly After That... indian_radio Radios 1 Dec 31, 2006 03:25 AM
Discussion Gyro not working correctly after a crash Powerkiter Mini Helis 13 Oct 11, 2006 04:12 AM