HobbyKing.com New Products Flash Sale
Reply
Thread Tools
Old Nov 02, 2012, 01:30 PM
Registered User
United Kingdom, Scotland, Argyll and Bute
Joined Oct 2012
647 Posts
Help!
s033g -27mhz to 2.4ghz

Can anyone help please? I've just removed the 27mhz pcb from my s033g and fitted a 2.4mhz board from a DH 9118 which runs the same 390 mains and n20 tail motors at the same 7.4v. Everything plugs in exactly the same. However, when the throttle stick was moved smoke came from the little black suppresser things on the motors. I immediatly stopped and unplugged the motors from the board to check the voltage coming out.I have proportional voltage coming from one but nothing from the other. I know the motors WERE good but now they are both dead. If the polarity was wrong to the motors? would'nt they just run backwards ?When I checked the voltage out of the board using the red wire from the motor as the assumed live in showed it as negative. Could it be that some strange reason they have changed the polarity out of the plugs and if so is this why the motors smoked?The tail motor works ok but forward and reverse are the wrong way round?
drambuidhe is offline Find More Posts by drambuidhe
Reply With Quote
Sign up now
to remove ads between posts
Old Nov 02, 2012, 01:42 PM
Registered User
Joined Oct 2012
37 Posts
Could be that you blew those black diodes on top of the motors. - on account of reversed voltage as you said. If so, then the motors are probably ok, but not the diodes

If you can replace them with something similar you may be OK. Just a suggestion. I'm no expert.
Boris13 is offline Find More Posts by Boris13
Reply With Quote
Old Nov 02, 2012, 02:01 PM
Registered User
United Kingdom, Scotland, Argyll and Bute
Joined Oct 2012
647 Posts
Yes I think you are right.The cunning g-ts have altered the polarity ouputs.I've no out put from one plug now so what would have blown on the pcb and can it be repaired? Iblew one of those suppresser things once before but just pinched one off a worn out spare which cured it , so hopefully the motors are ok.
drambuidhe is offline Find More Posts by drambuidhe
Reply With Quote
Old Nov 02, 2012, 02:04 PM
Registered User
Joined Oct 2012
37 Posts
Yep, maybe the output transistors could be damaged too, if your unlucky. Think they're usually FET types.
Boris13 is offline Find More Posts by Boris13
Reply With Quote
Old Nov 02, 2012, 02:27 PM
Registered User
United Kingdom, Scotland, Argyll and Bute
Joined Oct 2012
647 Posts
Are they the big black square things with metal heatsinks or the smaller semi circular thingsof which there are four?? Having just waited 4 weeks for this pcb from China I'm hoping I can repair it. Especially since its all an experiment and the pcb may not last long on the s033g anyway. I really hope I'm not gona have to buy another
drambuidhe is offline Find More Posts by drambuidhe
Reply With Quote
Old Nov 02, 2012, 05:59 PM
Registered User
Joined Oct 2012
37 Posts
I'm pretty sure they're the big ones with the heat sinks, though I've never replaced these myself.

Just a thought, you might be able to use the transistors from your old FM receiver....
They may even be idenentical to those used on the 2.4G pcb.
You need to read the numbers written on them.
Boris13 is offline Find More Posts by Boris13
Reply With Quote
Old Nov 03, 2012, 03:14 PM
Registered User
United Kingdom, Scotland, Argyll and Bute
Joined Oct 2012
647 Posts
Quote:
Originally Posted by Boris13 View Post
I'm pretty sure they're the big ones with the heat sinks, though I've never replaced these myself.

Just a thought, you might be able to use the transistors from your old FM receiver....
They may even be idenentical to those used on the 2.4G pcb.
You need to read the numbers written on them.
I think had I connected the motors up the otherway round all would have been good.I've ordered a replacement so will now have to be patient and try again later. Hows the s33? do you think it's better than the 33g?Thanks for your help.
drambuidhe is offline Find More Posts by drambuidhe
Reply With Quote
Old Nov 03, 2012, 03:24 PM
Registered User
United Kingdom, Scotland, Argyll and Bute
Joined Oct 2012
647 Posts
Quote:
Originally Posted by drambuidhe View Post
I think had I connected the motors up the otherway round all would have been good.I've ordered a replacement so will now have to be patient and try again later. Hows the s33? do you think it's better than the 33g?Thanks for your help.
sorry It's not you with the new s33 ,think I'm having a senior moment!!
drambuidhe is offline Find More Posts by drambuidhe
Reply With Quote
Old Nov 03, 2012, 04:01 PM
Registered User
Joined Oct 2012
37 Posts
Quote:
Originally Posted by drambuidhe View Post
sorry It's not you with the new s33 ,think I'm having a senior moment!!
Yep, I don't even have one.
I'm only here because the title looked interesting.
Boris13 is offline Find More Posts by Boris13
Reply With Quote
Old Nov 03, 2012, 05:52 PM
Registered User
United Kingdom, Scotland, Argyll and Bute
Joined Oct 2012
647 Posts
What I don't understand is why these components blow if the polarity is reversed.I used to make model boats using similiar motors with noise suppressors on them and they reversed??
drambuidhe is offline Find More Posts by drambuidhe
Reply With Quote
Old Nov 03, 2012, 09:54 PM
Tuguegarao City Philippines
xtian3188's Avatar
Joined Sep 2012
364 Posts
i got the same problem recently also. the small black square thingy (diode) on the motor pcb smoked and i managed to fix it. here are some photos.


edit: it should be diode in the middle with the gray strip pointing to the positive terminal of the motors (white and red).
xtian3188 is offline Find More Posts by xtian3188
Last edited by xtian3188; Nov 04, 2012 at 12:57 AM.
Reply With Quote
Old Nov 04, 2012, 11:57 AM
Registered User
United Kingdom, Scotland, Argyll and Bute
Joined Oct 2012
647 Posts
Thanks a lot for that! Two questions though. Where can I get those from and do they allow for a wally reversing their polarity?? P.s how did you blow yours in the first place?Cheers!
drambuidhe is offline Find More Posts by drambuidhe
Reply With Quote
Old Nov 04, 2012, 03:35 PM
Tuguegarao City Philippines
xtian3188's Avatar
Joined Sep 2012
364 Posts
you can get those at your local electronics shop. any small diode will do. the round one is ceramic disk capacitor (i think). the diode act as a one way valve so you dont want it to be reversed. i tried using old esc from my rc car to run my s033g then i accidentally reversed the polarity on one motor.
xtian3188 is offline Find More Posts by xtian3188
Reply With Quote
Old Nov 07, 2012, 06:47 AM
DWTRIAC23
United States, MA, North Andover
Joined Feb 2012
173 Posts
diodes have a polarity, ceramic disc capacitors do not, if that helps
dwtriac23 is offline Find More Posts by dwtriac23
Reply With Quote
Old Nov 23, 2012, 04:31 PM
Registered User
United Kingdom, Scotland, Argyll and Bute
Joined Oct 2012
647 Posts
s033g 27-2.4

Well looks like I'll be back in the air tomorrow, weather depending. However,not on 2.4-YET! My 27mhz replacement pcb turned up today but still no signs of the long awaited 9118 2.4ghz pcb to replace the one I shorted out!! At least I can see if the floats I've made are going to work. I've tried them tonight indoors and the signs aren't good, looks like even at around 100g they are taking some lifting
drambuidhe is offline Find More Posts by drambuidhe
Reply With Quote
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
For Sale 2.4ghz amp for boosted 2.4ghz applications 558th_AV8R FPV Equipment (FS/W) 5 Mar 16, 2012 04:04 PM
Found 27mhz am rx or 2.4ghz tx/rx kennyhoc3 Aircraft - General - Radio Equipment (FS/W) 0 Nov 27, 2010 04:20 AM
Yippee! 2.4Ghz conversion of TRAXXAS TQ2 TQ3 27MHz RADIO supi7 Car Talk 11 Oct 10, 2009 03:22 AM
Sold Futaba Magnum 3PK 27MHz plus 2.4GHz Jim Frahm Cars - Cars and Parts (FS/W) 0 Mar 03, 2008 10:14 AM