Espritmodel.com Telemetry Radio
Reply
Thread Tools
Old Oct 06, 2012, 07:45 AM
Registered User
Joined Feb 2012
16 Posts
Help!
PROBLEM on Crius AIO Pro Y6 With MegaPirate NG 2.7 R4.

When I hold it it looks like it wants to fly, but as soon as I give it a little more remote input it reacts pretty violently.
The general reactions on tilting the frame seem to be fine. I tried stable and acro mode- pretty much the same.
Also extremely violent reaction to YAW- through remote in or when I yaw the frame by hand it feels like it wants to flip.
I tried to change the PID values A LOT- still no big difference.


My Setup:

- pretty stiff Y6 Frame, arm lenght 21cm
- Turnigy 2822/17 1100KV Motors
- 8x4.5 Props
- Turnigy Plush 10A ESC connected to 2,3,5,6,7,8 according to "Crius All in One Pro v1.3docx"
- Frsky PPM Sum receiver connected to Throttle port
- total weight around

http://www.google.de/url?sa=t&rct=j&...7Ei6cvhu4lg7lg.
(I think with the new SW version I do not have to make the changes described in that document to the APM_Config.h any more- correct?)

In the APM Planner Mav 1.0 / 1.2.13 everything looks good.
I get reasonable remote values,
I was able to calibrate the remote, the ESCs were calibrated before with a servo- tester.
The CHNout values also look reasonable to me (?).



With Multiwii 2.1 (PPM on RX1, motor connections according to Multi Wii) it works fine and flies pretty stable even with preset PID values.


Does somebody have an idea on this- or even better- IS there somebody form the HAMBURG, GERMANY area to meet up and give me some "hands on" support?
I am really stuck and even though it works fine with MultiWii I would love to use MegaPirate because I already built quite a lot MultiWiis (and love them...)!


THANKS
RQuad is offline Find More Posts by RQuad
Reply With Quote
Sign up now
to remove ads between posts
Old Oct 06, 2012, 11:46 AM
Registered User
Joined Jul 2007
76 Posts
Could you post a video of how it reacts.
I build a Y6 using Openpilot. It flies lie a dream, check the attached video:
CC3d First outdoor hover (1 min 8 sec)

My settings are:
Hextronix Dt700
simon flashed F-30
Apc 10 x 4.7
I use the Futaba radio
roxyboby is offline Find More Posts by roxyboby
Reply With Quote
Old Nov 19, 2012, 08:07 AM
Click eagle to read my blog
jabram's Avatar
Australia, NSW, Kendall
Joined Jul 2012
4,970 Posts
I have seen exactly that before not on Y but I am certain you have the same problem.

Check ESC calibration - individually if you want to get it right.

Make sure your RC TX has NO TRIM set at all, not even Sub trim

Then do the radio calibration

If you do that I am certain you will find it behaving like a completely different beast.

The clue is the output PWM values should be real close to each other when the frame is level on the ground.
jabram is offline Find More Posts by jabram
RCG Plus Member
Last edited by jabram; Nov 19, 2012 at 09:00 AM.
Reply With Quote
Old Jan 22, 2013, 12:13 AM
Registered User
marvin081's Avatar
United States, TX, Laredo
Joined Dec 2011
63 Posts
@RQuad

Hi did u find a solution to your problem i just built a Y6 and i am experiencing the same behavior as yours using megapirateng. I still have to test multiwii software.

Thanks
marvin081 is online now Find More Posts by marvin081
Reply With Quote
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Discussion APM2.5 vs CRIUS aio pro little nellie Multirotor Talk 43 Dec 12, 2012 11:39 AM
Discussion Crius All in one Pro with Attopilot Voltage Sensor Megapirate? flippergrz Multirotor Electronics 3 Oct 03, 2012 04:22 PM
Question MegaPirateNG 2.7 R4 on Y6: motor directions RQuad Multirotor Electronics 0 Oct 03, 2012 02:05 PM
Help! CRIUS PRO with ArduCopterNG V2.7R1a by JLN on Y6: just 4 motor outputs working RQuad Multirotor Electronics 2 Oct 03, 2012 02:02 PM
Help! Crius MW AIO Pro Tx, Rx flash but no up-dates Flying Canuck Multirotor Electronics 3 Aug 23, 2012 04:38 PM