HobbyKing.com New Products Flash Sale
Reply
Thread Tools
Old Jan 29, 2013, 04:53 PM
Registered User
Joined Jan 2013
15 Posts
Quote:
Originally Posted by skippcj View Post
Hi just received my x4 tonight but have not managed to get it to bind.

The first time i connected the battery on the x4 I reversed the polarity (propellers spun),will this have damaged it?
Yes. Handy with a soldering iron? This should fix it up:

http://www.ebay.co.uk/itm/Hubsan-X4-...-/271126774783
tttonyyy is offline Find More Posts by tttonyyy
Reply With Quote
Sign up now
to remove ads between posts
Old Jan 29, 2013, 05:03 PM
Happy Holidays
AnthonysQuad's Avatar
Joined Jan 2013
961 Posts
Oh so he pluged in the battery wrong?<-----serious question
AnthonysQuad is offline Find More Posts by AnthonysQuad
Reply With Quote
Old Jan 29, 2013, 05:05 PM
Tri-Quad-Hexa-Octo-copters!!
United States, TX, San Antonio
Joined Feb 2007
14,410 Posts
Gents,
Banggood sells the X4 FCB for $11.80 shipped: http://www.banggood.com/Wholesale-Hu...4-p-63729.html
Cheers
Jim
Quadrocopter and Tricopter Info Mega Link Index
Quote:
Originally Posted by tttonyyy View Post
Yes. Handy with a soldering iron? This should fix it up:

http://www.ebay.co.uk/itm/Hubsan-X4-...-/271126774783
jesolins is offline Find More Posts by jesolins
Reply With Quote
Old Jan 29, 2013, 05:15 PM
Ain't crashing often anymore
mikefromgermany's Avatar
Germany, Berlin
Joined Jun 2012
3,190 Posts
Quote:
Originally Posted by AnthonysQuad View Post
Oh so he pluged in the battery wrong?<-----serious question
Yupp.
May also happen if you buy certain third party batts with changed polarity in the Losi plugs..
So ALWAYS check the plugs for polarity! ( it may become a "4 weeks waiting and paying 11.80 USD" mistake not doing so)

-mike-
mikefromgermany is offline Find More Posts by mikefromgermany
RCG Plus Member
Old Jan 29, 2013, 05:26 PM
Registered User
Joined Aug 2012
27 Posts
Quote:
Originally Posted by mikefromgermany View Post
Chances are you bricked it.
-mike-
Yeah, very sad if that's the case. As my engineer friend once told me:
"It won't live if you let the smoke out."

You can buy an new control board from Banggood or RC-Hawk.com. They aren't too expensive but I'm guessing its delicate soldering. I put a new motor in mine and I almost needed tweezers. If you are really desperate to fly ( I was when I got mine) I could sell you my extra control board and just order another one for me when I order new motors.
flyhigh42 is offline Find More Posts by flyhigh42
Reply With Quote
Old Jan 29, 2013, 05:29 PM
Registered User
Joined Aug 2012
27 Posts
Quote:
Originally Posted by Jakk View Post
Sounds like you may have a motor going bad, I had a similar problem with mine where it would fly for a bit then just loose power even at 100% throttle and drop to the floor. All the props were spinning but no power to lift off, the motor finally died completely and I replaced it. Flys fine again...
Yup - that's what happened to mine. Started flying crazy then barely at all.. anyone have a video on good ways to solder those tiny red / blue wires? I'll be ordering new motors soon!
flyhigh42 is offline Find More Posts by flyhigh42
Reply With Quote
Old Jan 29, 2013, 05:37 PM
Registered User
Joined Sep 2010
74 Posts
Quote:
Originally Posted by flyhigh42 View Post
Yup - that's what happened to mine. Started flying crazy then barely at all.. anyone have a video on good ways to solder those tiny red / blue wires? I'll be ordering new motors soon!
It's not to bad, I installed the motor and ran the wires to the board through the leg then cut them to length and with the help of the Hakko soldering station and a pair of small needle nose pliers attached them to the board. Flies like new again...
Jakk is offline Find More Posts by Jakk
Reply With Quote
Old Jan 29, 2013, 05:40 PM
Ain't crashing often anymore
mikefromgermany's Avatar
Germany, Berlin
Joined Jun 2012
3,190 Posts
Quote:
Originally Posted by flyhigh42 View Post
Yup - that's what happened to mine. Started flying crazy then barely at all.. anyone have a video on good ways to solder those tiny red / blue wires? I'll be ordering new motors soon!
Tiny? You're kidding me.
Take a soldering iron with a fine CLEAN tip, give every pad a short touch to remove the old wire - take the new wires, tin the ends and you are ready to go for the next short touch on the pads to solder the new wires.
Peace of cake. Nothing to fear.

-mike-
mikefromgermany is offline Find More Posts by mikefromgermany
RCG Plus Member
Old Jan 29, 2013, 11:54 PM
KDS450QS(ZYX4),V977,CX-20
FyreSG's Avatar
United States, CA, Monterey
Joined Apr 2012
4,564 Posts
How I "fixed" my V939 board after plugging in a battery of the opposite polarity: http://www.rcgroups.com/forums/showp...&postcount=485 I'm not sure if it would work for the X4.
FyreSG is online now Find More Posts by FyreSG
Reply With Quote
Old Jan 30, 2013, 04:11 AM
WRX STI V - EJ22 - 35.3 PSI
Ayodhya's Avatar
Malaysia, Selangor, Puchong
Joined Nov 2012
874 Posts
I'm so used to the the x4 now , only run expert mode I did a double flip today..no clue how...:what:
All rates maxed out to 100 flies like a baby doing figure 8s!
Ayodhya is offline Find More Posts by Ayodhya
Reply With Quote
Old Jan 30, 2013, 05:10 AM
Registered User
Joined Jan 2013
2 Posts
Quote:
Originally Posted by tttonyyy View Post
Yes. Handy with a soldering iron? This should fix it up:

http://www.ebay.co.uk/itm/Hubsan-X4-...-/271126774783
Thanks for the solution, last time I used a soldering iron I set fire to a table!

But I know a man that can.


Thanks to all else that replied also.
skippcj is offline Find More Posts by skippcj
Reply With Quote
Old Jan 30, 2013, 07:17 AM
WRX STI V - EJ22 - 35.3 PSI
Ayodhya's Avatar
Malaysia, Selangor, Puchong
Joined Nov 2012
874 Posts
Hey guys, my x4 didn't lift off the ground till I give throttle to around 69 to 70. Also when I bring it to 50 once in the air, it begins a slow decent while going back a little. Is that normal?
Ayodhya is offline Find More Posts by Ayodhya
Reply With Quote
Old Jan 30, 2013, 07:27 AM
Ain't crashing often anymore
mikefromgermany's Avatar
Germany, Berlin
Joined Jun 2012
3,190 Posts
Quote:
Originally Posted by Ayodhya View Post
Hey guys, my x4 didn't lift off the ground till I give throttle to around 69 to 70. Also when I bring it to 50 once in the air, it begins a slow decent while going back a little. Is that normal?
  1. Check battery for being dead (one charge/discharge cycle with your computerised charger - read the useable mAH - if the useable capacity is less than 80% of the printed on cap - discharge the batt.
  2. Check all motors for binding. Chck all props for be fixed firmly on the shafts.
  3. Check each single motor for performance ( it may be a slowly dying one among them - the PCB then restrains the remaining three to stay level) - causes your prob at highest probability

-mike-
mikefromgermany is offline Find More Posts by mikefromgermany
RCG Plus Member
Last edited by mikefromgermany; Jan 30, 2013 at 07:33 AM.
Reply With Quote
Old Jan 30, 2013, 08:30 AM
Registered User
minimadlex's Avatar
United Kingdom, England, London
Joined Mar 2011
48 Posts
Many Thanks Jim,
I had some spares on route and last night soldered a new motor on rear left and voila, perfect quaddie again! But i was lookin for one of those links last week, subscribed to save future hassle. Cheers again Jim.

Lex

Quote:
Originally Posted by Jimob23 View Post
Lex
You may already be aware of this post but it does contain good tips for the X4
and may find your answer here

http://www.rcgroups.com/forums/showp...2&postcount=30

I have no track record in any form of flight and rather 1/4 scale off road bikes
Solved all my start problems by following the set up instructions there

Cheers Jim

[
minimadlex is offline Find More Posts by minimadlex
Reply With Quote
Old Jan 30, 2013, 08:40 AM
We can rebuild it!
djdavies83's Avatar
United Kingdom, Wales, Swffryd
Joined Apr 2010
3,631 Posts
I've got some really weird movements after a crash, motors were on the way out anyway, while I'm waiting for new motors I'm gonna carry on having fun with the pitch/speed the X4 FC provides, those who are easily offended should look away now....
Name: ImageUploadedByTapatalk1359556696.760582.jpg
Views: 138
Size: 126.8 KB
Description:

For now the X4 board is going into one of my old ir nonG Syma S026 Chinooks, I've already tested a V929 board which worked well.

V929 quadcopter board in S026 tandem coax (1 min 37 sec)
djdavies83 is offline Find More Posts by djdavies83
Reply With Quote
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Discussion The Hubsan X4 youxif Multirotor Talk 55 Jan 31, 2014 09:21 AM
Discussion Hubsan x4 6axis scousethief Mini Multirotors 295 Jun 21, 2013 07:22 AM
Discussion Hubsan X4 Mini Quad dc9guy Mini Multirotors 32 Feb 04, 2013 10:14 PM
Discussion Hitec X4-80 eighty 4 port chager review search Timewarp Batteries and Chargers 4 Jun 22, 2012 04:20 PM