SMALL - espritmodel.com SMALL - Telemetry SMALL - Radio
Reply
Thread Tools
Old Oct 06, 2012, 09:32 PM
Noob with Issues
crash74's Avatar
United States, AZ, Maricopa
Joined Jul 2011
1,133 Posts
sparkie624 just wondering if your lights are such low voltage I'm sure they will only draw around 75mhs per flight. why use a separate battery? Unless you need the extra weight for ballance
crash74 is online now Find More Posts by crash74
Reply With Quote
Sign up now
to remove ads between posts
Old Oct 07, 2012, 03:53 AM
Registered User
sparkie624's Avatar
Roanoke, VA
Joined Sep 2008
928 Posts
Quote:
Originally Posted by viper1216 View Post
I'm getting there with the build. Should hopefully have it all buttoned up tonight, maybe tomorrow afternoon as it's supposed to rain most of the day here. Fuse is done and wings are glued. I did glue the wing panels together. Felt better about that. Not sure who posted about it fitting in a small vehicle, but I did a test today with the wings off on my little 1990 Toyota Tercel...fit right in with the passenger side seat down. Wings aren't a big deal to put on and take off aside from the usual wiring you would need to connect for the the flaps, ailerons and motors. Other than that, it's just 2 screws. I'll probably just leave it together as I have a Blazer as well, but figured I'd test fit it.
I was scheduled for maiden yesterday, but high winds and rain put it off a week. Oh well... Worse things can happen.
sparkie624 is offline Find More Posts by sparkie624
Reply With Quote
Old Oct 07, 2012, 03:54 AM
Registered User
sparkie624's Avatar
Roanoke, VA
Joined Sep 2008
928 Posts
Quote:
Originally Posted by crash74 View Post
sparkie624 just wondering if your lights are such low voltage I'm sure they will only draw around 75mhs per flight. why use a separate battery? Unless you need the extra weight for ballance

Didn't need the balance of weight, but did not want to put a load on my other battery on just 2 cells. Lights ran great at 7.4 volts, but under receiver voltage, could not get anything out of them.
sparkie624 is offline Find More Posts by sparkie624
Reply With Quote
Old Oct 07, 2012, 03:56 AM
Registered User
sparkie624's Avatar
Roanoke, VA
Joined Sep 2008
928 Posts
Quote:
Originally Posted by crash74 View Post
what are the specs for the motors? I'm building a Thrust machine for motor/ prop tests. I want to make sure I at least Double the watts/ Thrust of the original motors
I wish I had those specs, but they are not listed anywhere. I have already posted in pics what I have on them, but do not have any other stats that is listed on NitroPlanes. I will see if I can run mine and get you some VOLT, AMP, Wattage draws from the plane for you. that will be the best I can do. I have no way to pull thrust however.
sparkie624 is offline Find More Posts by sparkie624
Reply With Quote
Old Oct 07, 2012, 09:16 AM
Registered User
United States, RI, West Warwick
Joined Mar 2009
200 Posts
Quote:
Originally Posted by sparkie624 View Post
I was scheduled for maiden yesterday, but high winds and rain put it off a week. Oh well... Worse things can happen.
Have you tried taxiiing on grasss yet? I just need to pop my props on today. Hopefully I can beat the rain and try it out in the yard. I bought new 2" wheels for it. But when I went to put them on..the wheels on it are already 2". Might see if I can sneak off to the hobby shop today for some 2.25's.
viper1216 is offline Find More Posts by viper1216
Reply With Quote
Old Oct 07, 2012, 02:44 PM
Noob with Issues
crash74's Avatar
United States, AZ, Maricopa
Joined Jul 2011
1,133 Posts
where's the video???
crash74 is online now Find More Posts by crash74
Reply With Quote
Old Oct 07, 2012, 03:31 PM
Registered User
United States, RI, West Warwick
Joined Mar 2009
200 Posts
Quote:
Originally Posted by crash74 View Post
where's the video???
Didn't make the taxi test. Went apple picking with the family in the morning....rain beat me to it. Oh well. Scheduled for a maiden tomorrow. We'll see how it goes!! Report to follow.
viper1216 is offline Find More Posts by viper1216
Reply With Quote
Old Oct 07, 2012, 03:47 PM
Noob with Issues
crash74's Avatar
United States, AZ, Maricopa
Joined Jul 2011
1,133 Posts
crash74 is online now Find More Posts by crash74
Reply With Quote
Old Oct 07, 2012, 08:01 PM
Registered User
United States, RI, West Warwick
Joined Mar 2009
200 Posts
Can't find my "Manual"...can someone post the CG when they have a moment. And where does the piece that looks like 2 blue ski's go? Other than that, she's ready to go. Ended up having to use the stock 2" wheels. I grabbed some 2 1/4's today, but the hib is to fat and they don't fit. Here's hoping the grass is short!!
viper1216 is offline Find More Posts by viper1216
Reply With Quote
Old Oct 07, 2012, 08:15 PM
Registered User
sparkie624's Avatar
Roanoke, VA
Joined Sep 2008
928 Posts
Quote:
Originally Posted by viper1216 View Post
Have you tried taxiiing on grasss yet? I just need to pop my props on today. Hopefully I can beat the rain and try it out in the yard. I bought new 2" wheels for it. But when I went to put them on..the wheels on it are already 2". Might see if I can sneak off to the hobby shop today for some 2.25's.
I tried in my yard, but my grass is WAY too high. Will try at my field this weekend if weather permits.
sparkie624 is offline Find More Posts by sparkie624
Reply With Quote
Old Oct 07, 2012, 08:17 PM
Registered User
sparkie624's Avatar
Roanoke, VA
Joined Sep 2008
928 Posts
Quote:
Originally Posted by viper1216 View Post
Can't find my "Manual"...can someone post the CG when they have a moment. And where does the piece that looks like 2 blue ski's go? Other than that, she's ready to go. Ended up having to use the stock 2" wheels. I grabbed some 2 1/4's today, but the hib is to fat and they don't fit. Here's hoping the grass is short!!
It is posted in the attachments, but here it is.
sparkie624 is offline Find More Posts by sparkie624
Reply With Quote
Old Oct 07, 2012, 08:26 PM
Registered User
United States, RI, West Warwick
Joined Mar 2009
200 Posts
Quote:
Originally Posted by sparkie624 View Post
It is posted in the attachments, but here it is.
Awesome. Thank you. I was looking through the posts and didn't see it. I checked the scan of tha manual, but it was cut off on my computer. Is this plane balanced inverted?
viper1216 is offline Find More Posts by viper1216
Reply With Quote
Old Oct 07, 2012, 08:29 PM
Registered User
sparkie624's Avatar
Roanoke, VA
Joined Sep 2008
928 Posts
Quote:
Originally Posted by viper1216 View Post
Awesome. Thank you. I was looking through the posts and didn't see it. I checked the scan of tha manual, but it was cut off on my computer. Is this plane balanced inverted?
I did it on scales. Guess you could do it either way. You can also finger balance it under the wing.
sparkie624 is offline Find More Posts by sparkie624
Reply With Quote
Old Oct 08, 2012, 03:09 PM
Registered User
United States, RI, West Warwick
Joined Mar 2009
200 Posts
Flight Report

Well, I madened the Duke today. All I can say is....Wow. Had 3 flights on it. Take off from the grass was very smooth and it got right up. Didn't even use a quarter of the runway. Once airborn, it required about 2 clicks of up elevator and 4 clicks left aileron and it was trimmed. It was a little breezy and she bounced a little, but not a big deal. First landing was beautiful. Landed with about quarter flaps and it was perfect. Slowed it down just enough and touch down was nice and smooth. Second flight just as nice. Kinda screwed the second landing though, slowed it down a little to much and dropped the left wing. A little cartwheel. Right retract broke out. It came out clean in one piece attached to a wooden block. A little 5 minute epoxy and you'd never know it came out. 3rd flight I wanted to test it a bit. Up high and slow and brought out full flaps. I was at a little under half throttlle. Slowed way down, stalled and dropped out of the sky. Easy recovery, some power and nose down and she pulled right out, but had I been landing it would have been toast. Careful with the flaps. Greased the landing. I love this plane!! Flight time on the 2200's was 5 minutes and batteries were at 17%.
viper1216 is offline Find More Posts by viper1216
Last edited by viper1216; Oct 08, 2012 at 03:10 PM. Reason: typo
Reply With Quote
Old Oct 08, 2012, 03:23 PM
Registered User
United States, RI, West Warwick
Joined Mar 2009
200 Posts
One other odd thing that happened on the first takeoff. I punched the throttle, it spooled up for about 2 seconds and then shut-down. The speed controller beeped a few times like it does when you first plug it in. After that it was fine. Someopne told me it may be because I punched it to full throttle to fast. After that I just brought it up nice and smooth and it never happened again. Could have just been a fluke, but just a heads up if anyone else experiences it.
viper1216 is offline Find More Posts by viper1216
Reply With Quote
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Question Nitroplanes Aerosky 55" Extra and Sbach rcninja 3D Foamies 220 Jul 16, 2014 08:30 AM
Discussion AeroSky B60 Tim B. Electric Plane Talk 100 Jun 19, 2014 04:45 PM
Discussion FLY FLY Beechcraft Duke B60 Hollywood2979 Foamies (Kits) 0 Jul 16, 2012 02:51 PM
For Sale FS/FT Keurig B60 Special Edition...Used only 5 times Bombo Non R/C Items (FS/W) 1 Feb 21, 2011 01:58 PM
For Sale Keurig B60 Special Edition Gourmet Single-Cup Home-Brewing System thannamhbfp Non R/C Items (FS/W) 1 Dec 18, 2009 04:53 AM