SMALL - espritmodel.com SMALL - Telemetry SMALL - Radio
Reply
Thread Tools
Old Dec 13, 2012, 12:26 PM
RC Aircraft Junkie
jlk69's Avatar
USA, CA, Chula Vista
Joined Sep 2004
906 Posts
Quote:
Originally Posted by RoboHeli View Post
@datura : I think you're just learning to be a better pilot. I've had my Nano for a month and when I go back to my MSRX it's so easy to fly compared to when I first started with it. LOL.

I completely 2nd the notion that going to the Nano from the MSRX is a completely logical progression. That's how I've gone and it's been a very good step. I'm still not flying inverted but that's because I don't want to start doing that indoors yet and it's too cold to go outside now. I need more sim time...

@Daryoon : when using the deoxit, can you just squirt it directly into the servo without removing the servo from the board? I've heard that this is what some folks do but I haven't followed the mCPX threads (don't have one yet) to know whether that's good or bad practice.
Yeah, that's what people are doing. Just use whatever fine tip that came with the deoxit. I open the servo up and use a cotton swab with electrical contact cleaner as I don't have any deoxit yet.
jlk69 is offline Find More Posts by jlk69
Reply With Quote
Sign up now
to remove ads between posts
Old Dec 13, 2012, 04:23 PM
Registered User
Canada, ON, London
Joined May 2011
1,738 Posts
Help!

Hey folks, new to this thread I think... I've searched it for my heli's issues, but couldn't find it. Hoping someone may have some insights.

I've already had to send my nCPx back to HH for replacement of the 3-in-1 for this problem. They (thankfully) send me back a new board on my Nano, but I had to spendd $20 in shipping and wait to get it there and back. The problem has resurfaced on the new board so I'd like to see if there's something I can do before having to ship it again.

Here's the problem. The nano links to the Tx fine, may fly for a little while, but then it drops into fail safe mode - ie. no power to motors, blue Rx light is off, but servos jitter indicating board and gyros are still active.

I've got a short video that shows what I'm talking about:
20121213_Nano-issues (2 min 42 sec)


Any help you guys have would be appreciated!! I have tried cleaning up the antenna solder joint, I've tried unplugging the motors to see if they are over driving the ESC, etc. nada.

Thanks in advance for your help.
Jason.
uberjay is online now Find More Posts by uberjay
Reply With Quote
Old Dec 13, 2012, 05:20 PM
Registered User
Joined Apr 2012
35 Posts
Quote:
Originally Posted by uberjay View Post
Hey folks, new to this thread I think... I've searched it for my heli's issues, but couldn't find it. Hoping someone may have some insights.

.
Looks like you you could well have flakey wiring from the battery to the main board.

I'd check that you have power to the main board when the light goes out, if not then thats your problem.

You can try just taking the wire off, striping a new section and soldering it back on but you never know where the break in the wire is until you try ... The problem could even be in the plug on the end so its just a case of trying it and or replace with new.

Thats where I'd start anyway.
rangebound is offline Find More Posts by rangebound
Reply With Quote
Old Dec 13, 2012, 05:28 PM
Registered User
sirzeppu's Avatar
United States, UT, Farmington
Joined Aug 2011
1,427 Posts
Mine does that if the battery gets even a bit low or if the battery I'm using sucks (lol)...so it definitely seems like a power issue somewhere.
sirzeppu is online now Find More Posts by sirzeppu
Reply With Quote
Old Dec 13, 2012, 06:27 PM
Registered User
Canada, ON, London
Joined May 2011
1,738 Posts
Quote:
Originally Posted by rangebound View Post
Looks like you you could well have flakey wiring from the battery to the main board.

I'd check that you have power to the main board when the light goes out, if not then thats your problem.

You can try just taking the wire off, striping a new section and soldering it back on but you never know where the break in the wire is until you try ... The problem could even be in the plug on the end so its just a case of trying it and or replace with new.

Thats where I'd start anyway.
Thanks for the suggestion... I'll check it out. The reason I didn't immediately go that route was that when the blue light goes out and the motors stop, the servos are still powered and the gyro is still controlling them. Hence, I thought it was unrelated to the power.

At this point, though, I'll try anything ;-).

Thanks,
J
uberjay is online now Find More Posts by uberjay
Reply With Quote
Old Dec 13, 2012, 06:28 PM
Registered User
Canada, ON, London
Joined May 2011
1,738 Posts
Quote:
Originally Posted by sirzeppu View Post
Mine does that if the battery gets even a bit low or if the battery I'm using sucks (lol)...so it definitely seems like a power issue somewhere.
Thanks.... yeah, I thought it might be one of my (questionable) batteries. But I have the stock batteries and Thunder Powers also that are in perfect shape that also exhibit this problem.

I'll keep digging....

Cheers,
J
uberjay is online now Find More Posts by uberjay
Reply With Quote
Old Dec 13, 2012, 07:01 PM
USAF Retired - 1968-1988
Jake8131's Avatar
United States, IL, Mascoutah
Joined Dec 2010
3,370 Posts
Quote:
Originally Posted by uberjay View Post
Hey folks, new to this thread I think... I've searched it for my heli's issues, but couldn't find it. Hoping someone may have some insights.

I've already had to send my nCPx back to HH for replacement of the 3-in-1 for this problem. They (thankfully) send me back a new board on my Nano, but I had to spendd $20 in shipping and wait to get it there and back. The problem has resurfaced on the new board so I'd like to see if there's something I can do before having to ship it again.

Here's the problem. The nano links to the Tx fine, may fly for a little while, but then it drops into fail safe mode - ie. no power to motors, blue Rx light is off, but servos jitter indicating board and gyros are still active.

I've got a short video that shows what I'm talking about:
http://youtu.be/Aab7-FR3mvA

Any help you guys have would be appreciated!! I have tried cleaning up the antenna solder joint, I've tried unplugging the motors to see if they are over driving the ESC, etc. nada.

Thanks in advance for your help.
Jason.
Try brand new batteries.
Jake8131 is online now Find More Posts by Jake8131
Reply With Quote
Old Dec 13, 2012, 07:03 PM
Registered User
datura's Avatar
United States, TX, Austin
Joined Dec 2012
319 Posts
Quote:
Originally Posted by uberjay View Post
Hey folks, new to this thread I think... I've searched it for my heli's issues, but couldn't find it. Hoping someone may have some insights.
Thanks in advance for your help.
Jason.
Could it be your transmitter?
datura is offline Find More Posts by datura
Reply With Quote
Old Dec 13, 2012, 07:09 PM
Registered User
Joined Dec 2012
11 Posts
Looking for landing skids, is the stock the best bet or is there an upgraded skid?
Tat76 is offline Find More Posts by Tat76
Reply With Quote
Old Dec 13, 2012, 08:19 PM
Team WarpSquad
Daryoon's Avatar
San Diego, CA
Joined Dec 2010
6,659 Posts
RoboHeli: the spray kind like the one Radio Shack carries has about 5% of the Deoxit cleaner. The rest is propellant and delivery solution that quickly evaporates. I think this is the one people are using to spray directly into the servo area without disassembly first. Akin to WD40 for electronics. LOL

If you got the 100% solution, then the instruction says to apply with a cotton swap or something similar. Then remove the excess. I follow this up with the fader lube. Same steps as above.

I just tore down the servos last night putting together a Nano for a friend. Even took photos. I'll share later when I get to the computer. Perhaps a new Blog entry is in order. Been too busy working on other mods.
Daryoon is online now Find More Posts by Daryoon
Reply With Quote
Old Dec 13, 2012, 08:26 PM
when down=up, up=expensive
whichwaysup's Avatar
United States, VA, Roanoke
Joined Apr 2012
3,094 Posts
Quote:
Originally Posted by Daryoon View Post
RoboHeli: the spray kind like the one Radio Shack carries has about 5% of the Deoxit cleaner. The rest is propellant and delivery solution that quickly evaporates. I think this is the one people are using to spray directly into the servo area without disassembly first. Akin to WD40 for electronics. LOL

If you got the 100% solution, then the instruction says to apply with a cotton swap or something similar. Then remove the excess. I follow this up with the fader lube. Same steps as above.

I just tore down the servos last night putting together a Nano for a friend. Even took photos. I'll share later when I get to the computer. Perhaps a new Blog entry is in order. Been too busy working on other mods.
Daryoon - Are you saying that the radio shack aerosol version is not good? I, er, might have a friend who might have been using that on his servos. Don't tell me, er, him, it's gonna cause more problems!

So far its done wonders for sticky servos and no issues.
whichwaysup is online now Find More Posts by whichwaysup
RCG Plus Member
Latest blog entry: Clever sayings
Reply With Quote
Old Dec 13, 2012, 08:35 PM
2 seconds from crashing
indoorheli's Avatar
United States, WA, Seattle
Joined Sep 2007
7,356 Posts
Quote:
Originally Posted by Daryoon View Post
That guy is actually this guy ^^^^ IndoorHeli's helpful video. At least I think they are both the same person. LOL
.
Nope, not me I have a youtube account under the same name as my rcgroups and helifreak name (single I).
Nano cpX stock and brushless flight (4 min 4 sec)


That guy just has a good choice in names, and a similar passion for beating the heli's up indoors
indoorheli is online now Find More Posts by indoorheli
RCG Plus Member
Latest blog entry: FPV - DRQ250 and a little speed
Reply With Quote
Old Dec 13, 2012, 08:55 PM
Gopher huntin' stick jockey
turboparker's Avatar
East Bethel, MN USA
Joined Jul 2009
12,480 Posts
Quote:
Originally Posted by whichwaysup View Post
Daryoon - Are you saying that the radio shack aerosol version is not good? I, er, might have a friend who might have been using that on his servos. Don't tell me, er, him, it's gonna cause more problems!

So far its done wonders for sticky servos and no issues.
The 5% solution works just fine, but the 100% solution is a much better value over the long run. BTW - you can get the 100% in an aerosol, and you don't have to disassemble the servo to use it.

Here's the D-series 100% solution aerosol: http://store.caig.com/s.nl/it.A/id.1...2&category=188

Here's the FaderLube 100% solution aerosol: http://store.caig.com/s.nl/it.A/id.1...2&category=293

I've been using this stuff for decades on mixing consoles & other pro-audio gear, as well as my home-audio & ham radio gear - so I naturally started using it on these servos when I got into UMs about 4 years ago.

Joel
turboparker is offline Find More Posts by turboparker
Last edited by turboparker; Dec 13, 2012 at 09:01 PM.
Reply With Quote
Old Dec 13, 2012, 08:55 PM
2 seconds from crashing
indoorheli's Avatar
United States, WA, Seattle
Joined Sep 2007
7,356 Posts
Quote:
Originally Posted by Tat76 View Post
Looking for landing skids, is the stock the best bet or is there an upgraded skid?
I think Airtime rc has some skids out for the nano/msr that will be more durable. Or you could try Marios heavy tuff skids for the MSR....might hurt flight times though.

You might try to boil the stock skids before flying with a new set as it should make them more durable.
indoorheli is online now Find More Posts by indoorheli
RCG Plus Member
Latest blog entry: FPV - DRQ250 and a little speed
Reply With Quote
Old Dec 13, 2012, 10:30 PM
Registered User
JLink125's Avatar
United States, CA, Highland
Joined Mar 2009
1,279 Posts
Just finished and test flew my second nano, I had enough parts left after modding my BL nano so I built a stock one! All I had to purchase was a frame since I had spare servos. Also I run the airtime skids and love them! They are much stronger then stock.
JLink125 is online now Find More Posts by JLink125
Reply With Quote
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Cool Walkera MiNi CP - Smallest 100 sized 3D helicopter zadaw Micro Helis 5802 Today 11:04 AM
Discussion is there anything better than mcpx v2 at same or smaller size? Legendary_Agent 3D Electric Heli Flying 33 Feb 24, 2012 09:46 PM
Question Whatís Better than a Blade CP and Smaller than a Trex? HavingFun2002 Micro Helis 74 Mar 05, 2006 06:07 PM