HobbyKing.com New Products Flash Sale
Reply
Thread Tools
Old Aug 25, 2012, 11:14 PM
THE PUBLIC IS THE PROBLEM
subaru4wd's Avatar
United States, CA, Sacramento
Joined Aug 2012
3,293 Posts
Help!
Cannot keep my Tricopters YAW Servo centered & stable.

So i built this tricopter and im trying to get it to fly. Im having a very difficult time keeping my Yaw Servo centered and still. It appears whenever i give it any throttle, the Yaw begins to pitch either left or right, and when I correct it doesnt seem to want to center.

Ive been messing with Gain adjustments and other things, but im wondering if there's something i have over looked or any simple trick to make the servo more stable.

here is a video of how bad it used to be... its not nearly this bad anymore but still not "perfect"

KK2 tricopter - Yaw Servo Jitter (1 min 9 sec)
subaru4wd is online now Find More Posts by subaru4wd
Reply With Quote
Sign up now
to remove ads between posts
Old Aug 25, 2012, 11:46 PM
Do a Barrel Roll!
rcbif's Avatar
United States, OH, Medina
Joined Jun 2005
1,021 Posts
Are your running the latest firmware for your kk2? If so, do you have servo filter enabled? Have you actually flown the tricopter? Tails servos movement sometimes look kinda weird on the bench, but once they get in the air, they do their own thing pretty good.
rcbif is offline Find More Posts by rcbif
Reply With Quote
Old Aug 26, 2012, 12:24 AM
THE PUBLIC IS THE PROBLEM
subaru4wd's Avatar
United States, CA, Sacramento
Joined Aug 2012
3,293 Posts
No i havent flown it yet. And im running on whatever the KK Board was shipped with, most likely 1.0 :\

I have been trying to get it to take off evenly, but it always goes into a tailspin before i can get all 3 legs off the ground. I need to work more on my landing gear, the tri is alittle top-heavy and i have been chewing through prop's.

I have one prop left, and 3 ccw props. Tomorrow I will try to get it in the air and do my best to keep it there. I have been trying to mess with the PI gains and stuff, but its confusing in a way...
subaru4wd is online now Find More Posts by subaru4wd
Reply With Quote
Old Aug 26, 2012, 01:39 AM
Registered User
Austin42's Avatar
Eagle, ID
Joined Feb 2010
20 Posts
How much slop do you have in your yaw mechanism? The smoother it is the better. You might want to try a different servo. I had something like that I think a filter on the servo lead might have helped (disconnect the yaw motor' s lead trom your board and spool it up without the props again and see if the problem goes away) . The biggest help came from a a better yaw mechanism and a better servo. Half the fun is salving these issues. Well maybe not but after your fist damage free flight, that's the best. Good luck.
Austin42 is offline Find More Posts by Austin42
Reply With Quote
Old Aug 26, 2012, 02:28 AM
THE PUBLIC IS THE PROBLEM
subaru4wd's Avatar
United States, CA, Sacramento
Joined Aug 2012
3,293 Posts
Quote:
Originally Posted by Austin42 View Post
How much slop do you have in your yaw mechanism? The smoother it is the better. You might want to try a different servo.
There's zero slop in my yaw setup. Its pretty solid and stable. I believe I have solved the issue. I watched this video on youtube from mr.Hall, and took some notes on his settings, then input them into my KK2 board.
Hobbyking KK2 board setup for gain and auto level with flight video (11 min 30 sec)


I also removed my landing gear and set the tricopter level on the floor, then recalibrated the sensors. Without any of the props on, and all through the throttle range, my YAW servo appears to be very stable. And I have full control over left/right movement, as before sometimes it would just do its own thing most the time.

Tomorrow i'll put the last of my Props on and give it one last go. I'm trying to get my buddy to come along so I have somebody to video it
subaru4wd is online now Find More Posts by subaru4wd
Reply With Quote
Old Aug 26, 2012, 02:29 AM
THE PUBLIC IS THE PROBLEM
subaru4wd's Avatar
United States, CA, Sacramento
Joined Aug 2012
3,293 Posts
Quote:
Originally Posted by Austin42 View Post
You might want to try a different servo.
Yeah I tried with an analog servo and it was doing the same thing, so I suspected it was my KK2 board.
subaru4wd is online now Find More Posts by subaru4wd
Reply With Quote
Old Aug 26, 2012, 06:28 AM
Hulk likes flying things
Phalanx-0's Avatar
United States, IN, Kokomo
Joined May 2008
613 Posts
Sloppy servo centering can be caused by a sloppy tx stick/pot or a tail servo with a large center dead band. Get a good digital servo. They can be had for less than $20.
Phalanx-0 is offline Find More Posts by Phalanx-0
Reply With Quote
Old Aug 26, 2012, 06:33 AM
Hulk likes flying things
Phalanx-0's Avatar
United States, IN, Kokomo
Joined May 2008
613 Posts
I have found that the multis, once in the air actually are more stable than on the ground.
It appears that your f/c is getting too much vibration from your motors. Try isolating the sensors-f/c better.
Phalanx-0 is offline Find More Posts by Phalanx-0
Reply With Quote
Old Aug 26, 2012, 08:48 AM
Registered User
Romania, Bucuresti, Bucharest
Joined Oct 2011
134 Posts
You do realize that on a tricopter the rear motor would be leaning to one side to counter the torque effect from the motors right? Once you take off all that random movement will settle.
Be sure to check the gyro direction before you take off, if it wants to spin quickly into one direction is a sign of yaw gyro reversed.
bikerboy_id is online now Find More Posts by bikerboy_id
Reply With Quote
Old Aug 26, 2012, 09:04 AM
Do a Barrel Roll!
rcbif's Avatar
United States, OH, Medina
Joined Jun 2005
1,021 Posts
Quote:
Originally Posted by bikerboy_id View Post
Be sure to check the gyro direction before you take off, if it wants to spin quickly into one direction is a sign of yaw gyro reversed.
On both my tricopter builds with the kk2, the yaw gyro needed reversed. I would also advise flashing the kk2 with the latest firmware so you can use the servo filter option if your current servo, or future servos cant keep up with the kkboard, and get the jitters.

Basically, you might not have the jitters now because you havent dialed in the yaw p&i setting by flying it yet. Once you do get those dialed in, it might handle good, but the servo may be wobbling like crazy.
rcbif is offline Find More Posts by rcbif
Reply With Quote
Old Aug 26, 2012, 10:37 AM
THE PUBLIC IS THE PROBLEM
subaru4wd's Avatar
United States, CA, Sacramento
Joined Aug 2012
3,293 Posts
Thanks everybody. This helps alot. I was just tired last night of breaking props and not getting anywhere...

I can't wait to get 1.2 firmware loaded, but I didn't buy the USB connector so I am stuck for now.
subaru4wd is online now Find More Posts by subaru4wd
Reply With Quote
Old Sep 13, 2012, 10:16 PM
Registered User
Joined Mar 2011
8 Posts
Quote:
Originally Posted by Austin42 View Post
How much slop do you have in your yaw mechanism? The smoother it is the better. You might want to try a different servo. I had something like that I think a filter on the servo lead might have helped (disconnect the yaw motor' s lead trom your board and spool it up without the props again and see if the problem goes away) . The biggest help came from a a better yaw mechanism and a better servo. Half the fun is salving these issues. Well maybe not but after your fist damage free flight, that's the best. Good luck.
What you said...so true....Years ago 1982, I began backpacking & hiking the Rocky Mts. Upon returning from my 1st 5 night camp/hike I went to the Ranger Station to complain about the poor, incomplete, stupid, confusing trail markings. Why couldn't they do better? "I said".

The Park Ranger ask me if I enjoyed my "Adventure" back in to nature etc. I said yea, but those stupid Trail Markings, what's up with that?

He answered "That to is part of the Adventure". Sometimes it is fun NOT to know exactly were you are and exactly what is around the next bend in the trail."

I have the "Crazy Yaw" problem also......help me...pls

Whit101
whit101 is offline Find More Posts by whit101
Reply With Quote
Old Sep 13, 2012, 10:52 PM
THE PUBLIC IS THE PROBLEM
subaru4wd's Avatar
United States, CA, Sacramento
Joined Aug 2012
3,293 Posts
I was able to solve the yaw issue by dialing in the p & i gains on the KK2 board. I have been through quite a few servo's due to crashes, and have even changed the location of my servo once. Other than dealing with cheap, plastic geared, analog servos, the tri has remained ballanced and stable in the air.

Here is the latest video that I took today. After doing some final adjustments to the P & I gains... and for the first time I am able to fly without Auto Level

The HellaCopter makes it's Debut! (2 min 6 sec)


I still have yet to update to 1.2. I am still on the stock 1.0 that the KK2 board was shipped with.
subaru4wd is online now Find More Posts by subaru4wd
Reply With Quote
Old Apr 20, 2014, 12:08 PM
Registered User
eagle4's Avatar
Canada, QC, Montreal
Joined Feb 2013
68 Posts
i know this is an old thread, just wondering if you happened to know what p and i gain settings managed to fix your issue of not having the rear servo centering. i have the same problem but i'm unable to work out the problem
eagle4 is offline Find More Posts by eagle4
Reply With Quote
Old Apr 20, 2014, 01:45 PM
THE PUBLIC IS THE PROBLEM
subaru4wd's Avatar
United States, CA, Sacramento
Joined Aug 2012
3,293 Posts
Quote:
Originally Posted by eagle4 View Post
i know this is an old thread, just wondering if you happened to know what p and i gain settings managed to fix your issue of not having the rear servo centering. i have the same problem but i'm unable to work out the problem
It wasnt a gain issue, it was just my newb showing.

The servo will not center. Its not designed to. Once i put props on and flew it, the flight controller did what it needed to do to maintain a solid flight. Without a prop, and on the bench... the flight controller just wiggs out.

Have you flown your tri yet?
subaru4wd is online now Find More Posts by subaru4wd
Reply With Quote
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Question What servo's are people using for their Tricopter Yaws?? subaru4wd Scratchbuilt Multirotors 14 Sep 22, 2012 08:26 AM
Discussion quadrino tricopter yaw servo doesnt move juxsa Multirotor Talk 34 Jul 05, 2012 03:03 AM
Discussion Tricopter yaw servo question milo12 Multirotor Talk 2 Jun 20, 2012 02:58 PM
Sold Rc Explorer Tricopter w/ yaw servo hooked up already airbagit13 Aircraft - Electric - Multirotor (FS/W) 3 Mar 30, 2012 06:50 PM
Sold Rc Explorer Tricopter w/ yaw servo hooked up already airbagit13 FPV Equipment (FS/W) 1 Mar 30, 2012 06:50 PM