SMALL - espritmodel.com SMALL - Telemetry SMALL - Radio
Reply
Thread Tools
Old Aug 18, 2012, 06:42 AM
Registered User
XstarWake's Avatar
Canada, ON, Ottawa
Joined Oct 2010
252 Posts
Help!
HobbyKing ECO6 50W 5A Balancer/Charger unable to charge 4S??

Hi,

Ive been using the ECO6 for about 2 years, charging a range or batteries from 2S to 3S. I have to say, superb charger...

Now here is the issue, I have a new plane that uses 4S LiPo packs, and the charger doesnt like 4S... unable to charge\balance any 4S batteries... after about 5 seconds, it says "Battery Vol Err Cell Connect".......

I tryed to charge with another charger : Turnigy Accucel-6 50W 6A Balancer/Charger and is able to charge and balance.

I used the same powersupply for both... so we rule the powersupply as the error...

I would like to know if there is a fix?
Does someone have the same issue?

I need help please,

Thank you,

Max
XstarWake is offline Find More Posts by XstarWake
Last edited by XstarWake; Aug 18, 2012 at 07:01 AM.
Reply With Quote
Sign up now
to remove ads between posts
Old Aug 18, 2012, 08:08 PM
RC Helicopter Pilot
TheWoodCrafter's Avatar
United States, CA, Westminster
Joined Mar 2010
1,696 Posts
It could be a balance wire or board problem.

Have you tried to charge it without balancing?
That would isolate the balancing.
TheWoodCrafter is offline Find More Posts by TheWoodCrafter
Reply With Quote
Old Aug 19, 2012, 08:50 AM
No bounce, No play.
davidmc36's Avatar
Canada, ON, Ottawa
Joined Oct 2010
3,290 Posts
Does the charger in question have the low input voltage shut-off feature set higher than the other charger? ie: Is it shutting down at a higher input voltage than the functioning charger? Can you set the charge rate lower and see if it prevents it from reaching the low input voltage safety cut-off level?
davidmc36 is offline Find More Posts by davidmc36
Reply With Quote
Old Aug 22, 2012, 10:34 AM
Registered User
XstarWake's Avatar
Canada, ON, Ottawa
Joined Oct 2010
252 Posts
Hi TheWoodCrafter and Davidmc36,

Thanks for the reply!


TheWoodCrafter : I cant charge without plugging the balancing lead, since i need to have both connected to charge, balance or do anything. Otherwise, the charger will say : Connection Break.

Davidmc36 : ill double check if the low input voltage shut-off feature, see what the value of the feature is, but, I tryed to charge at 0.1 amp and still does tell me the same error message.

Thank you,

Max
XstarWake is offline Find More Posts by XstarWake
Reply With Quote
Old Aug 22, 2012, 10:50 AM
Registered User
United States, MN
Joined Feb 2011
4,356 Posts
My guess there's a broken connection internally on the balance plug on the charger. Are you using the balance board that came with it? Do you have a cell checker you could plug that balance board into? Or what happens if you use the balance board for the ECO6 on the 6s port of the Accucel6? Do you get an error then on the Accucell6?

TheWoodCrafter is right, if you set to Charge or Quick Charge instead of Balance it should not require a balance connection.
grimbeaver is offline Find More Posts by grimbeaver
Reply With Quote
Old Aug 22, 2012, 02:22 PM
Space Coast USA
hoppy's Avatar
Space Coast
Joined Oct 2000
20,848 Posts
Yes the Accucel 6 will charge lipos without the balance connector plugged in. Just use the straight "Charge" option without plugging in the balance connector.
hoppy is offline Find More Posts by hoppy
Reply With Quote
Old Aug 23, 2012, 08:15 AM
Registered User
XstarWake's Avatar
Canada, ON, Ottawa
Joined Oct 2010
252 Posts
Understood, I will try to see if its the balance board that is faulty.
To be sure, the balance plug is the board that has 2cell, 3cell, etc... white connector on it right?
Still using the same board that came with the charger yes.
I dont have a cell checker. Accucell has a built in board... not a external board like the ECO6...

So, if you guys are right, i can plug only my DEAN connector, and hit charge ??

Thank you so much for all your help GUYS!!!

Max
XstarWake is offline Find More Posts by XstarWake
Reply With Quote
Old Aug 23, 2012, 09:10 AM
Registered User
United States, MN
Joined Feb 2011
4,356 Posts
Quote:
Originally Posted by XstarWake View Post
Understood, I will try to see if its the balance board that is faulty.
To be sure, the balance plug is the board that has 2cell, 3cell, etc... white connector on it right?
Still using the same board that came with the charger yes.
I dont have a cell checker. Accucell has a built in board... not a external board like the ECO6...

So, if you guys are right, i can plug only my DEAN connector, and hit charge ??

Thank you so much for all your help GUYS!!!

Max
Yes try that board on your accucel6. Just plug it into the 6-cell port and your battery into the board like you always do and see if you have the same problem. Yes if you select "CHARGE" (not "BALANCE") you should be able to only connect your deans.
grimbeaver is offline Find More Posts by grimbeaver
Reply With Quote
Old Aug 23, 2012, 09:33 AM
Registered User
XstarWake's Avatar
Canada, ON, Ottawa
Joined Oct 2010
252 Posts
Ok, if i understand correctly.

On my balance board, i have up to 6 Cell balance plug that i can plug. So, i plug the dean, then plug the 4S batt into the 6S balancer port? Sorry if im a newb... but im a newb! heheh

Thanks a lot for the help again!

Max
XstarWake is offline Find More Posts by XstarWake
Reply With Quote
Old Aug 23, 2012, 12:36 PM
Registered User
United States, MN
Joined Feb 2011
4,356 Posts
battery into 4-cell port of balance board, balance board into 6-cell port on accucell6 charger. got it? connect it exactly the same as you would the ECO6, just imagine all the 2-cell through 5-cell connectors don't exist on the accucell6 charger.
grimbeaver is offline Find More Posts by grimbeaver
Reply With Quote
Old Aug 23, 2012, 01:19 PM
Registered User
XstarWake's Avatar
Canada, ON, Ottawa
Joined Oct 2010
252 Posts
cant connect the balance board to the Accucell, because, my balance board is connected via Banana plug to my Eco6....
XstarWake is offline Find More Posts by XstarWake
Reply With Quote
Old Aug 23, 2012, 01:25 PM
Registered User
United States, MN
Joined Feb 2011
4,356 Posts
Quote:
Originally Posted by XstarWake View Post
cant connect the balance board to the Accucell, because, my balance board is connected via Banana plug to my Eco6....
Impossible, there's no banana plugs on the stock balance board.

Look at this photo:
http://www.hobbyking.com/hobbyking/s...dproduct=11060

The board in the top center of the picture, that's the balance board, there's no banana plugs on it.
grimbeaver is offline Find More Posts by grimbeaver
Reply With Quote
Old Aug 23, 2012, 01:27 PM
Registered User
United States, MN
Joined Feb 2011
4,356 Posts
Let me put it this way, disconnect everything from the ECO6 and plug all of it into the Accucell6 as is. Everything you plug into the ECO6 can plug into the Accucell6 somewhere.
grimbeaver is offline Find More Posts by grimbeaver
Reply With Quote
Old Aug 23, 2012, 01:39 PM
Registered User
XstarWake's Avatar
Canada, ON, Ottawa
Joined Oct 2010
252 Posts
Wow, i understand. i was sure that it was banana plug....
Im more then sorry...
Ill try...
I feel so dum... sorry again.
XstarWake is offline Find More Posts by XstarWake
Reply With Quote
Old Aug 23, 2012, 10:10 PM
Space Coast USA
hoppy's Avatar
Space Coast
Joined Oct 2000
20,848 Posts
Dumb is not asking questions. Smart is asking questions. Just keep asking.
hoppy is offline Find More Posts by hoppy
Reply With Quote
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
New Product HobbyKing ECO6 50W 5A Balancer/Charger w/ accessories CrashingDutchman Batteries and Chargers 34 Jun 28, 2014 01:28 PM
Discussion Hobbyking ECO6 balanced charger shorted? help... MrDanny Batteries and Chargers 2 Nov 30, 2013 07:33 AM
Sold HobbyKing ECO6 50W 5A Balancer/Charger Orion_V Aircraft - Electric - Batteries & Chargers (FS/W) 4 Jul 07, 2011 07:09 PM
New Product HobbyKing Variable 6S 50W 5A Balancer/Charger with accessories CrashingDutchman Batteries and Chargers 25 Jun 28, 2011 04:04 PM
Discussion twin pack charge lead (2 x 3S)6S + Turnigy Accucel-6 50W 5A Balancer/Charger tevz Batteries and Chargers 5 Jun 20, 2009 09:35 AM