HobbyKing.com New Products Flash Sale
Reply
Thread Tools
Old Aug 10, 2012, 06:02 PM
Registered User
Australia
Joined Jun 2010
1,611 Posts
Discussion
Hobbyking 50mm alloy no thrust?

Hi

I purchased one of these 50mm alloy 4800kv 3s version EDF's for my T-33.

Link- http://www.hobbyking.com/hobbyking/s..._Version_.html

I'm running it on a 1300mah 3s Nanotech.

I've got a strange problem though in that it sounds like its screaming but has little thrust. At first I thought the intake/exhaust was too small so I carved out some foam, but it was the same. Then I pulled the fan off and looked at the adapter thinking the fan might be slipping so I added a locking washer and tried again but no joy there either. Slipping fan seems like the logical answer though. Yesterday I measured the current draw and it was a little odd. As I increased throttle the amps only came up to around 3.7amps at mid throttle, then as I passed mid throttle you could hear the motor increasing rpm to a scream, but the the current draw fell away to 1.7amps as it approach full throttle?
Does anybody have any thoughts on this? fan slipping? or something else?

input appreciated

Mick
Bravo47 is offline Find More Posts by Bravo47
Reply With Quote
Sign up now
to remove ads between posts
Old Aug 10, 2012, 06:08 PM
3DHOG
jcdfrd's Avatar
USA, CA, Aromas
Joined Sep 2010
4,849 Posts
make sure the fan is spinning in the correct direction
jcdfrd is offline Find More Posts by jcdfrd
Reply With Quote
Old Aug 10, 2012, 10:31 PM
Registered User
Australia
Joined Jun 2010
1,611 Posts
Quote:
Originally Posted by jcdfrd View Post
make sure the fan is spinning in the correct direction
We can cross that off the list, thx. Anybody else have any experience with this EDF?
Bravo47 is offline Find More Posts by Bravo47
Reply With Quote
Old Aug 10, 2012, 11:00 PM
3DHOG
jcdfrd's Avatar
USA, CA, Aromas
Joined Sep 2010
4,849 Posts
Mick
which direction is it spinning if your in front of the fan looking at it?..........clockwise or counter clockwise
this is a common problem with edf nubies, and their is a comment in the HK comments section about this rotor needing to run in an opposite direction which is why I asked but from the pics it looks like a normal rotation direction which if your in front of it looking at it you will want to see a counter clockwise direction

if the fan is slipping you should take off the rotor and shaft adapter and inspect for slippage it should be quit easy to detect
good luck
jcdfrd is offline Find More Posts by jcdfrd
Reply With Quote
Old Aug 11, 2012, 02:13 AM
Registered User
Australia
Joined Jun 2010
1,611 Posts
Quote:
Originally Posted by jcdfrd View Post
Mick
which direction is it spinning if your in front of the fan looking at it?..........clockwise or counter clockwise
Looking at the intake its a CCW rotation. Looking at the curvature of the blade viewed from the side, the rotation appears correct to me.

Mick
Bravo47 is offline Find More Posts by Bravo47
Reply With Quote
Old Aug 11, 2012, 12:23 PM
3DHOG
jcdfrd's Avatar
USA, CA, Aromas
Joined Sep 2010
4,849 Posts
ok that sounds correct, you could make a short video of whats its doing we could probably help better but if it sounds like the rotor is slipping then it has to come apart and see whats going on
jcdfrd is offline Find More Posts by jcdfrd
Reply With Quote
Old Aug 11, 2012, 07:30 PM
Effumall
kelberts's Avatar
Joined Nov 2005
3,619 Posts
is it possible your motor has been damaged/demagnetized?
kelberts is offline Find More Posts by kelberts
Reply With Quote
Old Aug 11, 2012, 09:33 PM
Registered User
Australia
Joined Jun 2010
1,611 Posts
Hobbyking 50mm Alloy 4800kv EDF, 1300hah 3s nanotech. The unit barely has enough thrust to get my T-33 air born. I've pretty much ruled out fan slipping, and running out of idea's. I ruffed up the inside of the prop adapter and marked with texta. No slip noted. Note the current draw falls away beyond 50% throttle? Amp draw peaks out under 4amps. Perhaps its the inrunner? Input appreciated.

Heres the video. Check it out

50mm Alloy no thrust problem? (0 min 43 sec)
Bravo47 is offline Find More Posts by Bravo47
Reply With Quote
Old Aug 11, 2012, 09:44 PM
3DHOG
jcdfrd's Avatar
USA, CA, Aromas
Joined Sep 2010
4,849 Posts
what wire do you have the amp clamp around?
jcdfrd is offline Find More Posts by jcdfrd
Reply With Quote
Old Aug 11, 2012, 11:30 PM
Registered User
Australia
Joined Jun 2010
1,611 Posts
Quote:
Originally Posted by jcdfrd View Post
what wire do you have the amp clamp around?
positive off the battery lead
Bravo47 is offline Find More Posts by Bravo47
Last edited by Bravo47; Aug 11, 2012 at 11:30 PM. Reason: correction
Reply With Quote
Old Aug 11, 2012, 11:41 PM
3DHOG
jcdfrd's Avatar
USA, CA, Aromas
Joined Sep 2010
4,849 Posts
Quote:
Originally Posted by Bravo47 View Post
positive off the battery lead
ok just checking thats fine I thought possibly that you may have had it around one of the motor wires and that would give some goofy readings as it is a/c on that side of the esc, so that is a strange reading your getting, the fan sounds ok to me but only getting 4amp draw..........is that correct those have to draw more than that, I guess that would be the reason for your thread hmmm ....have you tried a diff battery? have you checked your end points in the radio on the throttle channel and/or calibrated the esc throttle?
jcdfrd is offline Find More Posts by jcdfrd
Reply With Quote
Old Aug 12, 2012, 01:41 AM
Registered User
Australia
Joined Jun 2010
1,611 Posts
Yeah tried a couple of batteries, and once you rule out slipping I guess that only leaves me with a faulty motor. The rest of the electrics works OK and the throttle is calibrated. I only fitted this upgrade after the stock EDF blew its blades out the back end during a pass. Oh well I guess I'll order another motor as chasing a waranty from HK is to tedious.

Mick
Bravo47 is offline Find More Posts by Bravo47
Reply With Quote
Old Aug 12, 2012, 03:08 AM
Registered User
sloperjoe's Avatar
United States, WA, Vancouver
Joined Mar 2012
740 Posts
hmmmm, thats wierd...I have two of those with Red Brick 20 amp ESC's, both work awesome, one is in an A-6 Intruder I scratchbuilt and it flies like a pylon racer! you should be pulling 16-18amps at full throttle. have you got a different ESC you can connect to and see what happens?...
the only other thing I can possibly think of is the impeller might be on upside down...dont know if that is even possible I'll have to look at the one that is not in anything yet, should be rounded airfoil profile forward sharp side rearward... your motor "sounds" like its screaming...not to sure thats the problem, if your motor screams and your amps are low, its usually a prop/impeller problem. I'll go look at it.

here is a vid of my Intruder flying with that same fan (3s version)

Flight of the Intruder (3 min 43 sec)



Joe
sloperjoe is offline Find More Posts by sloperjoe
Reply With Quote
Old Aug 12, 2012, 03:14 AM
Carbon fiber is our friend
Steve C's Avatar
United States, CA, Lodi
Joined Feb 2001
4,230 Posts
The magnet rotor may have come loose from the shaft. It's usually glued on.
Steve C is online now Find More Posts by Steve C
Reply With Quote
Old Aug 12, 2012, 03:40 AM
Registered User
Dizz's Avatar
Brixham, Devon, England
Joined Jun 2004
297 Posts
If you have a second ESC I would try swapping that before getting bogged down dis-assembling fans and motors. Would be a strange failure, but at least it could be ruled out (or not).
Pete
Dizz is offline Find More Posts by Dizz
Reply With Quote
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Discussion HobbyKing Mercury Alloy 64mm 4700KV EDF Unit lipoflyer Electric Ducted Fan Jet Talk 286 Sep 10, 2014 08:39 PM
Sold Wicked 5400KV motor+50mm Alloy EDF+40A ESC $35 queadlunnrau Aircraft - Electric - Jets (FS/W) 6 May 04, 2012 08:50 PM
Sold Hobbyking 50mm Alloy EDF 4200kv $16 Shipped queadlunnrau Aircraft - Electric - Jets (FS/W) 2 Apr 04, 2012 09:35 PM
New Product HobbyKing - Mercury Alloy EDF Unit Mikemynameis Foamy EDFs 3 Nov 08, 2011 09:08 AM
Sold HobbyKing 7075 alloy struts BNIP $28 shipped kevinb120 Aircraft - Electric - Jets (FS/W) 1 Mar 01, 2011 11:33 PM