SMALL - espritmodel.com SMALL - Telemetry SMALL - Radio
Reply
Thread Tools
Old Jul 19, 2012, 04:42 PM
Registered User
United States, NE, Lincoln
Joined Jul 2012
67 Posts
Discussion
kk board firmware xcopter v4.7 by kapteinkuk

Hi, Everyone
I'm new to this and I need some help getting my xcopter running. I have been reading this post (Improved firmware for the KK multicopter, also the HK KK) now for hours and there is just too much info. I have a quadcopter x 525 that I got from good luck buy. It has a black kk board on it. I've loaded the firmware xcopter v4.7 using the kk multicopter flash tool from the repository. I think that I am close to getting it flying but after I configure everything I get some goofy responses from my motors.

I am using Spektrym DX6

When I push the elevator stick forward my back to motors will spin up real fast. But when I pull the elevator stick back my front two motors do not spin up as fast as my back two did.

Also, and I'm not sure exactly what this is called, but here I go. When I move the aileron stick to the Right my left two motors spin up real fast, but just like my elevator stick, when I move the stick in the opposite direction or left my right two motors do not spin up much at all.

When I operate the rudder, rudder right or rudder left the motors seem to spin up equally for there desired operation. I can not figure out what is wrong for the life of me.

When I loaded version 4.7 I had to flip the pots zero direction.
After that I set the throttle calibration using the yaw pot.

Can someone please shoot out some Ideas I know that may not be enough info ask me question if more is needed.

That other post is almost unusable. Lots of good info but impossible to follow.

Thanks
Shawn
shawn1979 is offline Find More Posts by shawn1979
Reply With Quote
Sign up now
to remove ads between posts
Old Jul 19, 2012, 04:50 PM
Suspended Account
Joined Jun 2012
787 Posts
Make sure your subtrims are centered on your DX.
Navy Jet Mech is offline Find More Posts by Navy Jet Mech
Reply With Quote  (Disabled)
Old Jul 19, 2012, 05:19 PM
Registered User
United States, NE, Lincoln
Joined Jul 2012
67 Posts
Thanks,
They are centered, I think somehow I am getting mixing with my radio. I am going to try and reset it. there are so many settings im not sure which ones to do. I am going to switch it from heli to airplane mode.
Thanks Again
Shawn
shawn1979 is offline Find More Posts by shawn1979
Reply With Quote
Old Jul 19, 2012, 06:18 PM
Registered User
VA
Joined Nov 2009
2,637 Posts
Definitely set it to airplane mode until you get the hang of it all. After you get the tx setup like you want do an esc calibration from the fc again. Give a little throttle and see if the quad tries to lift straight up. If it doesn't trim to the side that needs it to see if you can balance it out. For x mode you may have to apply trim to every channel except throttle to get a straight liftoff. kk firmware does not automatically make the stick center the neutral position.
pug398 is offline Find More Posts by pug398
Reply With Quote
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Help! Yaw problem with HK KK Board V2.1, KK firmware 4.7 count74 Multirotor Talk 2 Jul 18, 2014 03:37 PM
Question X-copter V4.7 Kapteinkuk motor setup frank100 Multirotor Talk 7 Jul 17, 2012 03:32 PM
Sold New KK board version 5.5/Xcopter ver. 2.3 w/ Programmer $25 shipped Rifraf Aircraft - Electric - Multirotor (FS/W) 3 May 09, 2012 07:59 PM
Sold Red KK board comes with German v4.5 firmware +4 kevinlib Aircraft - Electric - Multirotor (FS/W) 9 Aug 25, 2011 04:52 PM