HobbyKing.com New Products Flash Sale
Reply
Thread Tools
Old Jul 17, 2012, 07:29 PM
Registered User
Joined Jul 2012
165 Posts
Discussion
Motor won't spin, can't find the problem, please read and help

Ok, got my f550 up and flying. While hovering back and forth, I would notice a sudden dip to one side ever few seconds or so. I was only a few feet off the ground, when I noticed one of the props stopped spinning, and the craft became unstable, and slid into a hard landing. Upon inspection it looked as one of the motor to esc connections may have been loose, but none were unconnected. I pushed them all back in as best as possible, and tried it again. 

This time however my number 2 motor wouldnt spin (only will spin like a 1/4 turn every few seconds or so).  I posted on the forums, and it was suggested my solder connection might be bad. 

When I made it home tonight, I took things apart, resoldered my connection, put back together and tried again. No luck, same thing happening. I have a spare motor and esc, so I first swapped the motor out, same thing happening. So then I unsoldered the esc, and chanced that, still no luck. 

So thinking it might be the Naza, I swapped the connections for motors 1 & 2, same thing happen on same motor. 

My only conclusion is it could be a bad power distribution board.  Does that sound like a possibility? 

Any other ideas?

Thanks for the help,
Jeff
Troiano27 is offline Find More Posts by Troiano27
Reply With Quote
Sign up now
to remove ads between posts
Old Jul 17, 2012, 09:34 PM
Registered User
United States, NV, North Las Vegas
Joined Sep 2009
1,075 Posts
If I understand right you now have the first ESC/motor setup that would not work as your spare? If so, solder a deans or what ever type of battery connector you use to that ESC and solder up the motor, hook the ESC directly to the throttle CH on your receiver(unhook everything else but the BEC) now, without a prop of course plug in your battery and see if the motor spins up... If it does then you know the problem must be at the Power distro...thats if you're sure the solder joints are good

It really sounds like a bad motor>ESC connection or bad phase... with the spare setup doing exactly the same thing it almost has to be a power connection issue or bad distro trace.
shultz is offline Find More Posts by shultz
Reply With Quote
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Discussion Two of my Four motors won't spin properly! Heliupgrader Multirotor Talk 3 May 21, 2012 04:33 PM
Discussion Help I can't find any info on this engine anywhere can anyone help? wet banshee Engines 6 Mar 11, 2012 09:11 AM
Sold Futaba 9chp YOU WON'T FIND A BETTER DEAL 2.4ghz Aircraft - General - Radio Equipment (FS/W) 3 Mar 07, 2012 10:31 AM
Help! HK Multicopter Control Board - motor doesn't spin - need help Jetro223 Multirotor Talk 2 Feb 24, 2012 02:58 PM
Help! help with new motor won't spin just shudders hotdog1 Power Systems 8 Nov 04, 2010 10:17 AM