HobbyKing.com New Products Flash Sale
Reply
Thread Tools
Old Jul 11, 2012, 01:40 PM
Thermite + ice = Big boom.
boaterguy's Avatar
Canada, ON, Ottawa
Joined Apr 2009
2,275 Posts
Question
Hitec laser 6 not working?

I purchased a laser 6 on rccanada (no complaints I paid 25$ for it) and it's not working.
Channel 5 (retracts) and channel 6 (aux pot on top) are working perfectly, everything else doesn't work.
Each channel has it's own preset, so when I plug a servo into that channel, it travels to a point but won't move after that.
If I move channels 2 and 3, and sometimes 4, at the extreme I can hear the servo start buzzing, but it's not moving at all, nevermind enough.
I went to the manual and tried tightening the tension on the gimbals but it didn't help, I've tried playing with the DR switches and the screwdriver pots at the bottom and it's not changing anything.
I'm really over my head here as I don't know how this thing works.
Can someone who owns one/ knows how to work one help me out with this?
boaterguy is offline Find More Posts by boaterguy
Reply With Quote
Sign up now
to remove ads between posts
Old Jul 11, 2012, 01:48 PM
Wake up, feel pulse, be happy!
C₄H₁₀'s Avatar
United States, AK, Fairbanks
Joined Aug 2009
12,411 Posts
If the servos buzz a little when you push the sticks as far as they'll go, it sounds like it could be something with the sticks' potentiometers. I would just open it up and move the gimbal pots by hand and check for loose/damaged wires and whatnot. Do this with the radio powered up so you can monitor the servos in real time but BE CAREFUL, dammit. The radio isn't dangerous to you, but you're dangerous to the radio. Accidentally making a connection between the wrong points could fry it quick.
C₄H₁₀ is offline Find More Posts by C₄H₁₀
Reply With Quote
Old Jul 11, 2012, 02:23 PM
Thermite + ice = Big boom.
boaterguy's Avatar
Canada, ON, Ottawa
Joined Apr 2009
2,275 Posts
I opened it up and looked around a little bit, and everything looks like it's working fine.
Maybe i'll pull a pot out of the radio later and move it by hand, they might just not be connected to the gimbals properly.
boaterguy is offline Find More Posts by boaterguy
Reply With Quote
Old Jul 12, 2012, 03:34 AM
Registered User
Livermore, CA
Joined Sep 2004
8,582 Posts
The tech's at Hitec are a great! I have over a dozen Hitec radios and half of them I sent to them for a check-up and they check them for free and if anything I might pay $5-10.00, if some things need to be replaced.
Butch777 is offline Find More Posts by Butch777
Reply With Quote
Old Jul 12, 2012, 10:30 AM
Thermite + ice = Big boom.
boaterguy's Avatar
Canada, ON, Ottawa
Joined Apr 2009
2,275 Posts
That's good, i'll email them.
I can't get anything to work at all anymore, it looks like there's a broken pot on the receiver.
boaterguy is offline Find More Posts by boaterguy
Reply With Quote
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Discussion NIB Hitec OPTIMA 7 not working The Snake Radios 5 Apr 14, 2012 10:28 PM
Question Weird problem with New Y-6... Throttle works, but not Pitch Roll or Yaw Adidas4275 Hoverfly Technologies 4 Apr 02, 2012 11:21 AM
Discussion Hitec Optima 6 Receivers do not work steve51 Radios 6 Jan 17, 2012 10:03 AM
Discussion Hitec Laser 4 + Hitec receiver = Not working? finchkid24 Beginner Training Area (Aircraft-Electric) 21 Jun 04, 2008 05:57 PM
Question is there a Hitec Laser 4 Tx upgrade to Laser 6 from Hitec? oneleggimp Hitec/Multiplex USA 1 Nov 21, 2003 01:40 PM