HobbyKing.com New Products Flash Sale
Reply
Thread Tools
Old Jul 01, 2012, 10:14 PM
(stock)-Blade-400-Mcpx-dx6i
Joined Jun 2012
37 Posts
Help!
Blade 400 servo problems

hi guys watch the video it says it all. Please leave a reply your help would be very good


http://www.youtube.com/watch?v=OWrqF...1&feature=plcp
Joshheli is offline Find More Posts by Joshheli
Reply With Quote
Sign up now
to remove ads between posts
Old Jul 02, 2012, 01:26 AM
Everyone is an idiot (or I am)
Daddy.'s Avatar
United States, TX, Red Oak
Joined Jun 2012
417 Posts
Hi Josh, I suspect the gears are stripped in the servo which lead to it not properly centering anymore (common problem with those servos). Disconnect battery and slowly move the servo arm throughout it's range, do you feel grinding and clicking? You can move another servo arm to see how it should feel.

You can replace the gear set in the servo pretty easy and cheaply.

Now if the gears feel ok by moving the arm throughout it's range, just take the horn (arm) off and recenter it at midstick and level the swash.

Please ask questions if you don't understand and someone here will help you.

Ken
Daddy. is online now Find More Posts by Daddy.
Reply With Quote
Old Jul 02, 2012, 04:21 AM
(stock)-Blade-400-Mcpx-dx6i
Joined Jun 2012
37 Posts
Quote:
Originally Posted by Daddy. View Post
Hi Josh, I suspect the gears are stripped in the servo which lead to it not properly centering anymore (common problem with those servos). Disconnect battery and slowly move the servo arm throughout it's range, do you feel grinding and clicking? You can move another servo arm to see how it should feel.

You can replace the gear set in the servo pretty easy and cheaply.

Now if the gears feel ok by moving the arm throughout it's range, just take the horn (arm) off and recenter it at midstick and level the swash.

Please ask questions if you don't understand and someone here will help you.

Ken
thanks ken i will try re centring the servo arm i have no stripped gears. your help is greatly appreciated
Joshheli is offline Find More Posts by Joshheli
Reply With Quote
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
For Sale Upgraded Blade 400, HS-65HB servos, FREE DX6i and 4s lipos skydve76 Aircraft - Electric - Helis (FS/W) 4 Jul 31, 2012 05:24 AM
Discussion Blade 400 problems drsquat Electric Heli Talk 5 Apr 04, 2012 11:38 PM
Discussion Servo adjust problem Blade 400 haze10 Electric Heli Talk 6 Feb 06, 2010 02:16 AM
Discussion Blade 400 problems with Elevator (front servo) trondhindenes Mini Helis 2 Apr 05, 2009 11:26 PM
Discussion can anyone help with a servo problem blade 400? jet fellar Mini Helis 2 May 17, 2008 09:38 PM