HobbyKing.com New Products Flash Sale
Reply
Thread Tools
Old Jul 01, 2012, 09:27 AM
Registered User
Joined Jul 2012
2 Posts
Help!
Heng Long Panzer IV Tank Loose connection?

Hi Guys,

I have been looking for help on heng long tanks and this seems like a good place to ask a question I have.

I just brought my second heng long tank. The first is a two year old pershing which is still working fine.

The second which I picked up for a bargin at a market is a panzer IV with metal tracks and gear box.

The first thing I noticed about this tank is it has an A B C channel switch and this is what seems to be giving me problems.

When I got home I had no luck getting it to work at all.
The only thing I noticed is that when I switched the channel switch on the tank hull the lights would blink for a second.

After some general prodding and tinkering with the cables and switch (I did no action in particular) it come to life and started running. All actions worked (BB, turret and tracks).

Great I thought so I put it back together again and ran it around the floor. A few seconds later after going over the bump under a door it was not responding again.

I can only assume that there is something loose somewhere that is getting knocked into and out of position.

I managed to snap this rather bad pic while it was open.

Inside tank

I have looked at maybe buying another circuit board but that one looks nothing like the ones I can see for sale.

Anyone got any ideas what the problem might be?

Thanks!
kenjara is offline Find More Posts by kenjara
Last edited by kenjara; Jul 01, 2012 at 12:38 PM.
Reply With Quote
Sign up now
to remove ads between posts
Old Jul 01, 2012, 11:51 AM
Registered User
Panther F's Avatar
United States
Joined Oct 2008
556 Posts
They are notorious for having bad crystals and or bad continuity there. Try re-connecting them or a new set.


HTH









~ Jeff
Panther F is offline Find More Posts by Panther F
Reply With Quote
Old Jul 01, 2012, 12:49 PM
Registered User
Joined Jul 2012
2 Posts
Hey thanks for the reply. I got it working now. There was a component next to the channel switch on the circuit board which needed re-soldering.

Seems to be ok so far.

You can see it working here.

Thanks!
kenjara is offline Find More Posts by kenjara
Reply With Quote
Old Jul 01, 2012, 02:18 PM
Registered User
Panther F's Avatar
United States
Joined Oct 2008
556 Posts
Oh, the cold solder connection is the hidden culprit.

Good going on the repair!











~ Jeff
Panther F is offline Find More Posts by Panther F
Reply With Quote
Old Jul 26, 2012, 07:30 AM
Registered User
Joined Apr 2008
84 Posts
kanjara looks like you picked up a nice runner.
CHIEFSONN is offline Find More Posts by CHIEFSONN
Reply With Quote
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Question Heng Long Panzer III not moving foxmcloud RC Tanks 12 Jun 06, 2012 09:57 PM
Help! Heng Long Panzer III won't turn! Freekill000 RC Tanks 3 Mar 10, 2012 03:55 PM
Discussion Heng Long - Panzer IV - with pics ! Green Dragon RC Tanks 15 May 06, 2011 04:15 PM
Discussion Heng Long DAK PZ.KPFW.IV AUSF.F-1 Tank upgrade? winkle1984 RC Tanks 3 Dec 09, 2009 08:00 PM
Discussion Heng Long Panzer IV F1 Robert Stinson RC Tanks 4 May 01, 2008 09:55 AM