HobbyKing.com New Products Flash Sale
Reply
Thread Tools
Old Jun 26, 2012, 02:16 PM
Registered User
Joined Jun 2012
2 Posts
Discussion
Razor 450 - Need a little help here please

hows it going guys, i have the razor 450. just replaced the tail boom and belt yesterday.

went out earlier to try and fly this thing, but it looks like im having 2 problems here..

first problem is It dosnt look like one of the blades will pitch, only one blade pitches while the other one just remains still..

Second problem, when i try to take off. I can go full throttle.. and the best way i can describe it is that it looks like the copter is pushing itself against the ground..

I can litterally have it at full throttle and it will just pretty much kiss the ground.

I am pretty much a newbie when it comes to helis, i have other rc experience, but im not sure on this one.
standbackimapro is offline Find More Posts by standbackimapro
Reply With Quote
Sign up now
to remove ads between posts
Old Jun 26, 2012, 02:49 PM
Cranky old fart
Balr14's Avatar
Germantown, WI.
Joined Oct 2007
21,486 Posts
Did you crash this and rebuild it? Pushing down means the pitch is reversed. That could be a transmitter setting, but it's usually caused by flipping the blade grips over and attaching them to the wrong side of the linkage.
Balr14 is offline Find More Posts by Balr14
Reply With Quote
Old Jun 26, 2012, 06:10 PM
Registered User
Joined Jun 2012
2 Posts
Yes, well actually my brother crashed it and bent the tail boom, so we put a new tail boom on, belt, 2 tail rotor blades, and 2 main blades.

Actually i just noticed another problem, that little rod that comes out of the gyro that slides up and down in that bracket ( i guess it keeps the rotor straight ) is broken also, so that bottom piece of the gyro spins side to side now..

But can you tell me how to correct the pitch problem?


EDIT: The part im talking about thats broke is on the swash plate, its that rod that comes off, and rides up an down in that bracket. i guess its to keep the swash plate centered?
standbackimapro is offline Find More Posts by standbackimapro
Last edited by standbackimapro; Jun 26, 2012 at 06:24 PM.
Reply With Quote
Old Jun 26, 2012, 08:08 PM
Cranky old fart
Balr14's Avatar
Germantown, WI.
Joined Oct 2007
21,486 Posts
You are referring to the anti-rotation bracket pin and if it's not there the swashplate will spin and won't move up and down properly. You MUST replace it.

I still say somebody flipped linkage, maybe when replacing blades. Disconnect the motor and see which way the linkage and blades moves when you increase throttle. If the pitch is moving down as you increase throttle the blade holder linkage is wrong. If the ball on the blade holders is on the left, disconnect the linkage, rotate it 180 and connect it to the linkage on the right. If it's on the right, switch it to the left. Of course you will have to flip the blades, too.

One more thing, it's hard to believe you did that much damage without bending a feathering shaft. I would disassemble the head and check the feathering shaft. Make damn sure you keep track of the order of the bushings, grommets and washers when you do this. Or, you will have one hell of a time putting it back together.
Balr14 is offline Find More Posts by Balr14
Reply With Quote
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Discussion Hello Folks, New Guy Here... Need Help, Please C. M. Wolf Racing Boats - Electric 12 Jun 22, 2012 11:50 AM
Help! Need help with E-razor wildone Beginner Training Area (Heli-Electric) 2 Mar 26, 2012 02:31 PM
Discussion A little help here please! goldsworthy Trader Talk 5 Mar 10, 2012 11:27 AM
Discussion Learning on Dynam E Razor 450 PLZZZ HELP heliferret Electric Heli Talk 6 Feb 23, 2012 10:19 PM
Discussion A little help pleas EDP300 motor system??? Majortomski GWS (Grand Wing Servo) 2 Mar 26, 2008 08:01 AM