HobbyKing.com New Products Flash Sale
Reply
Thread Tools
Old Sep 26, 2012, 11:08 AM
NDw
Registered User
Ireland, Limerick, Kilmallock
Joined Aug 2010
2,123 Posts
Loiter testing in strong gusty wind. No adjustment to any of the sticks.

megapirateng 2.7 r4 loiter strong wind, aio pro (3 min 52 sec)
NDw is offline Find More Posts by NDw
Reply With Quote
Sign up now
to remove ads between posts
Old Sep 26, 2012, 12:18 PM
Registered User
Joined Feb 2012
5 Posts
Quote:
I have loaded MPNG 2.4R4
typo
Quote:
Use latest firmware - 2.7R4, and latest mission Planner.
I am using the latest versions of both MPNG and Mission planner

Quote:
Do you have a usb to serial port driver like this one?
Thanks for the link. I updated my driver and still have no joy. I don't think it was the driver anyway because I could load the code in Arduino IDE and also use the Multiwii GUI with USB or BT.

I'm not sure whats going on here. I read the baud should be changed in config to 57600 and I have tried that but still am unable to connect to Mission Planner.

Is there additional software needed on my PC for the Mavlink protocol for function?
WPDPilot is offline Find More Posts by WPDPilot
Reply With Quote
Old Sep 26, 2012, 02:29 PM
Registered User
Joined Feb 2012
5 Posts
Ok well all it took was a quick restart on the PC and we're up and running! I can connect through BT and USB

Thanks for the help!
WPDPilot is offline Find More Posts by WPDPilot
Reply With Quote
Old Sep 26, 2012, 02:59 PM
Registered User
KevinBuckley70's Avatar
Oxfordshire, UK
Joined Jul 2001
279 Posts
Quote:
Originally Posted by NDw View Post
Loiter testing in strong gusty wind. No adjustment to any of the sticks.

http://www.youtube.com/watch?v=9VWf7...ature=youtu.be
Do you know, is that as good as it gets in loiter mode? Or will it get better with adjustment?
KevinBuckley70 is offline Find More Posts by KevinBuckley70
Reply With Quote
Old Sep 26, 2012, 03:11 PM
Registered User
Joined Aug 2009
73 Posts
Quote:
Originally Posted by NDw View Post
Loiter testing in strong gusty wind. No adjustment to any of the sticks.

http://www.youtube.com/watch?v=9VWf7...ature=youtu.be
Looks good...
Can you please share you PID settings (take screenshot of the PID settings screen)
and what is your setup and how many cells are you using 3S or 4S?
Thanks
Lior
liorz055 is offline Find More Posts by liorz055
Reply With Quote
Old Sep 26, 2012, 03:21 PM
NDw
Registered User
Ireland, Limerick, Kilmallock
Joined Aug 2010
2,123 Posts
Quote:
Originally Posted by KevinBuckley70 View Post
Do you know, is that as good as it gets in loiter mode? Or will it get better with adjustment?
Well it was very windy and yeah I've just been messing with settings to see what difference they seem to make so I'm sure they can be made much better

. I saw a vid of a loiter test in alot of wind by someone else that was wayy smoother and seems super accurate. Don't know if they are a member here. THis is it.

MegaPirateNG V2.7 R3 LOITER TEST _ CRIUS ALL IN ONE PRO _.MOV (0 min 53 sec)
NDw is offline Find More Posts by NDw
Last edited by NDw; Sep 26, 2012 at 03:55 PM.
Reply With Quote
Old Sep 26, 2012, 03:25 PM
NDw
Registered User
Ireland, Limerick, Kilmallock
Joined Aug 2010
2,123 Posts
Quote:
Originally Posted by liorz055 View Post
Looks good...
Can you please share you PID settings (take screenshot of the PID settings screen)
and what is your setup and how many cells are you using 3S or 4S?
Thanks
Lior
Yep these are my current pid settings. I've bee n playing with them alot. I havn't messed with the alt hold settings yet.



It's an rctimer clone flamewheel 450 frame. 1200kv park450 motors and 8x4.5 props on a 3000mah 3 cell.
NDw is offline Find More Posts by NDw
Last edited by NDw; Sep 26, 2012 at 03:39 PM.
Reply With Quote
Old Sep 26, 2012, 04:51 PM
Registered User
KevinBuckley70's Avatar
Oxfordshire, UK
Joined Jul 2001
279 Posts
Quote:
Originally Posted by NDw View Post
Well it was very windy and yeah I've just been messing with settings to see what difference they seem to make so I'm sure they can be made much better

. I saw a vid of a loiter test in alot of wind by someone else that was wayy smoother and seems super accurate. Don't know if they are a member here. THis is it.

http://www.youtube.com/watch?v=OkkoudNBIQc
That looks pretty good. I was trying to get an idea of what the goal is - all I have for comparison is the NAZA/GPS (which is also pretty good).
KevinBuckley70 is offline Find More Posts by KevinBuckley70
Reply With Quote
Old Sep 26, 2012, 05:04 PM
Registered User
Joined Aug 2009
73 Posts
Quote:
Originally Posted by NDw View Post
Yep these are my current pid settings. I've bee n playing with them alot. I havn't messed with the alt hold settings yet.



It's an rctimer clone flamewheel 450 frame. 1200kv park450 motors and 8x4.5 props on a 3000mah 3 cell.
Thanks, I will try to use some of them in mine.
From your experience how should I adjust mine, is there some rule of thumb to know when you achieved optimality in a desired PID setting?
Thanks
Lior
liorz055 is offline Find More Posts by liorz055
Reply With Quote
Old Sep 26, 2012, 05:04 PM
NDw
Registered User
Ireland, Limerick, Kilmallock
Joined Aug 2010
2,123 Posts
As for how useful loiter mode is idk. But it is fun to mess with
NDw is offline Find More Posts by NDw
Reply With Quote
Old Sep 26, 2012, 05:17 PM
NDw
Registered User
Ireland, Limerick, Kilmallock
Joined Aug 2010
2,123 Posts
Quote:
Originally Posted by liorz055 View Post
Thanks, I will try to use some of them in mine.
From your experience how should I adjust mine, is there some rule of thumb to know when you achieved optimality in a desired PID setting?
Thanks
Lior
For loiter or general flying? For general flying I tried adjusting just the rates pids first in acro mode as described in this tutorial. But when i got it flying ok in acro mode and then tried the stabilisation mode the rate pids seemed way too high as it oscillated rapidly.

So I found what worked best for me was adjusting the stabilise pids so that it feels fairly stable. Then still in stabilise mode, adjust the rate pids up until you notice some rapid oscillations, then back off a bit of the rate pids.

Setting up channel 6 on a radio knob as described here to adjust settings in flight makes things way easier and faster.

For loiter I tried adjusting rate loiter but found it best at close to default. And rate speed. I found increasing rate speed seems to make it loiter closer to "center". But on a clam day making it too high will prob make it not that smooth.
NDw is offline Find More Posts by NDw
Reply With Quote
Old Sep 26, 2012, 07:19 PM
Registered User
Australia, VIC, Bannockburn
Joined Aug 2012
44 Posts
Hi all

Trying to get APC220 to work. I have configured them to same frequency and followed guide but the s0~s03 port on my board snapped off during crash. I soldered directly to board and gps is working. i have a bluetooth module working in ftdi port is there a way to test the APC220 link or a way to use it on my FTDI port ? using megapirateng 2.7 R4
didgydont is offline Find More Posts by didgydont
Reply With Quote
Old Sep 26, 2012, 08:15 PM
Registered User
karmonkey's Avatar
Spain, PM, Palma de Mallorca
Joined Aug 2012
24 Posts
hello
I just received my AIO with a gps and bluetooth from rctimer and im reading the all thread but i cant understand how to get started.

Ive downloaded the multiwwiconf 2.1 but now dont know how to do.
Can anyone tell me how to step up in that project?

Thanks in advance!!
karmonkey is offline Find More Posts by karmonkey
Reply With Quote
Old Sep 26, 2012, 11:07 PM
Registered User
United States, CA, Yosemite Lakes
Joined Jan 2008
687 Posts
Quote:
Originally Posted by NDw View Post
Yep these are my current pid settings. I've bee n playing with them alot. I havn't messed with the alt hold settings yet.



It's an rctimer clone flamewheel 450 frame. 1200kv park450 motors and 8x4.5 props on a 3000mah 3 cell.
Can You show me how you have your FC mounted?

Thanks
scribble007 is offline Find More Posts by scribble007
Reply With Quote
Old Sep 26, 2012, 11:27 PM
Ungifted Prodigy
Multor's Avatar
Australia, QLD
Joined Jul 2012
288 Posts
hi there, guys,
i managed to connect my sonar.

i just need to know if it works?
how can i do that? is there a status on gui or something?
Multor is offline Find More Posts by Multor
Reply With Quote
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Mini-HowTo Arduino and HobbyKing Multi-Rotor Control Board V3.0 or KKmulticontroller v5.5 pprioverde Multirotor Talk 30 May 14, 2014 10:52 AM
Discussion New updated Crius Multiwii SE flight controller SGsoar Multirotor Electronics 72 May 15, 2013 09:36 PM
Discussion Jim, any plans for more multi rotor flight controller? chris24g Xtreme Power Systems 12 Jun 25, 2012 09:11 PM
Sold One New, one used ArduPilot 2560 APM1.0 Flight Controlls/autopilots wingspinner FPV Equipment (FS/W) 3 May 28, 2012 01:55 AM
Question Quad Build Using HobbyKing Multi-Rotor Control Board V3.0 (Atmega328 PA) SJackson Multirotor Talk 27 Apr 30, 2012 09:51 PM