HobbyKing.com New Products Flash Sale
Reply
Thread Tools
Old Jan 28, 2013, 05:18 PM
Registered User
Son, Norway
Joined Sep 2004
3,371 Posts
Quote:
Originally Posted by Freakazoid View Post
And yeah, the motors are giving off a bit of a vibe, but no more then usual, not to mention the old KKboard had no issues with it.
I cant tune it with P, because its either slow to respond or extremely sensitive about it, I cant find a sweetspot in between.
It seems to go from one to another somewhere around 30 to 35, In between its just unpredictable drifting and wobbling.
I went ahead and replaced the KK with a KK2 on my Micro PCB quad. I was low on battery, so not much flying this evening, but it was quite wild on P=75, I=30. No oscillation, just too much stick response. Stick scaling probably needs to be reduced, at least inside the livingroom.
I tried SL, with default SL settings, and unlike my bigger Q450, it was stable as a rock.

The mounting itself was more work than expected. Frame had 45mm, new KK2 had 44mm between holes. Sensors probably got stress tested by my Dremel.
Then the three-wire cable used across signal pin 2-4 didn't fit, since someone thought it was as good idea to not space those 0.1". Luckily a had another 6ch RX with CPPM support left.

Fred
flarssen is offline Find More Posts by flarssen
Reply With Quote
Sign up now
to remove ads between posts
Old Jan 28, 2013, 05:22 PM
Registered User
Son, Norway
Joined Sep 2004
3,371 Posts
Quote:
Originally Posted by efx View Post
No, no motors on any of them or receivers. Just programming them at the moment with battery and card.
Make sure motor wires don't touch each other, otherwise there will be sparks and smoke instead of music.


Fred
flarssen is offline Find More Posts by flarssen
Reply With Quote
Old Jan 28, 2013, 05:25 PM
efx
Rookie in training, heads up
efx's Avatar
Los Angeles
Joined Mar 2010
3,208 Posts
Haha...good warning. one of the heat shrinks came off when I went to unplug the motor. Those things are always coming off and I didn't think about that either. It's always the simple stuff that gets you.

Quote:
Originally Posted by flarssen View Post
Make sure motor wires don't touch each other, otherwise there will be sparks and smoke instead of music.


Fred
efx is offline Find More Posts by efx
RCG Plus Member
Latest blog entry: Malware?
Reply With Quote
Old Jan 28, 2013, 05:47 PM
Registered User
Freakazoid's Avatar
Roosendaal, Netherlands
Joined Dec 2004
2,820 Posts
Quote:
Originally Posted by tech69x View Post
Have you got the throttle at 100 if so lower it and what is you're min / max throttle set at
Its at 90%, to allow for some maneuvering room when I give it "full" throttle.
Been doing that on my multiwii's too, seems to be the right thing to do.

Quote:
Originally Posted by theothercliff View Post
40% of P is not a bad place to start.

Whoa! Read page 1 about limits. You might want to put those limits back to the stock values.

Turn ESC LVC off (nicad). Set ESC startup to as firm as possible. Set your KK2 limits back to stock. With gain 0, retune your P. Set your I to 40% of P and then retune it too.
Im just following the tuning video on page one, instructing me to jack limits up to 100 to remove dampening.
Seemed odd to me too, but if thats what the video asks...

So my best action is to reset to factory, kill I-Gain and find the P-Gain butterzone,
then raise up I-Gain to 40% of what P-gain I ended up with and rinse/repeat?

Quote:
Originally Posted by flarssen View Post
I went ahead and replaced the KK with a KK2 on my Micro PCB quad. I was low on battery, so not much flying this evening, but it was quite wild on P=75, I=30. No oscillation, just too much stick response.
75? Thats triple the gain ive got and its like herding a strung out cat already. Isn't standard settings like, 35 or something?
Dont tell me this is one of those 0=100% kinda deals.. Because then ive been going the wrong direction.
Freakazoid is offline Find More Posts by Freakazoid
Reply With Quote
Old Jan 28, 2013, 07:34 PM
Registered User
Canada, ON, Toronto
Joined Jan 2013
9 Posts
Camera Stabilzer Problems

I'm getting jittering with one of my servos mainly on pitch, details in youtube link

is the problem bad or weak servos? (also i'm aware that its not setup perfect yet on the control board)

Jdrones Gimbal Test - are my servos not strong enough and causing the pitch vibrations (0 min 19 sec)
yuri karlwithaka is offline Find More Posts by yuri karlwithaka
Reply With Quote
Old Jan 28, 2013, 07:43 PM
Flying Wood For Fun
irun4fundotca's Avatar
Canada, ON, Harrowsmith
Joined Jan 2012
7,270 Posts
@ yuri karlwithaka
What servos are you using?

- are they metal gear?
irun4fundotca is online now Find More Posts by irun4fundotca
RCG Plus Member
Reply With Quote
Old Jan 28, 2013, 07:53 PM
Registered User
Canada, ON, Toronto
Joined Jan 2013
9 Posts
Quote:
Originally Posted by irun4fundotca View Post
@ yuri karlwithaka
What servos are you using?

- are they metal gear?
http://www.servodatabase.com/servo/emax/es08md
yuri karlwithaka is offline Find More Posts by yuri karlwithaka
Reply With Quote
Old Jan 28, 2013, 08:11 PM
Flying Wood For Fun
irun4fundotca's Avatar
Canada, ON, Harrowsmith
Joined Jan 2012
7,270 Posts
I dont know much about those ones, but see them on ebay alot from china being sold
I think using a couple good tail/cyclic servos might work better, would cost more tho for sure

I was going to use a couple alzrc rcs-ds45a servos for my pan/tilt
irun4fundotca is online now Find More Posts by irun4fundotca
RCG Plus Member
Last edited by irun4fundotca; Jan 28, 2013 at 08:45 PM.
Reply With Quote
Old Jan 28, 2013, 11:07 PM
HeliHarry
harrym's Avatar
United States, OK, Tulsa
Joined Dec 2006
338 Posts
I seem to have run into a bit of a problem and I'd like some input!

Both my quads are 600-650 mm
Total weight with 3K/3S battery = 1224g / 2.7lb - 1353g / 3lb
FC - Both have KK2 v1.5

Setup #1 (DIY)
Speed Controllers - Turnigy Plush 25a (Stock)
Motors - Turnigy 2217 20turn 860kv
Props - HobbyKing HCB-09 9x5 / GemFan - 10x4.5
Battery - Turnigy 3000/3S (New) & Turnigy 4000/3S (New)

Setup #2 (X525)
Speed Controllers - Turnigy Plush 30a (Stock)
Motors - iPower 2217-930 (930kv)
Props - HobbyKing HCB-09 9x5 / GemFan - 10x4.5
Battery - Turnigy 3000/3S (New) & Turnigy 4000/3S (New)

Flying with the default settings on DIY, before tuning and using the 9x5 props,
I was getting 7-9 minutes of flight. Then I did "sting tuning" with the 10x4.5
props and upped the Ail/Elev "P Gains" to 100 & "I Gain to 50.

Now I'm lucky to get 2-3 minutes of flight time.

I have not flown the X525, but I'm getting the same times "string tuning"
with the 10x4.5 props as with the DIY.

I don't have anymore 9x5 props so I can't go there until I get some more.
I do have some 9x4.7's that I'll try in a few days.

I asked this in an earlier post but didn't get any input...

Is there any correlation between low & high P & I Gains and power consumption?

Tnx!
harrym is offline Find More Posts by harrym
Reply With Quote
Old Jan 28, 2013, 11:36 PM
efx
Rookie in training, heads up
efx's Avatar
Los Angeles
Joined Mar 2010
3,208 Posts
Or you can just get this one which works just as well and it's cheaper. I know, I have a couple of them on my 450 tails.
http://www.hobbyking.com/hobbyking/s...05sec_21g.html

Quote:
Originally Posted by irun4fundotca View Post
I dont know much about those ones, but see them on ebay alot from china being sold
I think using a couple good tail/cyclic servos might work better, would cost more tho for sure

I was going to use a couple alzrc rcs-ds45a servos for my pan/tilt
efx is offline Find More Posts by efx
RCG Plus Member
Latest blog entry: Malware?
Reply With Quote
Old Jan 28, 2013, 11:49 PM
Registered User
New Zealand, Canterbury, Christchurch
Joined Dec 2012
1,427 Posts
Quote:
Originally Posted by harrym View Post
I seem to have run into a bit of a problem and I'd like some input!

Both my quads are 600-650 mm
Total weight with 3K/3S battery = 1224g / 2.7lb - 1353g / 3lb
FC - Both have KK2 v1.5

Setup #1 (DIY)
Speed Controllers - Turnigy Plush 25a (Stock)
Motors - Turnigy 2217 20turn 860kv
Props - HobbyKing HCB-09 9x5 / GemFan - 10x4.5
Battery - Turnigy 3000/3S (New) & Turnigy 4000/3S (New)

Setup #2 (X525)
Speed Controllers - Turnigy Plush 30a (Stock)
Motors - iPower 2217-930 (930kv)
Props - HobbyKing HCB-09 9x5 / GemFan - 10x4.5
Battery - Turnigy 3000/3S (New) & Turnigy 4000/3S (New)

Flying with the default settings on DIY, before tuning and using the 9x5 props,
I was getting 7-9 minutes of flight. Then I did "sting tuning" with the 10x4.5
props and upped the Ail/Elev "P Gains" to 100 & "I Gain to 50.

Now I'm lucky to get 2-3 minutes of flight time.

I have not flown the X525, but I'm getting the same times "string tuning"
with the 10x4.5 props as with the DIY.

I don't have anymore 9x5 props so I can't go there until I get some more.
I do have some 9x4.7's that I'll try in a few days.

I asked this in an earlier post but didn't get any input...

Is there any correlation between low & high P & I Gains and power consumption?

Tnx!
Listen to your motors, I would guess you could hear oscillations even if you can't see them. The motors are likely fighting themselves a lot increasing power usage. My Quad never started oscillating and I got all the way to 300 P gain, it wasn't until I got it out in a bit of wind that I saw the oscillations, after that I could hear them in the clam again. Now my P gains are on about 75, I is on 35 and it flies fine, even in heavy wind
WendoNZ is offline Find More Posts by WendoNZ
Reply With Quote
Old Jan 29, 2013, 12:03 AM
efx
Rookie in training, heads up
efx's Avatar
Los Angeles
Joined Mar 2010
3,208 Posts
I decided to play with the timings on the esc's and here's a video from that. Interesting to say the least.
Testing high timing on the quad... (3 min 8 sec)
efx is offline Find More Posts by efx
RCG Plus Member
Latest blog entry: Malware?
Reply With Quote
Old Jan 29, 2013, 12:05 AM
HeliHarry
harrym's Avatar
United States, OK, Tulsa
Joined Dec 2006
338 Posts
Quote:
Originally Posted by WendoNZ View Post
Listen to your motors, I would guess you could hear oscillations even if you can't see them....

I did the same thing, raised my P Gain all the way up to 300 and never
got any oscillations and can't hear any. It did act up a bit. I flew the DIY
outside and it flew well at P Gain 100, but only for 2-3 minutes on each
of 3 batteries. Even one 4000/3S.

Did you notice a reduction in run times when you had the Gain up high?
harrym is offline Find More Posts by harrym
Reply With Quote
Old Jan 29, 2013, 12:08 AM
Custom quad builder
tech69x's Avatar
United States, TX, Spring
Joined Apr 2012
2,364 Posts
This it why I use flashed esc's on all my quads
tech69x is offline Find More Posts by tech69x
Reply With Quote
Old Jan 29, 2013, 12:10 AM
HeliHarry
harrym's Avatar
United States, OK, Tulsa
Joined Dec 2006
338 Posts
Quote:
Originally Posted by tech69x View Post
This it why I use flashed esc's on all my quads
Are you directing that to me or someone else?
harrym is offline Find More Posts by harrym
Reply With Quote