HobbyKing.com New Products Flash Sale
Reply
Thread Tools
Old Aug 08, 2012, 01:45 AM
Registered User
United States, CA, Santa Monica
Joined Jul 2011
489 Posts
Hey KapteinKuk- any chance you'll release the source code for the firmware so we can all play around with it?

Thanks
Lpbug is offline Find More Posts by Lpbug
Reply With Quote
Sign up now
to remove ads between posts
Old Aug 08, 2012, 01:53 AM
Registered User
United States, TX, Houston
Joined Jan 2005
1,034 Posts
Quote:
Originally Posted by kapteinkuk View Post
I can think of two reasons: 20MHz oscillator is not starting, or flash memory corruption.

As soon as I get my hands on a dead KK2, I will investigate.
If someone can send me one, I will pay shipping. Preferable close to Norway so the shipping will be low.

The KK2 must have died (no text, LED flash or beep), on its own. No crash or mis-wiring.

However, I can not supply a new board.
Bugger...

Do you think that it may come back to life if i flash it with your new firmware when you release it?

I have other FC i can use so its not the end of the world.

Its a shame it bricked itself as it had allot of potential.

Cheers

Ben
wazzer is offline Find More Posts by wazzer
Reply With Quote
Old Aug 08, 2012, 02:02 AM
Registered User
Australia, QLD, Brisbane
Joined Nov 2011
949 Posts
Quote:
Originally Posted by wazzer View Post
Bugger...

Do you think that it may come back to life if i flash it with your new firmware when you release it?

I have other FC i can use so its not the end of the world.

Its a shame it bricked itself as it had allot of potential.

Cheers

Ben
Just send it back to HK under warranty.
Maybe they will send it to Rolf or analyse and give you a new one.
Erknie is offline Find More Posts by Erknie
Reply With Quote
Old Aug 08, 2012, 03:05 AM
Registered User
rustymit's Avatar
Saudi Arabia, Tabuk Province, Tabuk
Joined Nov 2005
21 Posts
Just Callibrated my esc's using the "y" splitter method, flawless, worked realy well. I have 4, 30A Blue series and trying to cal them using the fc is a nightmare, I believe it's because there is so much lag in the binding of spektrum receivers, the esc's enter into their program mode quicker than the Spektrum can react
rustymit is offline Find More Posts by rustymit
Reply With Quote
Old Aug 08, 2012, 03:26 AM
Quad Whisperer
Joined Jul 2008
942 Posts
Quote:
Originally Posted by HappySundays View Post
LOL... and that's in assembler.
My code (written in C) is currently at about 93% program, 72% data.
I still have a few features I want to put in...
I'm sure a good C compiler is not far behind assembler size wise, or speed wise.
kapteinkuk is offline Find More Posts by kapteinkuk
Last edited by kapteinkuk; Aug 08, 2012 at 03:42 AM.
Reply With Quote
Old Aug 08, 2012, 03:32 AM
Quad Whisperer
Joined Jul 2008
942 Posts
Quote:
Originally Posted by sharonx View Post
Any time frame for the improved SL firmware ?
No, not yet.
kapteinkuk is offline Find More Posts by kapteinkuk
Reply With Quote
Old Aug 08, 2012, 03:38 AM
Quad Whisperer
Joined Jul 2008
942 Posts
Quote:
Originally Posted by Lpbug View Post
Hey KapteinKuk- any chance you'll release the source code for the firmware so we can all play around with it?

Thanks
Yes, I will do that.
kapteinkuk is offline Find More Posts by kapteinkuk
Reply With Quote
Old Aug 08, 2012, 03:40 AM
Quad Whisperer
Joined Jul 2008
942 Posts
Quote:
Originally Posted by wazzer View Post
Bugger...

Do you think that it may come back to life if i flash it with your new firmware when you release it?

I have other FC i can use so its not the end of the world.

Its a shame it bricked itself as it had allot of potential.

Cheers

Ben
Yes, If flash memory corruption is the problem, the new FW will fix it.

Do you have a programmer, and can check if the dead KK2 responds to it?
kapteinkuk is offline Find More Posts by kapteinkuk
Reply With Quote
Old Aug 08, 2012, 04:02 AM
Registered User
United States, TX, Houston
Joined Jan 2005
1,034 Posts
Yes i do

I will check it out and let you know
wazzer is offline Find More Posts by wazzer
Reply With Quote
Old Aug 08, 2012, 05:49 AM
Registered User
quax's Avatar
NRW, Germany
Joined Apr 2004
711 Posts
Quote:
Originally Posted by kapteinkuk View Post
I'm sure a good C compiler is not far behind assembler size wise, or speed wise.
In deed, the code generation and the optimizer become better and better.

I think the advantage of your software is your "binary-float", that should be less code comsumptive than the standard float implementation.
If a software doesn't use floats, there may be an advantage for the C compiler over ASM meanwhile.
quax is offline Find More Posts by quax
Reply With Quote
Old Aug 08, 2012, 06:14 AM
Registered User
United Kingdom, Scotland, Aberdeen
Joined Mar 2010
696 Posts
Flashing

Hi,Simon,why dont you get "HK",to do a flashed speed controller,and get paid royalties,and then it will make us all happy,Marty.
NEAGRON is online now Find More Posts by NEAGRON
Reply With Quote
Old Aug 08, 2012, 06:32 AM
Registered User
Joined May 2012
89 Posts
Hi all,
I'm a bit confused about my KK2 board.
I have replaced my genuine DJI F450 frame with a home made 300mm quad frame.
I have calibrated the sensors and ESCs again as if starting afresh.
I have changed the following settings in my PI editor:

Roll/Pitch
PGain: 20
PLimit: 100
IGain: 0
I Limit: 20
Yaw:
PGain: 40
Plimit: 20
I Gain: 0
I Limit: 10
Self level is off,
Stick Scaling: Roll-30, Pitch-30, Yaw-30, Throttle-90.
It is still drifting to the left( I mean Motor #2 side) and I have put a set of new balanced props and a new quad frame.
What causes a quad to drift to one side only?Is it in the PI settings or other issues?Im lost.
It is a very easy board to learn and I have noticed it is quite stable during flight but only problem is drift.

Now onto receiver test:
I have noticed the following:
Elevator- stick movement forward, it shows (-94) a negative value on the KK2 screen!
Stick movement back, it shows +101+ a positive value on the screen.
Stick movement is correct though and corresponds to the appropriate movement.

Rudder- stick movement to the left, it shows +101, a positive figure on KK2 screen.
Stick movement to the right, it shows (-94), a negative figure on the screen.
Stick movement is correct.
Is this normal?
What am I missing?
Im using a Hitec- Aurora 9 Tx with Optima 9 Rx.
The rest, that is the Aileron and Throttle are fine and no dramas.
How do I fix this if it is wrong.
Anyone please care to explain where I'm wrong.
I really like this board a lot because of its ease to change settings on the spot.
Thanks a lot,
AeroR
AeroR is offline Find More Posts by AeroR
Reply With Quote
Old Aug 08, 2012, 06:32 AM
Registered User
Tokol, Hungary, EU
Joined Oct 2010
321 Posts
Quote:
Originally Posted by bobepine View Post
Look at the video I posted above. That's with 110 on the stick scaling for pitch and roll. It's aggressive though. I never go full stick to flip it with 110. It will easily pull triple flips at 110. You can start at around 80 and increase if it flips too slow for you, or if you like to be able to flip closer to center stick like me.

Best,
Chris
But I do!
I am also in this business for some time. This is how it flips@110 stick scaling with full stick (go to 0:45):

HK KK2.0 diy quad crash compilation (1 min 16 sec)
icah is online now Find More Posts by icah
Reply With Quote
Old Aug 08, 2012, 06:39 AM
Registered User
Joined May 2012
89 Posts
Quote:
Originally Posted by NEAGRON View Post
Hi,Simon,why dont you get "HK",to do a flashed speed controller,and get paid royalties,and then it will make us all happy,Marty.
Yes, I agree with Neagron. It would be a win-win for all involved.

AeroR
AeroR is offline Find More Posts by AeroR
Reply With Quote
Old Aug 08, 2012, 06:51 AM
Hulk likes flying things
Phalanx-0's Avatar
United States, IN, Kokomo
Joined May 2008
613 Posts
Learn to flash your own, it's easy.
Phalanx-0 is offline Find More Posts by Phalanx-0
Reply With Quote