HobbyKing.com New Products Flash Sale
Reply
Thread Tools
Old Jun 17, 2012, 07:15 PM
Registered User
United States, AZ, Queen Creek
Joined Jan 2007
201 Posts
Question
Help with a KK board, newbie is stuck.

Hi Guys,
I've been working with a tricopter setup. It's all built, everything is installed. I have a KK board (think it's a clone) all wired up and seems to be working fine. I have this problem, as I apply throttle all rotors start up. At this point the board acts normal, everything responds as it should. Now as I increase the throttle, the right forward motor will stop, the left will continue to power up as does the rear rotor. Increasing throttle, the left motor then stops and the rear rotor continues to run. The board was purchased on the RCG classifieds, and was bought new. I don't have any instructions to follow. I found instructions on the web for a KK board setup for tricopters. I have changed out motors and ESC's but still get the same result. am I missing something? Any suggestions at this time would be grateful. I'm not new to RC, I fly FPV, and would like to try FPV multirotor.

Thanks, Dave
rvski is offline Find More Posts by rvski
Reply With Quote
Sign up now
to remove ads between posts
Old Jun 17, 2012, 07:25 PM
Registered User
gitit20's Avatar
Joined May 2012
584 Posts
I bet you forgot to do the ESC calibration try this and see what this does also make sure its flashed with the try copter firmware and not a quadcopter firmware i forgot to do the ESC calibration and was like WTH for hours


Here is how you do it...

REMOVE YOUR PROPS BEFORE DOING THIS


-Turn yaw pot to zero.
-Turn on transmitter.
-Throttle stick to full.
-Turn on flight controller.
-Wait until the ESC's beeps twice after the initial beeps. (Plush and SS ESC's)
-Throttle stick to off. ESC's beep.
-Turn off flight controller.
-Restore the yaw pot.
-Power up and give it a go.


Quote:
Originally Posted by rvski View Post
Hi Guys,
I've been working with a tricopter setup. It's all built, everything is installed. I have a KK board (think it's a clone) all wired up and seems to be working fine. I have this problem, as I apply throttle all rotors start up. At this point the board acts normal, everything responds as it should. Now as I increase the throttle, the right forward motor will stop, the left will continue to power up as does the rear rotor. Increasing throttle, the left motor then stops and the rear rotor continues to run. The board was purchased on the RCG classifieds, and was bought new. I don't have any instructions to follow. I found instructions on the web for a KK board setup for tricopters. I have changed out motors and ESC's but still get the same result. am I missing something? Any suggestions at this time would be grateful. I'm not new to RC, I fly FPV, and would like to try FPV multirotor.

Thanks, Dave
gitit20 is offline Find More Posts by gitit20
Reply With Quote
Old Jun 17, 2012, 09:08 PM
Registered User
gitit20's Avatar
Joined May 2012
584 Posts
Also wanted to add it may be required to reverse the gyro's you can find that info on the kk board website
gitit20 is offline Find More Posts by gitit20
Reply With Quote
Old Jun 17, 2012, 09:11 PM
Atomic Playboy
United States, MN, Inver Grove Heights
Joined Jun 2012
218 Posts
This guide has step by step for everything:
http://www.rcexplorer.se/Educational...guide/tri.html

Also note that if you're running version 1.6 of the tricopter firmware, the pots are:
Yaw: P and I for yaw
Pitch: I for Roll and Pitch
Roll: P for Roll and Pitch

I didn't know this and had a hell of a time getting my gains set.
signal15 is offline Find More Posts by signal15
Reply With Quote
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Help! help needed with turnigy x9 and kk board setup guy1a Multirotor Talk 6 Apr 18, 2012 03:09 PM
Help! need help with a new multi with kk board abletowinginc Multirotor Talk 3 Apr 13, 2012 10:08 AM
Discussion Newb needs help with kk 5.5 board asap please MOTOSTEIN Multirotor Talk 0 Feb 11, 2012 06:34 PM
Help! Help with KK board Quad, motors shut down hogfarmer Multirotor Talk 24 Jan 27, 2012 07:48 PM
Discussion I need some help with Minsoo Kim KK board SeismicCWave Multirotor Talk 1 Apr 08, 2011 06:01 AM