HobbyKing.com New Products Flash Sale
Reply
Thread Tools
Old Jul 12, 2012, 11:26 AM
throw new IOPilotException();
IceWind's Avatar
Ireland, County Dublin, Dublin
Joined Feb 2005
2,641 Posts
What code are you guys using now to test?
I have received new arduinos so I can test this now.
IceWind is online now Find More Posts by IceWind
Reply With Quote
Sign up now
to remove ads between posts
Old Jul 12, 2012, 11:56 AM
Registered User
jalves's Avatar
Portugal
Joined Mar 2004
2,637 Posts
I am playing (and learning) with my homebrew "video experimenter".

Not much to show unfortunately.

icewind, Check the code uploaded by muerzi in this thread.
jalves is offline Find More Posts by jalves
Reply With Quote
Old Jul 12, 2012, 02:58 PM
Registered User
Joined Jan 2011
82 Posts
@IceWind: take this source from post 43
And build the diy osd circuit

Cheers
muerzi is offline Find More Posts by muerzi
Reply With Quote
Old Jul 12, 2012, 06:45 PM
throw new IOPilotException();
IceWind's Avatar
Ireland, County Dublin, Dublin
Joined Feb 2005
2,641 Posts
Got it. Thanks!
I picked all the parts today, tomorrow I should put this all together and test that code.
IceWind is online now Find More Posts by IceWind
Reply With Quote
Old Jul 14, 2012, 02:56 PM
throw new IOPilotException();
IceWind's Avatar
Ireland, County Dublin, Dublin
Joined Feb 2005
2,641 Posts
Got it up and running.
I noticed the image is not stable, but it's either the parts I've used or the fact I'm using a TV Card to check the video.

Any ideas?

(noticed now that the GoPro OSD image is stable, so it has to be from the OSD)
IceWind is online now Find More Posts by IceWind
Reply With Quote
Old Jul 14, 2012, 04:24 PM
Registered User
Joined Jan 2011
82 Posts
Have you tried the original diyosd code from dennis?

Will this be also unstable?
Please have a look back this thread. We all have the same prob, but at 500 khz it should be no problem to correct that jitter...
muerzi is offline Find More Posts by muerzi
Reply With Quote
Old Jul 14, 2012, 05:01 PM
throw new IOPilotException();
IceWind's Avatar
Ireland, County Dublin, Dublin
Joined Feb 2005
2,641 Posts
Yeah, with the diyosd code is equally unstable.
I was checking the previous posts, I need to still swap some parts. I initially made the first design that Dennis made and after to see if it would work better I made the second.
But there's some resistors I don't have available.
IceWind is online now Find More Posts by IceWind
Reply With Quote
Old Jul 16, 2012, 02:05 PM
Registered User
Joined Jan 2011
82 Posts
I soldered my video experimenter board today.
Tomorrow or on wednesday, i'll try what the board is able to "detect" in the videostream

Any progress so far?
muerzi is offline Find More Posts by muerzi
Reply With Quote
Old Jul 16, 2012, 05:13 PM
Registered User
jalves's Avatar
Portugal
Joined Mar 2004
2,637 Posts
My homebrew video experimenter with closedcaptions pde is capable of capturing the A and 4 characters that I am inserting in line 21 with the diyosd hardware, but nothing happens so far in the serial output.
jalves is offline Find More Posts by jalves
Reply With Quote
Old Jul 16, 2012, 11:26 PM
Registered User
Joined Jan 2011
82 Posts
Any code you used?
Can't understand what you mean
muerzi is offline Find More Posts by muerzi
Reply With Quote
Old Jul 17, 2012, 09:16 AM
Registered User
Joined Jan 2011
82 Posts
With code do you use for serial?
Normal serial won't work. Try the pollserial from nooptopicdesign...

Please post your code
muerzi is offline Find More Posts by muerzi
Reply With Quote
Old Jul 17, 2012, 01:41 PM
Registered User
jalves's Avatar
Portugal
Joined Mar 2004
2,637 Posts
muerzi,

I use nootropicdesign code, only change from NTSC to PAL.

I didn't have time so far to work deeply in the arduino library (TVout), the software example from nootropic work well to grab the SPDR data (A and 4 that I put in line 21 of teh video signal) and show it in the screen, but I was unable so far to see something in the serial output (pollserial that is...).

I couldn't so far find a TV video output with closed captions, my cable "box" output TV video through a scart but the closed captions aren't there (the "video experimenter" produces a continuous white line in the screen) .

How do you pretend to use your video experimenter board to see the closed captions (teletext) in the serial output of the arduino IDE ?
jalves is offline Find More Posts by jalves
Reply With Quote
Old Jul 17, 2012, 02:26 PM
Registered User
Joined Jan 2011
82 Posts
Do you use 128,96 for tv.begin?

How many delays do you use before writting the 'A' and how many delays to wait before writting to SPDR again?

Try tv.print(c[0]) and tv.print(c[1]) to see the chars in the video and uncomment the "displayccdata".

I will try to send them through serial AND overlay it on the video.
muerzi is offline Find More Posts by muerzi
Reply With Quote
Old Jul 18, 2012, 01:29 PM
Registered User
Joined Jan 2011
82 Posts
Today i experimented a bit and see what i have.

Here a little description

1: The Characters "A" (2 times)
2: The Video Experimenter board found the bit that are on
3: The adjusted bit beginnings
Code:
// VBI_Inserter with _delay_loop_1(44); before writting to SPDR
byte bpos[][8] = {{1,  8,  14, 20, 26, 33, 39, 46},   {53, 60, 66, 73, 79,  85,  91,  98}};
but i can get no ouput. wheter on serial nor witch tv.print. With tv.print i tryed to remove the Parity check, but nothing happend.

Any idea?
muerzi is offline Find More Posts by muerzi
Reply With Quote
Old Jul 18, 2012, 01:49 PM
Registered User
jalves's Avatar
Portugal
Joined Mar 2004
2,637 Posts
same boat here...

maybe a PAL problem??

I would like to have a video feed with closed captions (teletext) to test the nootropic software, but I am unable to find one available.
jalves is offline Find More Posts by jalves
Reply With Quote
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Build Log Opensource frames design files! DexterIt Multirotor Talk 5 Apr 26, 2012 08:42 AM