HobbyKing.com New Products Flash Sale
Reply
Thread Tools
Old May 16, 2012, 05:53 AM
FPV flyer
Czech Republic, Prague
Joined Jan 2012
51 Posts
Help!
Novice get stucked with Multiwii Y6 Copter

Hello copter maniacs,

I am newbie to rotor and mutirotor machines. I have experience with RC fixed wings models and aslo successfull with FPV equipment.

I like to make a video by airplane and it is very inviting to fly with camera with some multirotor.

After study I choose plug and play soulution from multiwiicopters.com - I chosed they package deal Y6 Scarab with gimbal.
Y6 is builded now, and almost everithing looks works good, but I am stucked now, have problem with some oscilation/ stabilisation.


I make some two very short videos with problem.
In "hand" video on begin I am trying to destabilize copter pitch position, it works very nice, copter is tryinfg to push aginst my hand.
Then trying "roll destabilization and copter is not helping to stabilize it, even it made it worst
Second video shows how it looks after start.

Multiwii Y6 In hand trouble (1 min 6 sec)


Multiwii Y6 - on the ground trouble (0 min 24 sec)

TX is calibrated (loww, mid & end points).
Props are balanced, engines also balanced, not experience from previous project, but looks that vibration are now very low)
PID are default preseted from multiwiicopters.com
Not sure about acc and gyro calibrating (not sure if I made it corect and if it can cause those problems) - I just do that by sticks on TX after copter is powered on and unarmed.

Thank you very much for any hint, any advice.

Have a nice day, Dave.
sprstemvnose is offline Find More Posts by sprstemvnose
Reply With Quote
Sign up now
to remove ads between posts
Old May 16, 2012, 06:36 AM
Registered User
Joined Jul 2008
35 Posts
Did you calibrate all the ESC's? Are all the ESC's connected to the correct outputs on the flightcontroller?
Gh05trider is offline Find More Posts by Gh05trider
Reply With Quote
Old May 16, 2012, 07:34 AM
FPV flyer
Czech Republic, Prague
Joined Jan 2012
51 Posts
Quote:
Originally Posted by Gh05trider View Post
Did you calibrate all the ESC's? Are all the ESC's connected to the correct outputs on the flightcontroller?
Hello, I calibrated the ESCīs all together thrue multiconnector wire suplied in the package, Do you think it is ok?

I will check as you recomend the ESC to FC connection.

thank you very much for your advices, David.
sprstemvnose is offline Find More Posts by sprstemvnose
Reply With Quote
Old May 16, 2012, 07:36 AM
FPV flyer
Czech Republic, Prague
Joined Jan 2012
51 Posts
Quote:
Originally Posted by Gh05trider View Post
Did you calibrate all the ESC's? Are all the ESC's connected to the correct outputs on the flightcontroller?
P.S. Do you mean the throtle learning curve calibration?
sprstemvnose is offline Find More Posts by sprstemvnose
Reply With Quote
Old May 16, 2012, 07:44 AM
Registered User
Joined Jul 2008
35 Posts
Quote:
Originally Posted by sprstemvnose View Post
P.S. Do you mean the throtle learning curve calibration?
Yes that's the one.
Gh05trider is offline Find More Posts by Gh05trider
Reply With Quote
Old May 16, 2012, 08:41 AM
Registered User
Joined Sep 2010
286 Posts
Seems like a gyro compensation direction is the wrong way, might need to change the roll direction.
bladeaudio is offline Find More Posts by bladeaudio
Reply With Quote
Old May 16, 2012, 03:01 PM
FPV flyer
Czech Republic, Prague
Joined Jan 2012
51 Posts
Quote:
Originally Posted by Gh05trider View Post
Yes that's the one.
Quote:
Originally Posted by bladeaudio View Post
Seems like a gyro compensation direction is the wrong way, might need to change the roll direction.
Hello, try now do all what you said to me.

Firstly I disconected all ESCīs from FC and check one by one if is it wired correctly

I dont know why, but after reconect all together the gyro works (if I can say, you can judge it one video)
But in random moments something get wrong and big oscilation hapens.

I made a 1min. video

on begin I am showing it with low RPM the gyro looks now works
then try control it by Tx, looks also good
last part try to destabilize copter a litle and oscilation starts

Is it possible that it can be caused by wrong ESC calibration?
Maybe calibrate it again?
Maybe vibrations are not low enough?

if you have any idea what can be wrong, I will be your slave forever guys!
thank you for any hints, David.

Multiwii Y6 - oscilation trouble, hand test (0 min 57 sec)
sprstemvnose is offline Find More Posts by sprstemvnose
Reply With Quote
Old May 16, 2012, 03:24 PM
FPV flyer
Czech Republic, Prague
Joined Jan 2012
51 Posts
I dont write what hardware is used, I think it can be usefull

I am using exactly this - http://www.multiwiicopter.com/products/sku-21
Tx is Hitec Aurora and Rx is Optima7

All I changed is just I desolder the DC bridge on Paris Sirius 600 board, other things used without change of something

After first day hand and livingroom testing I saw that one group of LED in Andromeda orientation LED board is not working (sometimes flashes fast, today just short blinks, mostly time are off, but probably nothing to do with the oscilation)

bye, David.
sprstemvnose is offline Find More Posts by sprstemvnose
Reply With Quote
Old May 16, 2012, 03:27 PM
Registered User
Joined Sep 2010
286 Posts
It looks like it is doing the correct compensation. Have you tried flying it? It could be I term wind up caused by your holding it and its not able to truly correct for the motion you are creating with your hand. That's just a hunch because it seems to start out fine and then suddenly get worse after it's been running a while.
bladeaudio is offline Find More Posts by bladeaudio
Reply With Quote
Old May 16, 2012, 04:02 PM
Plane Destroyer / Life Enjoyer
airbagit13's Avatar
Miami, FL
Joined May 2009
3,484 Posts
You got some balls sticking your hands between 4 spinning blades of death to grab your copter. Lol
airbagit13 is offline Find More Posts by airbagit13
Reply With Quote
Old May 16, 2012, 04:40 PM
FPV flyer
Czech Republic, Prague
Joined Jan 2012
51 Posts
Quote:
Originally Posted by bladeaudio View Post
It looks like it is doing the correct compensation. Have you tried flying it? It could be I term wind up caused by your holding it and its not able to truly correct for the motion you are creating with your hand. That's just a hunch because it seems to start out fine and then suddenly get worse after it's been running a while.
Quote:
Originally Posted by airbagit13 View Post
You got some balls sticking your hands between 4 spinning blades of death to grab your copter. Lol
I dont tried to fly it for now, I am too scared to start to learn to fly it
I have to solve it and find where is the problem firstly, otherwise I will crash it very fast
I hope you are right, but it starts so randomly and is then absolutely uncontrollable...


I know about danger, what to say to it, stupid thing, you are absolutely right
Any hint to my point apreciated

good night, David.
sprstemvnose is offline Find More Posts by sprstemvnose
Reply With Quote
Old May 16, 2012, 05:36 PM
Plane Destroyer / Life Enjoyer
airbagit13's Avatar
Miami, FL
Joined May 2009
3,484 Posts
Ahhh now that I watched the video its all gravy. I thought you walked over to it and grabbed it out of the air. Lots of people like doing that and then flinging it to the sides. Freaks me the hell out!

I agree that you should try to just hover it. If you think it may go crazy just hover ofer some tall grass and cut the throttle if your uncomfortable, it seemed to be moving the right way. Did you balance all your props?
airbagit13 is offline Find More Posts by airbagit13
Reply With Quote
Old May 16, 2012, 07:16 PM
Registered User
Joined Sep 2010
286 Posts
Ya, good idea, find a place with some tall grass and get it up off the ground just high enough to be out of the ground effect from the prop wash and see how if flies.

It could be that you have some gains set too high as well, maybe back off your I setting for now, you really don't need I to fly, it just adds to the stability, but if its set too high it will cause oscillations.
bladeaudio is offline Find More Posts by bladeaudio
Reply With Quote
Old May 16, 2012, 10:01 PM
Plane Destroyer / Life Enjoyer
airbagit13's Avatar
Miami, FL
Joined May 2009
3,484 Posts
What he said. Tune it with no I get her to fly good and then slowly add I till she feels nice and stable.
airbagit13 is offline Find More Posts by airbagit13
Reply With Quote
Old May 17, 2012, 07:16 AM
FPV flyer
Czech Republic, Prague
Joined Jan 2012
51 Posts
Quote:
Originally Posted by bladeaudio View Post
Ya, good idea, find a place with some tall grass and get it up off the ground just high enough to be out of the ground effect from the prop wash and see how if flies.

It could be that you have some gains set too high as well, maybe back off your I setting for now, you really don't need I to fly, it just adds to the stability, but if its set too high it will cause oscillations.
Quote:
Originally Posted by airbagit13 View Post
What he said. Tune it with no I get her to fly good and then slowly add I till she feels nice and stable.

Hi guys, thank you so much for your hints!
Props are balanced on magnetic balancer, motors also balanced by tape
I dont balance it dinamically, just static.

OK, my plan is now to try set lower I on roll + pitch and make some new test, hope the oscilation disappear.
Anyway I will wait just for less windy day ang go out to try it hovering.

Have a nice day, David.
sprstemvnose is offline Find More Posts by sprstemvnose
Reply With Quote
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Discussion Newbie trying to get an x copter to fly right with kk 5.5 jb_bak Multirotor Talk 1 Feb 19, 2012 11:05 AM
Build Log RC-Carbon Y6 Build on MultiWii platform Sid3ways Multirotor Talk 80 Sep 18, 2011 09:44 AM
Discussion Multiwii Y6 problem. AlexnderH Multirotor Talk 1 Aug 10, 2011 07:13 AM
Discussion First Flight with the prototype "WOV-Y6 500 Copter" WOV-Y6-Copter Multirotor Talk 37 Mar 28, 2011 10:30 PM
Build Log MultiWii Copter Build Log ghost2212 Multirotor Talk 2 Mar 16, 2011 01:01 PM