HobbyKing.com New Products Flash Sale
Reply
Thread Tools
Old Apr 22, 2012, 12:17 PM
Registered User
Joined Apr 2012
4 Posts
Help!
Help! Burn the Flysky 9x radio, and now shows me 1.1V on the screen

FIXED!!!

Hi all, I present my name is Daniel and am writing from Chile.

I have a radio Flysky 9x (TURNIGY 9x). connect the lipo in reverse, and burn the radio, I followed the post repair but I have a problem and that radio is showing me the battery voltage to 1.1V.

Change the 22uf capacitor, and VR 5V and 3.3 V are ok. the VR module 5v Tx seems that burned in the output is have 2.4V and the receiver does not respond is crazy.

then do the tests without the module, but can not find the problem that shows me 1.1v in the radio display. verified with the voltmeter and 12v lipo has.

I hope I can help, thanks.

* Excuse my English
Mc.Daniel is offline Find More Posts by Mc.Daniel
Last edited by Mc.Daniel; Apr 25, 2012 at 11:50 AM. Reason: FIXED!!!
Reply With Quote
Sign up now
to remove ads between posts
Old Apr 23, 2012, 08:12 AM
Registered User
Joined Apr 2012
4 Posts
Guys, nobody has a clue, that I should check??

Please, this is the largest community in RC!

I appreciate any help!
Mc.Daniel is offline Find More Posts by Mc.Daniel
Reply With Quote
Old Apr 23, 2012, 01:43 PM
Registered User
Central California
Joined Dec 2006
2,404 Posts
Ive seen this report several times.IIRC the best thing to do is to return it for service (if they actually do have service).You can spend loads of time trying to chase down all the burnt components and still not make it right again.About the only way to be sure you have everything working correctly again is to toss it and buy another one.
aerocal is offline Find More Posts by aerocal
Reply With Quote
Old Apr 25, 2012, 11:01 AM
Registered User
Crashj007's Avatar
United States, NC, Raleigh
Joined Oct 2011
193 Posts
If you shorted the transmitter LiPo (??) battery it may be discharged past the safe point. First step is to check the transmitter (tx) battery voltage and also see if it has swollen. It may well have dropped off to 1.1 volts. There are ways to recover them, but I would never fly with a damaged battery. The best setup for you may be to use the standard AA batteries.
It should be impossible to burn the transmitter if you use the three position connector and connect the positive to the middle position and the ground to either outside position.
I do not understand how you can be seeing 1.1 volt on the screen. That would not be enough voltage to drive the LCD? The transmitter can be operated on two LiFe batteries (6.8V), but you have to bugger with the alarm circuit to do that.
Once you have checked the transmitter battery get back to us with results.
Good luck.
Crashj007 is offline Find More Posts by Crashj007
Reply With Quote
Old Apr 25, 2012, 11:48 AM
Registered User
Joined Apr 2012
4 Posts
Fixed!

The problem was stupid. When removing the condenser, cut a copper track (12V), and there was never voltage to the voltage divider, which is between the resistance of 5.1K and 2.7. Therefore the micro, had not as knowing the battery voltage.

Thanks a lot
Mc.Daniel is offline Find More Posts by Mc.Daniel
Reply With Quote
Old Apr 25, 2012, 12:03 PM
Registered User
Crashj007's Avatar
United States, NC, Raleigh
Joined Oct 2011
193 Posts
As I pointed out elsewhere, the best solution to the battery change is to use two LiPoFe as described here:
http://www.rcmodelreviews.com/tendollarbattery.shtml
Just buy them somewhere else.
Glad you fixed it.
Crashj007 is offline Find More Posts by Crashj007
Reply With Quote
Old Nov 17, 2012, 09:32 AM
Registered User
asaak's Avatar
Joined Mar 2012
146 Posts
HI!

same happened to me! Where is this " Repair post Mc.Daniel refers to?? I want to try to fix mine!

Thanks!
asaak is offline Find More Posts by asaak
Reply With Quote
Old Nov 19, 2012, 06:58 AM
Registered User
Joined Apr 2012
4 Posts
Hi,


Quote:
Originally Posted by asaak View Post
HI!

same happened to me! Where is this " Repair post Mc.Daniel refers to?? I want to try to fix mine!

Thanks!
Hi, the schematic refer to de voltage divisor. the radio take a reference voltage, and then, calculate the voltage show en screen..

In my case, when i was change the component burns, cut a copper track (12V), and there was never voltage to the voltage divider, which is between the resistance of 5.1K and 2.7. Therefore the micro, had not as knowing the battery voltage.


Check if all tracks are ok.

Regards
Mc.Daniel is offline Find More Posts by Mc.Daniel
Reply With Quote
Old Nov 19, 2012, 07:26 AM
B12
Registered User
Finland
Joined Sep 2010
583 Posts
Quote:
Originally Posted by Mc.Daniel View Post

I have a radio Flysky 9x (TURNIGY 9x). connect the lipo in reverse, and burn the radio,
It is a wide spread problem with these radios that diy folks reverse the diy lipos.

The reason is the flysky has the same connector as JST 2s balance lead. Flysky has positive on center pin and negative on both sides.

If you just buy a pre-wired jst connector and solder the red wire to red on battery and black to black, you will fry the radio as has happened to too many people.

http://www.hobbyking.com/hobbyking/s...5pcs_bag_.html
B12 is offline Find More Posts by B12
Reply With Quote
Old Nov 19, 2012, 04:36 PM
Registered User
asaak's Avatar
Joined Mar 2012
146 Posts
Hi guys!

I am trying to know what components have been damaged, because so far I can not identify them just looking at the components ( there is no one blown, or fried, just bad smell ).

I am testing with a voltimeter and I don't have 5v nor 12V on either of the VR. What are the parts I have to check to know the first component that is not working? I check the point on the image on the very beggining of the post and I don't get the voltages shown. Any ideas?
asaak is offline Find More Posts by asaak
Reply With Quote
Old Oct 18, 2013, 06:07 AM
Registered User
Joined Sep 2013
5 Posts
Any update???

I have smoked mine...
saintofinternet is offline Find More Posts by saintofinternet
Reply With Quote
Old Oct 19, 2013, 03:04 AM
Rusty
Rusty Nail's Avatar
Auckland, New Zealand
Joined Feb 2006
884 Posts
Links (found in under a minute using a thing called google):
Repairing a Turnigy 9X after battery reversal (14 min 5 sec)

http://openrcforums.com/wiki/index.p...ty_Brick_-_Fix
Rusty Nail is offline Find More Posts by Rusty Nail
Reply With Quote
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Question Where to buy the Turnigy 9x/flysky 9ch radio ChiWiAzPilot Radios 89 Dec 19, 2012 03:48 PM
Cool 3D FPV now see on screen without Glasses Rc Heli Halle Multirotor Talk 5 Apr 04, 2012 03:11 PM
Sold FlySky 9x TH9X radio w/ FrSky Telemetry Module and 2s 1300 battery. NEW! JIMinKENTUCKY Aircraft - General - Radio Equipment (FS/W) 1 Feb 25, 2012 06:08 PM
Discussion FlySky/iMax/Turnigy 9x/Eurgle 9CH radio malfunction TheButcher Radios 3 Jan 18, 2012 10:20 AM
Discussion The FlySky/iMax/Turnigy 9x/Eurgle 9CH radio how many out there? Bill Smudge Radios 3 Nov 13, 2011 12:39 PM