HobbyKing.com New Products Flash Sale
Reply
Thread Tools
Old Apr 15, 2012, 03:26 PM
Registered User
Joined Apr 2011
186 Posts
Discussion
4.0 update problem

I have been trying to update to 4.0 ever since the firmware was rereleased.
I install 4.0 on both HFP(black board) and GPS. Recalibrate Temp, ACC, and Compas. Recalibrate throttle range. Lower Gain to 40% Read to Fly.

I try and take off and it looks good at first but there is no rudder. The quad just starts to flat spin to the right. I try to trim but no luck. Rudde has no athority.I can reinstall 3.00 and the quad flies great (all trims @ zero) This is the 3rd time I have reflashed to 4.0 with the same strange results. What could I be missing.

next level quad frame
cobra 2826\12
turnigy 60 amp
hfp black board
hf gps
4s 4000 lipo



cheers
Huck
Huck Norris is offline Find More Posts by Huck Norris
Last edited by Huck Norris; Apr 15, 2012 at 03:36 PM.
Reply With Quote
Sign up now
to remove ads between posts
Old Apr 15, 2012, 03:30 PM
Registered User
Joined Apr 2011
186 Posts
flight log here
Huck Norris is offline Find More Posts by Huck Norris
Reply With Quote
Old Apr 15, 2012, 04:58 PM
JZSlenker's Avatar
United States, PA, Harrisburg
Joined Aug 2011
377 Posts
Did you uninstall both the firmware and setup clients from your computer? You need to download the newer versions of the software (both). Then update your firmware and pick your configuration type in the setup client. Then do your calibrations. You will need to adjust all of your gains again for version 4.
JZSlenker is offline Find More Posts by JZSlenker
Reply With Quote
Old Apr 15, 2012, 08:48 PM
S11D336B's Avatar
USA, FL, Winter Springs
Joined Apr 2006
3,066 Posts
Firstly, make sure your rudder channel is working in the setup client.

If it is then it could be an issue with your setup running out of yaw authority. Essentially the newer firmware handles yaw limiting better which is important if you don't want to flip. To fix this, you need to rotate your motors the opposite direction of the spin you are seeing.



Quote:
Originally Posted by Huck Norris View Post
I have been trying to update to 4.0 ever since the firmware was rereleased.
I install 4.0 on both HFP(black board) and GPS. Recalibrate Temp, ACC, and Compas. Recalibrate throttle range. Lower Gain to 40% Read to Fly.

I try and take off and it looks good at first but there is no rudder. The quad just starts to flat spin to the right. I try to trim but no luck. Rudde has no athority.I can reinstall 3.00 and the quad flies great (all trims @ zero) This is the 3rd time I have reflashed to 4.0 with the same strange results. What could I be missing.

next level quad frame
cobra 2826\12
turnigy 60 amp
hfp black board
hf gps
4s 4000 lipo



cheers
Huck
S11D336B is offline Find More Posts by S11D336B
Site Sponsor
Reply With Quote
Old Apr 15, 2012, 09:24 PM
Registered User
Joined Apr 2011
186 Posts
I think I found my problem.

I was caliberating the ACC, TEMP and Compas BEFORE I had chosen my motor layout.

I suppose a flying machine does not like that.

Thanks for the time
Going to the test field tomorrow AM.


cheers
Mike Hagadorn
Huck
Huck Norris is offline Find More Posts by Huck Norris
Reply With Quote
Old Apr 15, 2012, 10:38 PM
manual flying apologist
Adidas4275's Avatar
United States, CA, Fresno
Joined Mar 2011
6,944 Posts
good find! I am sure you are not the only one that it has happened to.

I got some good use out of your MKTR today Huck!

Ill post the video soon.... still editing
Adidas4275 is offline Find More Posts by Adidas4275
Reply With Quote
Old Apr 16, 2012, 03:50 AM
Registered User
Joined Feb 2006
726 Posts
Quote:
Originally Posted by Huck Norris View Post
I think I found my problem.

I was caliberating the ACC, TEMP and Compas BEFORE I had chosen my motor layout.

I suppose a flying machine does not like that.

Thanks for the time
Going to the test field tomorrow AM.


cheers
Mike Hagadorn
Huck
That was the only change you did and now itīs working? it has not much sense the calibration is related to the flying configuration you choose. In any way will do it like you not to get any risk but could be fine to know from HF if it has any relation or not.
elossam is offline Find More Posts by elossam
Reply With Quote
Old Apr 16, 2012, 10:52 AM
USA, CA, Mountain View
Joined Dec 2008
612 Posts
Quote:
Originally Posted by Huck Norris View Post
I think I found my problem.

I was caliberating the ACC, TEMP and Compas BEFORE I had chosen my motor layout.

I suppose a flying machine does not like that.

Thanks for the time
Going to the test field tomorrow AM.


cheers
Mike Hagadorn
Mike, Check your esc's carefully. Sometimes the solder pads leading to the motors start to detach partially. Hard to see or find and only intermittently causes the yaw problem. For some reason it exhibits on the newer firmware more readily. I finally replaced all esc's as a desperation move and that's when I found the loose solder pad. HF could chime in here but I don't think calibrating before you set config would make a difference.
Earl E Adobtr is offline Find More Posts by Earl E Adobtr
RCG Plus Member
Latest blog entry: Current Folding Quad Project
Reply With Quote
Old Apr 16, 2012, 05:47 PM
Registered User
Joined Apr 2011
186 Posts
Update.... Problem is not resolved. Tried to fly today Too windy out side so the parking garage would be great to set my AL trims. Started flying at 25 gain and was flying smooth. I upped the gain a bit to about 40 still smooth. Throttle seems a bit more sensitive with 4.0 for me. I was flying about 1-2 minutes and all the sudden I lose yaw control and the quad starts spinning to the right again. I land drop gain back to 25 take off and I regain yaw for a brief period then lose it again. I change batteries for a new lipo try to take off and no rudder control at all quad spinning to the right. Remember this is a quad that has over 50 flights on it and flies great with the previous 3.6 firmware.

I am using Turnigy Plush ESC and all the brains are covered by heat shrink.

thanks
Mike
Huck Norris is offline Find More Posts by Huck Norris
Reply With Quote
Old Apr 16, 2012, 08:21 PM
aka Helidaho
AeroVideoUS's Avatar
United States, ID, Boise
Joined Jun 2010
2,678 Posts
Dang, we need to get your issue fixed so we can get some more awesome videos! Although, I don't have any ideas, sorry...

Paul
AeroVideoUS is offline Find More Posts by AeroVideoUS
Reply With Quote
Old Apr 17, 2012, 02:38 AM
S11D336B's Avatar
USA, FL, Winter Springs
Joined Apr 2006
3,066 Posts
Mike,
You need to to do a few things.

1. Move your throttle trim all the way down.
2. Set your throttle endpoints to +-100%
3. Re-calibrate your ESCs manually using the RX.
4. Fly

If you are still having trouble with yaw, rotate your motors in the opposite direction the multirotor spins when this happens.

This information is here:
https://hoverflytech.zendesk.com/ent...ng-yaw-control

Quote:
Originally Posted by Huck Norris View Post
Update.... Problem is not resolved. Tried to fly today Too windy out side so the parking garage would be great to set my AL trims. Started flying at 25 gain and was flying smooth. I upped the gain a bit to about 40 still smooth. Throttle seems a bit more sensitive with 4.0 for me. I was flying about 1-2 minutes and all the sudden I lose yaw control and the quad starts spinning to the right again. I land drop gain back to 25 take off and I regain yaw for a brief period then lose it again. I change batteries for a new lipo try to take off and no rudder control at all quad spinning to the right. Remember this is a quad that has over 50 flights on it and flies great with the previous 3.6 firmware.

I am using Turnigy Plush ESC and all the brains are covered by heat shrink.

thanks
Mike
S11D336B is offline Find More Posts by S11D336B
Site Sponsor
Reply With Quote
Old Apr 17, 2012, 12:11 PM
manual flying apologist
Adidas4275's Avatar
United States, CA, Fresno
Joined Mar 2011
6,944 Posts
George, if we are using square booms and not round booms do you have a suggestion on how to rotate them?

I do not currently have this issue, but it has been something that I have not had to deal with when using Rusty's frame with round 5/8" booms.

Thanks
Adidas4275 is offline Find More Posts by Adidas4275
Reply With Quote
Old Apr 17, 2012, 01:46 PM
Registered User
Joined Apr 2011
186 Posts
yeah I am rocking square booms on my quad. I guess you would go with chims.
Huck Norris is offline Find More Posts by Huck Norris
Last edited by Huck Norris; Apr 17, 2012 at 02:14 PM.
Reply With Quote
Old Apr 17, 2012, 06:35 PM
Sokratis
canopus1970's Avatar
Ελλάς, Κρήτη, Ηράκλειο
Joined May 2009
51 Posts
Quote:
Originally Posted by Adidas4275 View Post
George, if we are using square booms and not round booms do you have a suggestion on how to rotate them?

I do not currently have this issue, but it has been something that I have not had to deal with when using Rusty's frame with round 5/8" booms.

Thanks
This is that you need ...
https://www.mikrocontroller.com/inde...108c0c5c869ef0
canopus1970 is offline Find More Posts by canopus1970
Reply With Quote
Old Apr 17, 2012, 09:17 PM
manual flying apologist
Adidas4275's Avatar
United States, CA, Fresno
Joined Mar 2011
6,944 Posts
i have seen those before.... i think I would need to make something. I use RC-Carbon frame which I dont think i could use those sims like they are. Good idea, perhaps I will do some more looking at shimming my motors.
Adidas4275 is offline Find More Posts by Adidas4275
Reply With Quote
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Discussion OPTIC 6 SPORT 2.4 - Firmware update V1.02(0) A.T. Hitec/Multiplex USA 4 Apr 11, 2012 07:24 PM
Discussion Problems with Futaba T8FG and 4.0 Jeos72 Hoverfly Technologies 3 Apr 11, 2012 03:36 PM
Alert OPTIC 6 SPORT 2.4 - Firmware update V1.02(0) A.T. Radios 0 Mar 05, 2012 02:58 AM
Discussion Pheonix Simulator update 4.0.F Problem Cfly100 Simulators 2 Feb 29, 2012 04:41 PM