HobbyKing.com New Products Flash Sale
Reply
Thread Tools
Old Apr 07, 2012, 12:14 PM
Registered User
rpm3's Avatar
Pleasanton, California
Joined Nov 2000
709 Posts
Discussion
Hitec X4 Plus AC/DC

I have just started using this charger....just getting the programming where i understand it...which is a totally another subject...soooooooo

I have only charged different packs 3 times...separately....the cooling fan has NOT come on...other chargers I have are ON when you start the charge...does this charger have a heat sensor for turning on/off the fan?

thanks
Ralph Matile
rpm3 is offline Find More Posts by rpm3
Reply With Quote
Sign up now
to remove ads between posts
Old Apr 07, 2012, 12:32 PM
Snappy Title On Backorder....
tsymonds's Avatar
United States, TX, Killeen
Joined Jun 2011
1,033 Posts
The short answer is yes. You can see the internal temp of the charger by pressing the down arrow while charging. It'll cycle through several settings and parameters one of which is internal and external temp. Internal will always show current temp but external requires the thermocouple attachment. The fan generally won't come on until it's either already warm (using it outdoors for instance) or you have a pretty heavy charge load on it.
tsymonds is online now Find More Posts by tsymonds
Reply With Quote
Old Apr 07, 2012, 01:32 PM
Registered User
rpm3's Avatar
Pleasanton, California
Joined Nov 2000
709 Posts
Thanks Tsymonds!

...and while I'm at it....
I have some batteries...couple years old.....
BUT
They are 3s, but the balancing plug on them is a 4S....I have several like this...and i can look, but I don't believe they are from "no name" manufacturers..I think one is a polyquest in fact...

My first go around with one of those batteries with a 4S balance plug and this Hitec X4 AC is as I suspected...not working....soooo..
Anyone else run into this?....or an easy work around?

thanks
Ralph Matile
rpm3 is offline Find More Posts by rpm3
Last edited by rpm3; Apr 07, 2012 at 01:41 PM.
Reply With Quote
Old Apr 07, 2012, 01:51 PM
Registered User
rpm3's Avatar
Pleasanton, California
Joined Nov 2000
709 Posts
ok....strike the last post...it is the Thunder Power pack that has a connector that doesn't seem to work...I need to look a bit more....got some chores to do first!
rpm3 is offline Find More Posts by rpm3
Reply With Quote
Old Apr 07, 2012, 06:11 PM
Snappy Title On Backorder....
tsymonds's Avatar
United States, TX, Killeen
Joined Jun 2011
1,033 Posts
There's always one wire than than cell count.
tsymonds is online now Find More Posts by tsymonds
Reply With Quote
Old Apr 11, 2012, 04:53 PM
Registered User
rpm3's Avatar
Pleasanton, California
Joined Nov 2000
709 Posts
OK..charged a few packs...just one at a time....things seem just great...
The instructions...well...maybe I'm not of "at least average intelligence" like i have stated soooo many times.....

Thankfully some help from the "rc group" got me thru the setup...its still not an "automatic" event when i go to charge...but with some practice it will be.

I do like the charger so far......I'm sure there are things I'd like to see improved, but for the packs I use...it is a great charging solution....

So, at the very beginning of using this..HIGH marks so far....as time goes on...we'll see!
rpm3 is offline Find More Posts by rpm3
Reply With Quote
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Discussion Hitec X4 AC Plus AC/DC Four-Channel Multi-Charger rpm3 Batteries and Chargers 159 Jun 29, 2014 01:05 PM
Help! Need Help programming Hitec X4 AC/DC charger scphoto Batteries and Chargers 4 Apr 13, 2012 11:03 PM
Sold Hitec X4 AC Plus mayhemx007 Aircraft - Electric - Batteries & Chargers (FS/W) 2 Feb 14, 2012 01:25 AM
Discussion Q6 AC/DC vs Hitec X4 Plus AC/DC rpm3 Batteries and Chargers 0 Jan 21, 2012 10:33 AM
New Product BRAND NEW! Hitec X4 AC Plus Charger - in stock at ServoCity! ServoCity ServoCity.com 0 Oct 19, 2011 08:48 AM