HobbyKing.com New Products Flash Sale
Reply
Thread Tools
Old Apr 03, 2012, 10:44 PM
Registered User
United States, KY, West Liberty
Joined Nov 2010
30 Posts
Discussion
Blade 400 problems

Crashed my Blade 400 yesterday. No big deal. needed a new feathering shaft, so while i had it apart, I replaced the main hub and blade grips with microheli parts. Finally got them to fit right with a few shims.
So with i cranked it up, the blades went to negitive pitch, and the swash plate went down when is should have gone up.Yeah, holding it in my hand and it got heavier, lol
Checked my tx with another Helicopter and it worked fine. DX6I)
Then i tried hooking my battery up again and nothing would happened. Tried this several times and it would not bind up to the tx. I also noticed that there was a relative large spark each time I hooked up the battery to the helicopter.
Any ideas what might have happened? No, I didnt remove any electrical connections
And so perhaps my reciever is shot or maybe my ESC.
If my reciever is shot, what would be the reccomded reciever to put back in my Blade 400?
Help please
Dave
drsquat is offline Find More Posts by drsquat
Last edited by drsquat; Apr 03, 2012 at 10:47 PM. Reason: add info
Reply With Quote
Sign up now
to remove ads between posts
Old Apr 03, 2012, 11:12 PM
WOS
Registered User
United States, IN, Michigan City
Joined Nov 2003
808 Posts
I would think if the polarity was reversed it would of burnt really quick. Swash plate going the wrong direction? when nothing was changed? My guess would soemthing was defintaly changed. Blade pitch might of installing the grips the wrong direction. but swashplate going wrong direction sounds like a polarity issue but dont think the esc would like it very much
WOS is offline Find More Posts by WOS
Reply With Quote
Old Apr 04, 2012, 08:12 AM
Closed Account
Joined Dec 2007
6,549 Posts
Quote:
Originally Posted by drsquat View Post
Crashed my Blade 400 yesterday. No big deal. needed a new feathering shaft, so while i had it apart, I replaced the main hub and blade grips with microheli parts. Finally got them to fit right with a few shims.
So with i cranked it up, the blades went to negitive pitch, and the swash plate went down when is should have gone up.Yeah, holding it in my hand and it got heavier, lol
Checked my tx with another Helicopter and it worked fine. DX6I)
Then i tried hooking my battery up again and nothing would happened. Tried this several times and it would not bind up to the tx. I also noticed that there was a relative large spark each time I hooked up the battery to the helicopter.
Any ideas what might have happened? No, I didnt remove any electrical connections
And so perhaps my reciever is shot or maybe my ESC.
If my reciever is shot, what would be the reccomded reciever to put back in my Blade 400?
Help please
Dave
Can't help you with the electrical issue, but it sounds like you installed your new grips "flipped" which will reverse your pitch. Is the link from the swash to the blade grips controlling the leading edge of the blade or the trailing edge on your re build?
Xrayted is offline Find More Posts by Xrayted
Reply With Quote
Old Apr 04, 2012, 09:10 PM
Registered User
United States, KY, West Liberty
Joined Nov 2010
30 Posts
yep, I messed up

Yep problem solved. DUHHH. I am such an idiot. After taking everything apart, again and again, yea i found the blade grips were backwards. As far as the elecrical problem, I just did the bind process again and all is well. The arcing? Well i dont know but the chopper seems to be doing ok now

Thank you
Dave
drsquat is offline Find More Posts by drsquat
Reply With Quote
Old Apr 04, 2012, 09:57 PM
WOS
Registered User
United States, IN, Michigan City
Joined Nov 2003
808 Posts
I know when I connect the battery it always arcs a little. Only way to cure this problem is to connect an inline switch so no power is at the battery terminals when you plug it in. then just turn the switch on
WOS is offline Find More Posts by WOS
Reply With Quote
Old Apr 05, 2012, 12:38 AM
Registered User
United Kingdom, England, Witham
Joined Feb 2011
899 Posts
Have a look here
http://www.rcgroups.com/forums/showthread.php?t=983802

Its meant for bigger birds with higher cell counts but it gives you an idea of what the spark is and what you can do to stop it

I didn't know about this when I started building My HK500 on 6S so the spark and accompanying crack made me think there was a short somewhere lol
Essex2visuvesi is offline Find More Posts by Essex2visuvesi
Reply With Quote
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
For Sale BNF Blade 400 (needs blade holder) trade!! N4682H Aircraft - Fuel - Helis (FS/W) 2 Mar 21, 2012 11:09 AM
Discussion Blade 400 gyro problem feefo Mini Helis 2 Jan 14, 2012 02:03 PM
Discussion can anyone help with a servo problem blade 400? jet fellar Mini Helis 2 May 17, 2008 10:38 PM
Discussion blade 400 problem still isnt fixed imapimp Mini Helis 1 May 03, 2008 10:14 PM
Help! blade 400 problem imapimp Mini Helis 17 May 03, 2008 06:15 PM