HobbyKing.com New Products Flash Sale
Reply
Thread Tools
Old Apr 02, 2012, 04:24 PM
Registered User
Joined Apr 2011
41 Posts
Discussion
PowerLab 8 won't auto discharge after charge (won't cycle)

Hi,

I have set up what I thought would be an automatic cycle of charge to 3.8V then discharge to 2.6V for my Thundersky LFP160AHA cells. It charges fine but then just sits there interminably until I stop the charger and initiate a discharge only, which it also does fine and stops when it gets to 2.6V. Below are screen grabs at the end of the charge phase. Can someone tell me why the PL8 won't automatically flip from charge to discharge when the 3.8V charge cutoff is reached? It's obviously something minor I have missed. I am using a modified copy of the Library 3 preset (Generic High Power) to allow charge and discharge at 20A.

Thanks, MW.
martinwinlow is offline Find More Posts by martinwinlow
Reply With Quote
Sign up now
to remove ads between posts
Old Apr 03, 2012, 01:00 PM
AR-15 BRD!
Howard Matos's Avatar
Frederick, MD
Joined May 2002
1,040 Posts
Quote:
Originally Posted by martinwinlow View Post
Hi,

I have set up what I thought would be an automatic cycle of charge to 3.8V then discharge to 2.6V for my Thundersky LFP160AHA cells. It charges fine but then just sits there interminably until I stop the charger and initiate a discharge only, which it also does fine and stops when it gets to 2.6V. Below are screen grabs at the end of the charge phase. Can someone tell me why the PL8 won't automatically flip from charge to discharge when the 3.8V charge cutoff is reached? It's obviously something minor I have missed. I am using a modified copy of the Library 3 preset (Generic High Power) to allow charge and discharge at 20A.

Thanks, MW.
Hi,

Can you email me a copy of the preset you are using? You can send it to howard@fmadirect.com. I will let you know what I find, thanks.
Howard Matos is offline Find More Posts by Howard Matos
Reply With Quote
Old Apr 03, 2012, 02:06 PM
Registered User
ggcrandall1's Avatar
USA, GA, Marietta
Joined Aug 2005
5,557 Posts
Martin,

There is a parameter to set the delay (for cooling) between charge and discharge. Have you checked that to see if it is set too high?

Glen
ggcrandall1 is online now Find More Posts by ggcrandall1
Reply With Quote
Old Apr 04, 2012, 09:12 PM
Registered User
SteveM732's Avatar
United States, OR, Beaverton
Joined Feb 2008
1,976 Posts
Have you set it to do more than one cycle?
SteveM732 is offline Find More Posts by SteveM732
Reply With Quote
Old Apr 05, 2012, 03:22 AM
Registered User
Joined Apr 2011
41 Posts
Quote:
Originally Posted by ggcrandall1 View Post
Martin,

There is a parameter to set the delay (for cooling) between charge and discharge. Have you checked that to see if it is set too high?

Glen
Hi - It is set to 30 mins and from the graph you can see the voltage is held at 3.8V for a lot longer... MW
martinwinlow is offline Find More Posts by martinwinlow
Reply With Quote
Old Apr 05, 2012, 03:23 AM
Registered User
Joined Apr 2011
41 Posts
Quote:
Originally Posted by SteveM732 View Post
Have you set it to do more than one cycle?
No, as I understand it, one cycle is one charge and then one discharge - the preset is configured to end on a discharge. MW
martinwinlow is offline Find More Posts by martinwinlow
Last edited by martinwinlow; Apr 06, 2012 at 05:57 AM.
Reply With Quote
Old Apr 08, 2012, 05:26 AM
Registered User
Joined Apr 2011
41 Posts
Appears to be working now! I don't think I changed anything....?
martinwinlow is offline Find More Posts by martinwinlow
Reply With Quote
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Discussion Walkera CB180D won't fly after changing rotor blades steveap1 Beginner Training Area (Heli-Electric) 3 Mar 27, 2012 10:01 AM
Discussion powerlab 8 charging questions ndamico FMA Direct 2 Mar 06, 2012 11:05 PM
Question Gee Bee won't charge Skrogg Scratchbuilt Indoor and Micro Models 9 Feb 23, 2012 05:27 PM
Discussion Green CHARGE not working - Copter won't take charge BigKid_Champ Coaxial Helicopters 1 Jan 30, 2012 01:04 PM
Discussion Powerlab 8 regenerative discharge question? Eddie500 FMA Direct 11 Nov 09, 2011 03:05 PM