HobbyKing.com New Products Flash Sale
Reply
Thread Tools
Old Mar 28, 2012, 06:03 AM
Registered User
Joined Mar 2012
27 Posts
Discussion
Problem with new Bixler

Hi Guys,

I've got my new bixler and had a crash on the first flight Broke the prob and minor damage else where- it's all repaired new prop etc.

When I power it up now all the flying controls work in the correct way- I power up the throttle and the motor reaches full power then slowly reduces to a stop by its self....

I've tried a few fully charged batteries and checked all the connections.

Any other tips??

Thanks a million!
MadridFlyer is offline Find More Posts by MadridFlyer
Reply With Quote
Sign up now
to remove ads between posts
Old Mar 28, 2012, 07:24 AM
Registered User
United States, NC, Holly Springs
Joined Dec 2010
104 Posts
One thought would be to check all soldered connections. I had this happen on a ground vehicle where one of the wires came loose from the ESC. The truck would work for maybe a minute or two and then shut down. I soldered the wire back to the ESC and all is well.
swimman is offline Find More Posts by swimman
Reply With Quote
Old Mar 28, 2012, 08:24 PM
Registered User
United States, NJ, Frenchtown
Joined Mar 2003
9,031 Posts
If you can measure the battery voltage while running down ?

You should have a ESC battery lead problem. They run down smoothly.
A bad solder joint in any of the motor leads is usually a scheeching or juddering motor. Not a smooth slow down.

Swap ESCs. Then a motor with the original stuff.
cyclops2 is offline Find More Posts by cyclops2
Reply With Quote
Old Mar 29, 2012, 11:25 PM
United States, CA, Santa Rosa
Joined Mar 2011
877 Posts
Make sure you didn't damage your battery in the crash. Have you tried different batts?
asosestrom is offline Find More Posts by asosestrom
Reply With Quote
Old Mar 30, 2012, 03:35 PM
Registered User
Joined Mar 2012
27 Posts
Hi,

I must have damaged the esc- i've tried everything else!

Cheers.
MadridFlyer is offline Find More Posts by MadridFlyer
Reply With Quote
Old Mar 30, 2012, 06:09 PM
Build to Fly? FLY to BUILD!
Legot's Avatar
United States, AZ, Gilbert
Joined Nov 2009
1,104 Posts
Quote:
Originally Posted by MadridFlyer View Post
Hi,

I must have damaged the esc- i've tried everything else!

Cheers.
It's very unlikely that the ESC itself is damaged from the crash. If you have a different battery, try the one that didn't crash. It is more likely that the battery was punctured and looses it's charge quickly, in which case you might smell a mildly sweet smell from the battery.

Inspect it well and report back please, good luck.
Legot is offline Find More Posts by Legot
Reply With Quote
Old Mar 31, 2012, 06:36 PM
Registered User
Joined Mar 2012
27 Posts
Thanks- It seems my battery charger for whatever reason wasn't charging my batteries fully.

I've now ordered a new one!
MadridFlyer is offline Find More Posts by MadridFlyer
Reply With Quote
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Question Weird problem with New Y-6... Throttle works, but not Pitch Roll or Yaw Adidas4275 Hoverfly Technologies 4 Apr 02, 2012 11:21 AM
Discussion new bixler lipy Electric Plane Talk 4 Sep 04, 2011 06:23 AM