Espritmodel.com Telemetry Radio
Reply
Thread Tools
Old Mar 27, 2012, 11:02 PM
manual flying apologist
Adidas4275's Avatar
United States, CA, Fresno
Joined Mar 2011
6,944 Posts
Question
Weird problem with New Y-6... Throttle works, but not Pitch Roll or Yaw

I have 2 HFpro boards. One working in a Y-6 and one in a new build.


In my new build I have a problem and I need a fresh set of eye (so to speak)

Here is the problem:

Everything works fine...... the setup client shows all channels from the RX working and setup correctly. The flight controller blinks green when powered. I can arm the flight controller. The throttle channel responds perfect, but the Elevator and Aileron inputs do NOTHING! None of the motors speed up or slow down. I even tried it with props on and it bolted to my bench.

So the throttle works perfect, but I get 0 ability to control the Y-6 with Pitch, Yaw or Roll. Even though the setup client shows that the Flight Controller is getting the signal from Pitch, Yaw and Roll via the RX.


My setup:
SunnySky 2814 700kv
Hobbywing 30a ESC
Spektrum AR8000
Spektrum TM1000
HoverFly Pro
4s5000 mah flight battery
3s500 mah battery for the FC and RX
CC BEC @5v for RX
I have singal pin only from the RX to the HFpro board
I have all but 1 red pin removed from the ESCs to the HFpro board.



What I have tried:

I tried connecting a ground and 12v wire from the HFpro to the RX and disconnected the CC BEC from the RX = No change

I tried changing my ESC timings from High to Low = no change

I tried swapping HFpro boards (one from my working Y-6) = no change


What I need:

some ideas of what to try....... I am at a loss, my other Y-6 is setup very similarly with a BEC powering the RX and no 12v from the HFpro to RX with AR8000 and TM1000 running with a 3s and 4s battery config....



It is really strange to me that the setup config would see Pitch, Roll and Yaw, the Controller will arm (Yaw input) I get throttle respose (motors spin up) but I cannot get Pitch, Yaw or Roll control...

The Setup config shows Auto Level, Alt Hold, Position Hold and RTH all off.... but I cannot get the light to change from Green to Purple when I turn Auto Level on with throttle above 50%.



Any help would be appreciated.
Adidas4275 is offline Find More Posts by Adidas4275
Reply With Quote
Sign up now
to remove ads between posts
Old Mar 28, 2012, 10:29 AM
manual flying apologist
Adidas4275's Avatar
United States, CA, Fresno
Joined Mar 2011
6,944 Posts
when swapping out Rxs and other components I noticed that after I bumped or moved the multicopter when armed it would then respond to stick inputs. However they seemed delayed and sluggish.....

I have come to the thought that perhaps this is normal behavior for the HFpro board?


When i was flying mutliwii boards I could hold my quad above my head and push the stick around and feel the motors change RPMs.

Is it possible that the HFpro boards do not work the same and only will change motor RPM after it knows that it is off the ground (after acclerometers feel motion) ?


I am tempted to put the props back on and try and fly over long grass just in case I dont have control....


this all seems strange to me, but I will make sure and document what I find for future trouble shooting.
Adidas4275 is offline Find More Posts by Adidas4275
Reply With Quote
Old Mar 28, 2012, 10:34 AM
Air Traffic Controller
United States, TN, Knoxville
Joined Aug 2011
250 Posts
The HFP senses when the craft is flyng. If it doesn't detect flight, I'm thinking the sticks wouldn't affect the motors for pitch, yaw and roll. Throttles have to work to get it airborne.
Webheadfred is offline Find More Posts by Webheadfred
Reply With Quote
Old Mar 28, 2012, 11:06 AM
manual flying apologist
Adidas4275's Avatar
United States, CA, Fresno
Joined Mar 2011
6,944 Posts
okay, so..... i have been toiling away for no reason.


My other FC that I have had you can bench test them and the pitch, roll and yaw will change motor RPMs with the throttle up.... i guess with my other HFpro Y-6 I never tried to bench test it.


okay, well that means today I should get it in the air.....
-------------------------------------------------------------------------------------

Okay, got it in the air, a little twitchy... perhaps vibrations getting to the FC, running small props and have not balanced them at all.... time to balance my 11x4.5s and 12x3.8s to see which net me more flight time.

Thanks for the help!
Adidas4275 is offline Find More Posts by Adidas4275
Last edited by Adidas4275; Mar 28, 2012 at 08:56 PM. Reason: Update
Reply With Quote
Old Apr 02, 2012, 11:21 AM
multi rotors,foamies,car lover
windfou's Avatar
Joined Dec 2008
1,443 Posts
Quote:
Originally Posted by adidas4275 View Post
okay, so..... I have been toiling away for no reason.


My other fc that i have had you can bench test them and the pitch, roll and yaw will change motor rpms with the throttle up.... I guess with my other hfpro y-6 i never tried to bench test it.


Okay, well that means today i should get it in the air.....
-------------------------------------------------------------------------------------

okay, got it in the air, a little twitchy... Perhaps vibrations getting to the fc, running small props and have not balanced them at all.... Time to balance my 11x4.5s and 12x3.8s to see which net me more flight time.

Thanks for the help!
:d:d:d
windfou is offline Find More Posts by windfou
Last edited by windfou; Apr 03, 2012 at 12:54 AM.
Reply With Quote
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Help! Servos work with Servo tester but not with Receiver?? mejmea Power Systems 0 Mar 18, 2012 12:18 PM
Discussion Yaw and Throttle issue with my Y-6 Adidas4275 Hoverfly Technologies 7 Jan 03, 2012 06:44 PM
Discussion Should a glider be able to roll axially? Yaw and pitch purely? Fly2High Hand Launch 40 Oct 28, 2011 06:25 AM
Discussion Spektrum TM1000 Y-harness not working with Voltage sensor coldboot Radios 5 Sep 20, 2011 07:05 PM