HobbyKing.com New Products Flash Sale
Reply
Thread Tools
Old Mar 21, 2012, 10:39 AM
Registered User
Joined Oct 2011
114 Posts
Discussion
Servo Glitching Corona 919mg digital servo

Hello Guys,
recently I used on my 450 clone the famous HTX900 servo's even on the tail ... Slow but useful at the beginning (it's like having expo :P ) ... I decided to change to a digital servo: the corona mg919 digital servo.
I know that's not really a good tail servo, but it its fast and even if it hasn't got an incredible torque it would suit me for now (not doing hard 3d).
The problem is that I used a servo tester to see if the corona and the htx900 servos worked good toghether,and suddenly all 3 of them started to make noise and glitching!!
I started reading about interference voltages, incompatibility between digital and analog servos, capacitors in the receiver ... And now I'm just confused
can anybody help me with this problem and sort my ideas about these issues?
mick3485 is offline Find More Posts by mick3485
Reply With Quote
Sign up now
to remove ads between posts
Old Mar 21, 2012, 10:40 AM
Registered User
Joined Oct 2011
114 Posts
Forgot to say that the servo tester was powerd by 6V AA batteries and if i put only the corona in the servo tester it glitches a bit. This thing is driving me nuts!! :P
mick3485 is offline Find More Posts by mick3485
Last edited by mick3485; Mar 21, 2012 at 10:49 AM.
Reply With Quote
Old Mar 21, 2012, 01:47 PM
"Unnecessary Necessity"
coriolan's Avatar
Canada, QC, Quebec City
Joined Sep 2006
5,823 Posts
Most digital servos tend to do that when not attached to a control as they try to neutralize their feed back with no load on the output. My first digital servos(also Corona) where doing the same until actually installed in a model. The slight drag from the linkage let them chose a position instead of hunting down an exact position and overshooting causing oscillations.
coriolan is online now Find More Posts by coriolan
Reply With Quote
Old Mar 21, 2012, 02:33 PM
Registered User
Athens
Joined Aug 2008
98 Posts
That jittering dosen't seem to be normal ,for every kind of servo ,analog or digital . First of all, are your servos rated for 6 volts power supply? I ask because your servo tester is power supplied by 6 volts battery. But it is the nominal voltage. Real value of voltage may exceed 6.4-6.5 volts and corona DS-919 MG dosen't seem to "like" more than 5.5 volts. Try them pluged in your receiver ,using 5 volts from BEC of your speed control.
bladeskiller is offline Find More Posts by bladeskiller
Reply With Quote
Old Mar 21, 2012, 04:04 PM
Registered User
Joined Oct 2011
114 Posts
thank's guys!!
all solved
glitching went away by using rx and esc bec!!
i god a 3300uf 16v capacitor in the spare of the rx to! you never know
mick3485 is offline Find More Posts by mick3485
Reply With Quote
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Sold HobbyKing 929BB, HobbyKing 929MG, & Corona Digital 929MG servos - NIB Garret H Aircraft - General - Radio Equipment (FS/W) 1 Jan 11, 2012 01:09 AM
Sold 4x Corona 919MG Metal Digital Servos JHawk19 Aircraft - General - Radio Equipment (FS/W) 3 Jan 01, 2012 04:05 PM
Discussion Corona Digital Servos from BP Hobbies Jimbo45cn Large Electric Helis 11 Nov 06, 2011 02:13 PM
For Sale 4 New Corona DS-928BB Digital Ball Bearing Servos Bud Morrison Aircraft - General - Radio Equipment (FS/W) 0 Oct 19, 2011 07:58 PM
Help! Corona Glitches parambir Radios 2 Oct 05, 2011 02:54 AM