HobbyKing.com New Products Flash Sale
Reply
Thread Tools
Old Oct 21, 2003, 01:22 AM
I told them, I was drunk.
temp_oct's Avatar
Bangkok, Thailand
Joined Aug 2003
484 Posts
Help!
What's WRONG with my new TX??????


My TX was about a month old. I've just tried the control throw of my spitfire. I add some down elevator trim, it was too much so I press the up trim.
?????
Nothing happens.
I press it again
!!!!!!!!!!!!!!!!!!!! OH NO!!!
The up trim is totally dead!!!!!!!
I tried to put some up trim to other model memory. No response .

I am so sad now since I had not been flying since Friday. I plan to fly tomorrow with my new mod on the spitfire.

Anybody has any idea on this?????? Am I mess up with some program??????? I am so sad now......

I think I wait several weeks for that
temp_oct is offline Find More Posts by temp_oct
Reply With Quote
Sign up now
to remove ads between posts
Old Oct 21, 2003, 01:24 AM
The One....
genovia's Avatar
San Jose, Ca.
Joined Jan 2002
5,813 Posts
Check your servo throw make sure that the arms are centered. BTW: What type of TX do you have?
genovia is offline Find More Posts by genovia
Reply With Quote
Old Oct 21, 2003, 01:28 AM
I told them, I was drunk.
temp_oct's Avatar
Bangkok, Thailand
Joined Aug 2003
484 Posts
JR 8103 airplane version.
It is not the servo, it is the TX
Usually it will display how much trim I have, but can adjust it only one way (down elevator only). All other digital trim (rudder and aileron) are fine
Any suggestion?
temp_oct is offline Find More Posts by temp_oct
Reply With Quote
Old Oct 21, 2003, 01:30 AM
The One....
genovia's Avatar
San Jose, Ca.
Joined Jan 2002
5,813 Posts
Have you tried it with other rx and servo to see if it works? If your Rudder and elev is fine. try the servo, just to make sure.
genovia is offline Find More Posts by genovia
Reply With Quote
Old Oct 21, 2003, 01:35 AM
I told them, I was drunk.
temp_oct's Avatar
Bangkok, Thailand
Joined Aug 2003
484 Posts
The trim on the display as well as the servo doesn't move
I tried swap the channels, the servo works fine.


WHERE IS THAT DARN RECEIPT???
temp_oct is offline Find More Posts by temp_oct
Reply With Quote
Old Oct 21, 2003, 01:39 AM
Profiled Interfractionalist
William A's Avatar
Tacoma,WA USA
Joined Jun 2001
4,024 Posts
Gotta be the switch contacts in the 'up' trim button then.
If it's a separate wired component, maybe a broken wire.
Pop the cover and take a look-see.
William A is offline Find More Posts by William A
Reply With Quote
Old Oct 21, 2003, 01:42 AM
I told them, I was drunk.
temp_oct's Avatar
Bangkok, Thailand
Joined Aug 2003
484 Posts
I agree but I don't have parts.
There is a separate PCB for each digital trim switch. The soldering seems to be fine. I didn't check the contact on the switch yet (I've just broke my fuse in the DMM yesterday. What a bad luck!)
temp_oct is offline Find More Posts by temp_oct
Reply With Quote
Old Oct 21, 2003, 03:23 AM
I told them, I was drunk.
temp_oct's Avatar
Bangkok, Thailand
Joined Aug 2003
484 Posts
PROBLEM FIXED:
Thank you everybody.
The up-elevator trim switch is OK, however, there is a piece of plastic that suppose to push the switch when I press up trim that is not doing its job. I tighten the screw and it is working fine
So, I will definately fly tomorrow
temp_oct is offline Find More Posts by temp_oct
Reply With Quote
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
What's wrong with my Tantrum landing gear? Parkflyer Parkflyers 10 Jul 10, 2003 01:15 AM
What's wrong with my turn signal flasher? Karl Bē Life, The Universe, and Politics 4 Apr 02, 2003 07:45 PM
What's wrong with my electronics? akh223 Parkflyers 6 Feb 19, 2003 01:27 AM
What's wrong with my NIMH battery? I FO nut Parkflyers 4 May 30, 2002 08:49 PM
What's wrong with my charger? tenover Power Systems 4 Apr 29, 2002 06:55 PM