HobbyKing.com New Products Flash Sale
Reply
Thread Tools
Old Mar 18, 2012, 07:58 AM
Registered User
massachusetts, usa
Joined Dec 2010
32 Posts
Help!
X4 charger USB adapter install trouble

hi all!
i now have a usb adapter for the hitec x4 charger. anybody using this? with the "chargemonitor" software?
i cant seem to get the adapter to install correctly on the pc, driver issue's.
after insalling "chargemonitor" software, the adapter doesnt show up on a com port, windows thinks its a memory stick and cant install any drivers for it...although ive seen it show up next the the yellow memory stick icon as the uart bridge controller, but sill with a yellow question mark.
im not sure what to do here/next...
it shows up in computer management under device manager as a yellow question mark, and "cp2102 usb to uart bridge controller"
also, windows now keeps asking to install a memory stick driver (which is not successful) even if i unplug all usb devises.
iv deleted the " chargemonitor" softwr, and the memory stick/uart drivers many times to try a diff. order of installation.
hitec doesnt have driver info on any of its manuals for this..

windows xp sp3(im not sure what other spec info would be helpful)

any ideas???
thanks guys!
bradp015 is offline Find More Posts by bradp015
Reply With Quote
Sign up now
to remove ads between posts
Old Mar 20, 2012, 01:06 AM
Inventor&Genius Extraordinary
tune by tito's Avatar
USA, CA, Riverside
Joined May 2006
491 Posts
Quote:
Originally Posted by bradp015 View Post
hi all!
i now have a usb adapter for the hitec x4 charger. anybody using this? with the "chargemonitor" software?
i cant seem to get the adapter to install correctly on the pc, driver issue's.
after insalling "chargemonitor" software, the adapter doesnt show up on a com port, windows thinks its a memory stick and cant install any drivers for it...although ive seen it show up next the the yellow memory stick icon as the uart bridge controller, but sill with a yellow question mark.
im not sure what to do here/next...
it shows up in computer management under device manager as a yellow question mark, and "cp2102 usb to uart bridge controller"
also, windows now keeps asking to install a memory stick driver (which is not successful) even if i unplug all usb devises.
iv deleted the " chargemonitor" softwr, and the memory stick/uart drivers many times to try a diff. order of installation.
hitec doesnt have driver info on any of its manuals for this..

windows xp sp3(im not sure what other spec info would be helpful)

any ideas???
thanks guys!
you need to remove the cp2102 usb to uart driver installed now from the device manager in window Xp in the computer, then disconnect the cp2102 usb to uart device from the computer after you do this. then go to Silicon Labs and download the cp210x drivers, Install the new drivers with out connecting the cp2102 device to the computer, after you install the new drivers connect the cp2102 device to the computer and check if the cp2102 load ok. Install the battery charger software from Hitec, turn you charge on, change the setting for the temp sensor to PC Link(check you charger manual(program flow chart)) you can only do this for the battery charger # 1 & 2 only. after this connect the cp2102 to the charger where the temp sensor is installed or connector. Check every thing is working fine.

problems you can encounter when installing the cp2102 software:
1- If you install the cp2102 device with out installing the driver software first the window xp software will install the driver is best to handling the communication protocol in this case the Communication Device Controller(CDC) drivers which is the standard for this devices however the cp21xx devices use a unique software driver from Silicon Labs because the cp21xx are a HID device and not a CDC device.
if you encounter this problem uninstall the cp2102 software drivers; disconnect the cp2102 device from the computer make sure no software for the cp2102 or Silicon labs software is installed in the computer.
reinstall the cp2102 software drivers with out connecting the cp2102 device to the computer. check you computer xp device manager for the correct driver installation.

2-the battery charger is not set to "PC LINK". you must enable this setting you self. check you battery charger manual program flow chart page 10 in the paper manual or page 12 in the PDF manual. however is in the setting where you change the temperature sensor cut off temperature setting.

3-the PC LINK is connected in the wrong port, you can use only the temp sensor port for the battery charger # 1 & 2.

Best Regards Tito
tune by tito is offline Find More Posts by tune by tito
Reply With Quote
Old Mar 20, 2012, 07:15 PM
Registered User
massachusetts, usa
Joined Dec 2010
32 Posts
thanks tito,
so, i did get it to work. you can see below my trouble after tito helped me.
here's what happen: while looking at the device manager, i saw that plugging in the hitec adaptr didnt install right. i had a device installer window open , it wanted to install the usb flash driver, as you can see that in device manager as well. when i closed that window, another "driver installer' window appeared asking if i wanted to install the cp21x driver, i clicked yes. after that the cp21x appear in the correct location in device manager. i plugged it into the X4 charger and am now watching a battery charger on screen.

i have to say, "where are all these instructions from hitec" when i bought the adapter, it came in a plastice bag, no paperwork whatsoever. maybe the instructions are included in the new models, if so, an oversight by hitec. a service bulliten would of been nice in this instance.
i am not overly impressed with the documentation hitec provides with it products, but rather unimpressed. thanks to tito, i can now use my purchase. thank you tito


posted before i got this thing to work:
im still not sure if im doing it correctly. here's what ive done, i dont think its right.
uninstall any cp21 drivers
installed CP210x USB to UART Bridge VCP Drivers from silabs site
http://www.silabs.com/products/mcu/P...CPDrivers.aspx
i plugged the hitec usb adapter in and i get this in the device manager(see pict)
you can see that win is still wanting to install a usb flash drive driver, not sure why.
the uart installer said i have a conflicting driver on the install, (1201) so i had it uninstall it.
i have no usb devices plugged in while doing all this

if the above driver i got from silab's site is not the right one, could you point me to the correct one? appreciate it!
bradp015 is offline Find More Posts by bradp015
Last edited by bradp015; Mar 20, 2012 at 07:31 PM.
Reply With Quote
Old Mar 25, 2012, 10:20 PM
Inventor&Genius Extraordinary
tune by tito's Avatar
USA, CA, Riverside
Joined May 2006
491 Posts
You are welcome, I will look into the memory device problem, this can be that the battery charger enumerate as a Cp210x bridge and memory device. I do know that the battery charger can record battery charging event for viewing another time after racing or charging batteries. Also could be the driver in windows.
1- first remove the driver from window XP WHILE the CP210x is connected to the computer.
2-Disconnect the CP210x Device from the computer, make sure no other Silicon lab software is installed if you only are using the CP210x device. This device is use by Silicon Labs for most of the Development tool for the 8051 and new 32 bits micro-controller, so if you use silicon Lab IDE you must disable the drivers.

3-Download the new drivers from Silicon Labs and install them WITHOUT connecting the Cp210x device to the computer. After you install the driver then you can connect the Cp210x device to the computer. make sure every thing work as intended.
Best Regards Tito
tune by tito is offline Find More Posts by tune by tito
Reply With Quote
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Sold Castle Creations Castle Link USB adapter -= GYRO =- Aircraft - Electric - Power Systems (FS/W) 2 Feb 29, 2012 07:22 PM
Sold BeastX V3.08 and USB Updater and Satellite Adapter Andyzboy Aircraft - Electric - Helis (FS/W) 1 Feb 29, 2012 06:22 PM
Sold NEW CC Ice 75 Lite ESC + Castle Link USB Adapter -= GYRO =- Aircraft - Electric - Power Systems (FS/W) 4 Feb 29, 2012 10:23 AM
Help! Is this Safe Question on USB Wall Charger & SYMA S-107 USB Charger Turk_WLF Coaxial Helicopters 1 Feb 16, 2012 03:02 PM
For Sale Hyperion Adapter Harness and USB Adapter mwhitman Aircraft - Electric - Batteries & Chargers (FS/W) 0 Oct 17, 2011 04:50 PM