HobbyKing.com New Products Flash Sale
Reply
Thread Tools
Old Mar 15, 2012, 12:15 AM
Crash and Burn
lawlist's Avatar
Joined Sep 2011
678 Posts
Discussion
Do batteries go bad to the point of an "open circuit" error?

I have a battery that is 30C 11.1v 850mAh that keeps causing the Triton2EQ charger to read "open circuit", which is the same message I get when I forget to attach the lead from the battery to the charger. Is it possible that the batteries themselves have gone bad, or is my problem almost certainly a bad lead or broken wire (e.g., 99.9 percent probability)? The charger is working correctly with other batteries of the same make / model.
lawlist is offline Find More Posts by lawlist
Reply With Quote
Sign up now
to remove ads between posts
Old Mar 15, 2012, 02:10 AM
Crash and learn
United States, PA
Joined Dec 2011
1,605 Posts
I'd try a lower current setting to see if it makes a difference. Different batteries should help isolate the problem.

If it is the battery, it likely will do the same while flying. Listen closely for motor changes.
Ribble is offline Find More Posts by Ribble
Reply With Quote
Old Mar 15, 2012, 02:12 AM
Fly Runaway Fans
United States, TX, Fort Worth
Joined Jan 2009
9,387 Posts
When the battery resting voltage falls below the recoverable remnant charge for lipos (roughly 3.6V) the charger will not recognize the battery as chargeable.
arbilab is offline Find More Posts by arbilab
Reply With Quote
Old Mar 16, 2012, 10:57 AM
Crash and Burn
lawlist's Avatar
Joined Sep 2011
678 Posts
I switched the charger over to "discharge" at about 9 volts .9 amps for about 45 minutes, and then switched it back to charge and it charged for about 45 minutes. So the wires are good. I've got a few work-related projects today, but will make an effort to use the battery again soon. The fact that I was able to charge after discharging is a good sign.
lawlist is offline Find More Posts by lawlist
Reply With Quote
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Help! new pl8 v2 - bad cell count node wiring xh error.. help? ohsnap FMA Direct 13 Apr 05, 2012 05:23 PM
Help! Triton Jr. "Open Circuit" error AtomicPenguin Batteries and Chargers 13 Jan 08, 2012 10:20 AM
Question Do old transmitters go bad? Dvglas Radios 8 Dec 05, 2011 03:06 AM
Discussion Is there any open source Long Range RC transmitter Circuit? garik111 Radios 3 Dec 01, 2011 08:20 AM
Discussion 2 A123 cells go open circuit on charger? Why? snackboy Batteries and Chargers 14 Apr 18, 2007 11:57 AM